aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-06-18 15:29:26 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-06-18 15:39:42 +0000
commitbeb4adb31351f1ea43b1aa2e53a6213d16208ce7 (patch)
tree90dfcd71c532ae9c8303656c6e4f052fe418d0a1 /graphics
parentaeb2d6000af2536c0e7f8be228cc267cefe76a09 (diff)
downloadports-beb4adb31351f1ea43b1aa2e53a6213d16208ce7.tar.gz
ports-beb4adb31351f1ea43b1aa2e53a6213d16208ce7.zip
graphics/ImageMagick[6-7]: optionize the dependency on ffmpeg
- Make an option for FFMPEG, and do not enable it by default. - Do not bump PORTREVISION: pkg will take care of it, and ports users may rebuild it if needed. - Note: there is no simple way to deactivate this option when ffmpeg is already installed. PR: 256215 Reported by: Toshimichi Masubuchi (ImageMagick7) and gessel (6) Approved by: maintainer’s time-out
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick6/Makefile12
-rw-r--r--graphics/ImageMagick7/Makefile11
2 files changed, 17 insertions, 6 deletions
diff --git a/graphics/ImageMagick6/Makefile b/graphics/ImageMagick6/Makefile
index 704682077510..ea7516006de8 100644
--- a/graphics/ImageMagick6/Makefile
+++ b/graphics/ImageMagick6/Makefile
@@ -32,8 +32,7 @@ COMMENT= Image processing tools (legacy version)
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libltdl.so:devel/libltdl \
- libavutil.so:multimedia/ffmpeg
+LIB_DEPENDS= libltdl.so:devel/libltdl
TESTS_DEPENDS= gsfonts>=0:print/gsfonts
@@ -63,7 +62,7 @@ SAMPLE_FILES= coder.xml colors.xml delegates.xml log.xml magic.xml mime.xml \
PLIST_SUB= PORTVERSION=${PORTVERSION:R}
OPTIONS_SUB= yes
-OPTIONS_DEFINE= BZIP2 DOCS DJVU FFTW FONTCONFIG FPX FREETYPE \
+OPTIONS_DEFINE= BZIP2 DOCS DJVU FFMPEG FFTW FONTCONFIG FPX FREETYPE \
GRAPHVIZ GSLIB HEIF JPEG2000 JBIG JPEG LCMS2 LZMA LQR MODULES \
OPENEXR OPENMP PANGO PDF PERL PNG RAQM SVG TESTS TIFF WEBP WMF \
THREADS X11 16BIT_PIXEL HDRI RAW
@@ -87,6 +86,8 @@ PLIST_SUB+= QBIT=${_QBIT}
BZIP2_DESC= bzip2 compressed MIFF images
BZIP2_CONFIGURE_WITH= bzlib
+FFMPEG_DESC= Video CODEC support from FFmpeg
+
FFTW_CONFIGURE_WITH= fftw
FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
@@ -265,6 +266,11 @@ CONFIGURE_ARGS+= --without-djvu
PLIST_SUB+= DJVU="@comment "
.endif
+.if ${PORT_OPTIONS:MFFMPEG}
+BUILD_DEPENDS+= ffmpeg:multimedia/ffmpeg
+RUN_DEPENDS+= ffmpeg:multimedia/ffmpeg
+.endif
+
.if ${PORT_OPTIONS:MGSLIB}
CONFIGURE_ARGS+= --with-gslib
. if ${PORT_OPTIONS:MX11}
diff --git a/graphics/ImageMagick7/Makefile b/graphics/ImageMagick7/Makefile
index a30bef93ac11..4b138cc740d1 100644
--- a/graphics/ImageMagick7/Makefile
+++ b/graphics/ImageMagick7/Makefile
@@ -32,8 +32,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libltdl.so:devel/libltdl \
- libzip.so:archivers/libzip \
- libavutil.so:multimedia/ffmpeg
+ libzip.so:archivers/libzip
TESTS_DEPENDS= gsfonts>=0:print/gsfonts
@@ -62,7 +61,7 @@ SAMPLE_FILES= colors.xml delegates.xml log.xml mime.xml policy.xml \
PLIST_SUB= PORTVERSION=${PORTVERSION:R}
OPTIONS_SUB= yes
-OPTIONS_DEFINE= BZIP2 DOCS DJVU FFTW FONTCONFIG FPX FREETYPE \
+OPTIONS_DEFINE= BZIP2 DOCS DJVU FFMPEG FFTW FONTCONFIG FPX FREETYPE \
GRAPHVIZ GSLIB JPEG2000 JBIG JPEG LCMS2 LZMA LQR MODULES \
OPENEXR OPENMP PANGO PDF PERL PNG RAQM SVG TESTS TIFF WEBP WMF \
THREADS X11 16BIT_PIXEL HDRI HEIF RAW
@@ -72,6 +71,7 @@ OPTIONS_DEFAULT= 16BIT_PIXEL BZIP2 FFTW FONTCONFIG FREETYPE \
DJVU_DESC= DJVU format support (needs THREADS)
GSLIB_DESC= libgs (Postscript SHLIB) support
+FFMPEG_DESC= VIDEO codec support as FFmpeg
TESTS_DESC= Run bundled self-tests after build
#SIMD_CONFIGURE_WITH= gcc-arch
CONFIGURE_ARGS+= --without-gcc-arch
@@ -302,6 +302,11 @@ USES+= ghostscript
RUN_DEPENDS+= gsfonts>=0:print/gsfonts
.endif
+.if ${PORT_OPTIONS:MFFMPEG}
+BUILD_DEPENDS+= ffmpeg:multimedia/ffmpeg
+RUN_DEPENDS+= ffmpeg:multimedia/ffmpeg
+.endif
+
.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install-strip install-docDATA install-data-html
.else