aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-07-29 16:11:35 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-07-29 16:11:35 +0000
commitc0b7a3fc422ac9d0da75a9175506eb3344b45f00 (patch)
treee5770c3f31c107bfa39145cca477228cedde824c /graphics
parentda8a91bbd7e124e4dc7254dd9fd15fda020b233f (diff)
downloadports-c0b7a3fc422ac9d0da75a9175506eb3344b45f00.tar.gz
ports-c0b7a3fc422ac9d0da75a9175506eb3344b45f00.zip
Add patch from upstream that makes mate-desktop support optional. And
disable this for atril-lite. PR: 201967 Submitted by: Matthieu Volat <mazhe@alkumuna.eu>
Notes
Notes: svn path=/head/; revision=393164
Diffstat (limited to 'graphics')
-rw-r--r--graphics/atril-lite/Makefile2
-rw-r--r--graphics/atril/Makefile5
-rw-r--r--graphics/atril/files/configure.ac89
-rw-r--r--graphics/atril/files/patch-configure286
-rw-r--r--graphics/atril/files/patch-shell_ev-window.c39
5 files changed, 406 insertions, 15 deletions
diff --git a/graphics/atril-lite/Makefile b/graphics/atril-lite/Makefile
index cd4d4d976f2d..3113937895bb 100644
--- a/graphics/atril-lite/Makefile
+++ b/graphics/atril-lite/Makefile
@@ -1,7 +1,7 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
PKGNAMESUFFIX= -lite
COMMENT= MATE multi-format document viewer
diff --git a/graphics/atril/Makefile b/graphics/atril/Makefile
index 58949c1ab911..92715d832e58 100644
--- a/graphics/atril/Makefile
+++ b/graphics/atril/Makefile
@@ -23,7 +23,7 @@ SLAVEPORT?= no
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig tar:xz
-USE_MATE= desktop icontheme
+USE_MATE= icontheme
USE_XORG= sm
USE_GNOME= cairo gtk20 intlhack libxml2
USE_LDCONFIG= yes
@@ -37,7 +37,10 @@ INSTALL_TARGET= install-strip
.if ${SLAVEPORT} == lite
CONFIGURE_ARGS+=--disable-thumbnailer \
+ --without-matedesktop \
--disable-previewer
+.else
+USE_MATE+= desktop
.endif
GLIB_SCHEMAS= org.mate.Atril.gschema.xml
diff --git a/graphics/atril/files/configure.ac b/graphics/atril/files/configure.ac
index 5905b98e7dfd..631880d35ee7 100644
--- a/graphics/atril/files/configure.ac
+++ b/graphics/atril/files/configure.ac
@@ -1,5 +1,14 @@
---- configure.ac.orig 2015-07-28 09:49:21.172132000 +0200
-+++ configure.ac 2015-07-28 09:53:17.414002000 +0200
+--- configure.ac.orig 2015-07-29 15:31:05.000000000 +0200
++++ configure.ac 2015-07-29 15:31:25.000000000 +0200
+@@ -199,7 +199,7 @@
+ ;;
+ esac
+
+-PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS])
++PKG_CHECK_MODULES([SHELL_CORE],[libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS])
+
+ dnl
+ dnl zlib support
@@ -699,16 +699,16 @@
case "$with_gtk" in
2.0)
@@ -20,3 +29,79 @@
fi
;;
esac
+@@ -760,6 +760,23 @@
+
+ AC_CHECK_FUNC(localtime_r, AC_DEFINE(HAVE_LOCALTIME_R, 1, [Defines if localtime_r is available on your system]))
+
++# *********************
++# Mate-desktop support
++# *********************
++
++AC_ARG_WITH(matedesktop,
++ [AS_HELP_STRING([--without-matedesktop],
++ [Disable the use of matedesktop])],
++ [],
++ [with_matedesktop=yes])
++
++AM_CONDITIONAL([WITH_MATEDESKTOP],[test "$with_matedesktop" = "yes"])
++
++if test "$with_matedesktop" = "yes"; then
++ PKG_CHECK_MODULES([SHELL_CORE], mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED)
++ AC_DEFINE([WITH_MATEDESKTOP],[1],[Define if mate-desktop support is enabled])
++fi
++
+ # *****************
+ # Help files
+ # *****************
+@@ -929,27 +946,28 @@
+ echo "
+ Configure summary:
+
+- Platform...........: $with_platform
+- GTK+ version.......: $with_gtk
+- GTK+ Unix Print....: $with_gtk_unix_print
+- Keyring Support....: $with_keyring
+- DBUS Support.......: $enable_dbus
+- SM client support..: $with_smclient
+- Caja Plugin........: $enable_caja
+- Thumbnailer........: $enable_thumbnailer
+- Previewer..........: $enable_previewer
+- Gtk-Doc Support....: $enable_gtk_doc
+- Debug mode.........: $enable_debug
+- GObj. Introspection: $enable_introspection
+- Tests..............: $enable_tests
+-
+- PDF Backend........: $enable_pdf
+- PostScript Backend.: $enable_ps
+- TIFF Backend.......: $enable_tiff
+- DJVU Backend.......: $enable_djvu
+- DVI Backend........: $enable_dvi
+- Pixbuf Backend.....: $enable_pixbuf
+- Comics Backend.....: $enable_comics
+- XPS Backend........: $enable_xps
+- ePub Backend.......: $have_webkit
++ Platform............: $with_platform
++ GTK+ version........: $with_gtk
++ GTK+ Unix Print.....: $with_gtk_unix_print
++ MATE desktop Support: $with_matedesktop
++ Keyring Support.....: $with_keyring
++ DBUS Support........: $enable_dbus
++ SM client support...: $with_smclient
++ Caja Plugin.........: $enable_caja
++ Thumbnailer.........: $enable_thumbnailer
++ Previewer...........: $enable_previewer
++ Gtk-Doc Support.....: $enable_gtk_doc
++ Debug mode..........: $enable_debug
++ GObj. Introspection.: $enable_introspection
++ Tests...............: $enable_tests
++
++ PDF Backend.........: $enable_pdf
++ PostScript Backend..: $enable_ps
++ TIFF Backend........: $enable_tiff
++ DJVU Backend........: $enable_djvu
++ DVI Backend.........: $enable_dvi
++ Pixbuf Backend......: $enable_pixbuf
++ Comics Backend......: $enable_comics
++ XPS Backend.........: $enable_xps
++ ePub Backend........: $have_webkit
+ "
diff --git a/graphics/atril/files/patch-configure b/graphics/atril/files/patch-configure
index c1f731107149..765eff491454 100644
--- a/graphics/atril/files/patch-configure
+++ b/graphics/atril/files/patch-configure
@@ -1,6 +1,81 @@
---- configure.orig 2015-07-28 09:49:10.059868000 +0200
-+++ configure 2015-07-28 09:53:49.981847000 +0200
-@@ -22224,14 +22224,14 @@
+--- configure.orig 2015-07-13 16:08:54.000000000 +0200
++++ configure 2015-07-29 15:33:13.000000000 +0200
+@@ -674,6 +674,8 @@
+ HELP_DIR
+ YELP_LC_DIST
+ YELP_LC_MEDIA_LINKS
++WITH_MATEDESKTOP_FALSE
++WITH_MATEDESKTOP_TRUE
+ ATRIL_MIME_TYPES
+ ENABLE_EPUB_FALSE
+ ENABLE_EPUB_TRUE
+@@ -1006,6 +1008,7 @@
+ enable_comics
+ enable_xps
+ enable_epub
++with_matedesktop
+ with_help_dir
+ with_html_dir
+ enable_gtk_doc
+@@ -1757,6 +1760,7 @@
+ --without-gtk-unix-print
+ Disable the use of gtk-unix-print
+ --without-keyring Disable the use of libsecret and keyring
++ --without-matedesktop Disable the use of matedesktop
+ --with-help-dir=DIR path where help files are installed
+ --with-html-dir=PATH path to installed docs
+
+@@ -20038,12 +20042,12 @@
+ pkg_cv_SHELL_CORE_CFLAGS="$SHELL_CORE_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libxml-2.0 >= \$LIBXML_REQUIRED gtk+-\$GTK_API_VERSION >= \$GTK_REQUIRED gio-2.0 >= \$GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= \$MATEDESKTOP_REQUIRED \$SHELL_PLATFORM_PKGS\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libxml-2.0 >= \$LIBXML_REQUIRED gtk+-\$GTK_API_VERSION >= \$GTK_REQUIRED gio-2.0 >= \$GLIB_REQUIRED gthread-2.0 \$SHELL_PLATFORM_PKGS\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_SHELL_CORE_CFLAGS=`$PKG_CONFIG --cflags "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS" 2>/dev/null`
++ pkg_cv_SHELL_CORE_CFLAGS=`$PKG_CONFIG --cflags "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -20055,12 +20059,12 @@
+ pkg_cv_SHELL_CORE_LIBS="$SHELL_CORE_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libxml-2.0 >= \$LIBXML_REQUIRED gtk+-\$GTK_API_VERSION >= \$GTK_REQUIRED gio-2.0 >= \$GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= \$MATEDESKTOP_REQUIRED \$SHELL_PLATFORM_PKGS\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libxml-2.0 >= \$LIBXML_REQUIRED gtk+-\$GTK_API_VERSION >= \$GTK_REQUIRED gio-2.0 >= \$GLIB_REQUIRED gthread-2.0 \$SHELL_PLATFORM_PKGS\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_SHELL_CORE_LIBS=`$PKG_CONFIG --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS" 2>/dev/null`
++ pkg_cv_SHELL_CORE_LIBS=`$PKG_CONFIG --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -20081,14 +20085,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS" 2>&1`
++ SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS" 2>&1`
+ else
+- SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS" 2>&1`
++ SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$SHELL_CORE_PKG_ERRORS" >&5
+
+- as_fn_error $? "Package requirements (libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED $SHELL_PLATFORM_PKGS) were not met:
++ as_fn_error $? "Package requirements (libxml-2.0 >= $LIBXML_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED gio-2.0 >= $GLIB_REQUIRED gthread-2.0 $SHELL_PLATFORM_PKGS) were not met:
+
+ $SHELL_CORE_PKG_ERRORS
+
+@@ -22453,14 +22457,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -18,7 +93,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22244,14 +22244,14 @@
+@@ -22473,14 +22477,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -36,7 +111,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22273,10 +22273,10 @@
+@@ -22502,10 +22506,10 @@
fi
if test $_pkg_short_errors_supported = yes; then
EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
@@ -49,7 +124,7 @@
fi
# Put the nasty error message in config.log where it belongs
echo "$EPUB_PKG_ERRORS" >&5
-@@ -22305,14 +22305,14 @@
+@@ -22534,14 +22538,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -67,7 +142,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22325,14 +22325,14 @@
+@@ -22554,14 +22558,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -85,7 +160,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22354,10 +22354,10 @@
+@@ -22583,10 +22587,10 @@
fi
if test $_pkg_short_errors_supported = yes; then
EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
@@ -98,7 +173,7 @@
fi
# Put the nasty error message in config.log where it belongs
echo "$EPUB_PKG_ERRORS" >&5
-@@ -22388,14 +22388,14 @@
+@@ -22617,14 +22621,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -116,7 +191,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22408,14 +22408,14 @@
+@@ -22637,14 +22641,14 @@
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"webkit2gtk-\$WEBKIT_API_VERSION >= \$WEBKIT_REQUIRED \\
@@ -134,7 +209,7 @@
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
-@@ -22437,10 +22437,10 @@
+@@ -22666,10 +22670,10 @@
fi
if test $_pkg_short_errors_supported = yes; then
EPUB_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "webkit2gtk-$WEBKIT_API_VERSION >= $WEBKIT_REQUIRED \
@@ -147,3 +222,192 @@
fi
# Put the nasty error message in config.log where it belongs
echo "$EPUB_PKG_ERRORS" >&5
+@@ -22751,6 +22755,125 @@
+ fi
+
+
++# *********************
++# Mate-desktop support
++# *********************
++
++
++# Check whether --with-matedesktop was given.
++if test "${with_matedesktop+set}" = set; then :
++ withval=$with_matedesktop;
++else
++ with_matedesktop=yes
++fi
++
++
++ if test "$with_matedesktop" = "yes"; then
++ WITH_MATEDESKTOP_TRUE=
++ WITH_MATEDESKTOP_FALSE='#'
++else
++ WITH_MATEDESKTOP_TRUE='#'
++ WITH_MATEDESKTOP_FALSE=
++fi
++
++
++if test "$with_matedesktop" = "yes"; then
++
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for SHELL_CORE" >&5
++$as_echo_n "checking for SHELL_CORE... " >&6; }
++
++if test -n "$SHELL_CORE_CFLAGS"; then
++ pkg_cv_SHELL_CORE_CFLAGS="$SHELL_CORE_CFLAGS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"mate-desktop-2.0 >= \$MATEDESKTOP_REQUIRED\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_SHELL_CORE_CFLAGS=`$PKG_CONFIG --cflags "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++if test -n "$SHELL_CORE_LIBS"; then
++ pkg_cv_SHELL_CORE_LIBS="$SHELL_CORE_LIBS"
++ elif test -n "$PKG_CONFIG"; then
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"mate-desktop-2.0 >= \$MATEDESKTOP_REQUIRED\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_SHELL_CORE_LIBS=`$PKG_CONFIG --libs "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED" 2>/dev/null`
++ test "x$?" != "x0" && pkg_failed=yes
++else
++ pkg_failed=yes
++fi
++ else
++ pkg_failed=untried
++fi
++
++
++
++if test $pkg_failed = yes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED" 2>&1`
++ else
++ SHELL_CORE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED" 2>&1`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$SHELL_CORE_PKG_ERRORS" >&5
++
++ as_fn_error $? "Package requirements (mate-desktop-2.0 >= $MATEDESKTOP_REQUIRED) were not met:
++
++$SHELL_CORE_PKG_ERRORS
++
++Consider adjusting the PKG_CONFIG_PATH environment variable if you
++installed software in a non-standard prefix.
++
++Alternatively, you may set the environment variables SHELL_CORE_CFLAGS
++and SHELL_CORE_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details." "$LINENO" 5
++elif test $pkg_failed = untried; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
++$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
++as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
++is in your PATH or set the PKG_CONFIG environment variable to the full
++path to pkg-config.
++
++Alternatively, you may set the environment variables SHELL_CORE_CFLAGS
++and SHELL_CORE_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.
++See \`config.log' for more details" "$LINENO" 5; }
++else
++ SHELL_CORE_CFLAGS=$pkg_cv_SHELL_CORE_CFLAGS
++ SHELL_CORE_LIBS=$pkg_cv_SHELL_CORE_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++
++fi
++
++$as_echo "#define WITH_MATEDESKTOP 1" >>confdefs.h
++
++fi
++
+ # *****************
+ # Help files
+ # *****************
+@@ -23716,6 +23839,10 @@
+ as_fn_error $? "conditional \"ENABLE_EPUB\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
+ fi
++if test -z "${WITH_MATEDESKTOP_TRUE}" && test -z "${WITH_MATEDESKTOP_FALSE}"; then
++ as_fn_error $? "conditional \"WITH_MATEDESKTOP\" was never defined.
++Usually this means the macro was only invoked conditionally." "$LINENO" 5
++fi
+ if test -z "${HAVE_GTK_DOC_TRUE}" && test -z "${HAVE_GTK_DOC_FALSE}"; then
+ as_fn_error $? "conditional \"HAVE_GTK_DOC\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
+@@ -26300,27 +26427,28 @@
+ echo "
+ Configure summary:
+
+- Platform...........: $with_platform
+- GTK+ version.......: $with_gtk
+- GTK+ Unix Print....: $with_gtk_unix_print
+- Keyring Support....: $with_keyring
+- DBUS Support.......: $enable_dbus
+- SM client support..: $with_smclient
+- Caja Plugin........: $enable_caja
+- Thumbnailer........: $enable_thumbnailer
+- Previewer..........: $enable_previewer
+- Gtk-Doc Support....: $enable_gtk_doc
+- Debug mode.........: $enable_debug
+- GObj. Introspection: $enable_introspection
+- Tests..............: $enable_tests
+-
+- PDF Backend........: $enable_pdf
+- PostScript Backend.: $enable_ps
+- TIFF Backend.......: $enable_tiff
+- DJVU Backend.......: $enable_djvu
+- DVI Backend........: $enable_dvi
+- Pixbuf Backend.....: $enable_pixbuf
+- Comics Backend.....: $enable_comics
+- XPS Backend........: $enable_xps
+- ePub Backend.......: $have_webkit
++ Platform............: $with_platform
++ GTK+ version........: $with_gtk
++ GTK+ Unix Print.....: $with_gtk_unix_print
++ MATE desktop Support: $with_matedesktop
++ Keyring Support.....: $with_keyring
++ DBUS Support........: $enable_dbus
++ SM client support...: $with_smclient
++ Caja Plugin.........: $enable_caja
++ Thumbnailer.........: $enable_thumbnailer
++ Previewer...........: $enable_previewer
++ Gtk-Doc Support.....: $enable_gtk_doc
++ Debug mode..........: $enable_debug
++ GObj. Introspection.: $enable_introspection
++ Tests...............: $enable_tests
++
++ PDF Backend.........: $enable_pdf
++ PostScript Backend..: $enable_ps
++ TIFF Backend........: $enable_tiff
++ DJVU Backend........: $enable_djvu
++ DVI Backend.........: $enable_dvi
++ Pixbuf Backend......: $enable_pixbuf
++ Comics Backend......: $enable_comics
++ XPS Backend.........: $enable_xps
++ ePub Backend........: $have_webkit
+ "
diff --git a/graphics/atril/files/patch-shell_ev-window.c b/graphics/atril/files/patch-shell_ev-window.c
new file mode 100644
index 000000000000..6a8f6cfa7b6b
--- /dev/null
+++ b/graphics/atril/files/patch-shell_ev-window.c
@@ -0,0 +1,39 @@
+--- shell/ev-window.c.orig 2015-07-10 12:46:39.000000000 +0200
++++ shell/ev-window.c 2015-07-29 15:31:25.000000000 +0200
+@@ -41,8 +41,10 @@
+ #include <gio/gio.h>
+ #include <gtk/gtk.h>
+
++#ifdef WITH_MATEDESKTOP
+ #include <libmate-desktop/mate-aboutdialog.h>
+ #include <libmate-desktop/mate-gsettings.h>
++#endif
+
+ #include "egg-editable-toolbar.h"
+ #include "egg-toolbar-editor.h"
+@@ -1501,7 +1503,13 @@
+ ev_window);
+ }
+
++#ifdef WITH_MATEDESKTOP
+ if (mate_gsettings_schema_exists (MATE_LOCKDOWN_SCHEMA)) {
++#else
++ GSettingsSchema *schema_mate_lockdown_schema = g_settings_schema_source_lookup (g_settings_schema_source_get_default(), MATE_LOCKDOWN_SCHEMA, FALSE);
++ if (schema_mate_lockdown_schema != NULL) {
++ g_settings_schema_unref (schema_mate_lockdown_schema);
++#endif
+ if (!ev_window->priv->lockdown_settings)
+ ev_window->priv->lockdown_settings = g_settings_new (MATE_LOCKDOWN_SCHEMA);
+ g_signal_connect (ev_window->priv->lockdown_settings,
+@@ -5053,7 +5061,11 @@
+
+ comments = build_comments_string (ev_window->priv->document);
+
++#ifdef WITH_MATEDESKTOP
+ mate_show_about_dialog (
++#else
++ gtk_show_about_dialog (
++#endif
+ GTK_WINDOW (ev_window),
+ "name", _("Atril"),
+ "version", VERSION,