aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-15 19:24:51 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-15 19:24:51 +0000
commitc6ffeeb6e35dd358910aeca820e48cd85b38bda7 (patch)
tree6de41b51648f82430dcf0eca0b5edfb5b8db35ec /graphics
parentd55f214d30bfbde66dc3bb3827857c644f315825 (diff)
downloadports-c6ffeeb6e35dd358910aeca820e48cd85b38bda7.tar.gz
ports-c6ffeeb6e35dd358910aeca820e48cd85b38bda7.zip
Toyplot is a kid-sized plotting toolkit for Python with grownup-sized goals:
* Develop beautiful interactive, animated plots that embrace the unique capabilities of electronic publishing and support repoducibility. * Create the best possible data graphics out-of-the-box, maximizing data ink and minimizing chartjunk. * Provide a clean, minimalist interface that scientists and engineers will love. WWW: https://pypi.python.org/pypi/toyplot
Notes
Notes: svn path=/head/; revision=392201
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-toyplot/Makefile22
-rw-r--r--graphics/py-toyplot/distinfo2
-rw-r--r--graphics/py-toyplot/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 68659aade904..c6bf48a84b50 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -860,6 +860,7 @@
SUBDIR += py-sorl-thumbnail
SUBDIR += py-soya3d
SUBDIR += py-stltools
+ SUBDIR += py-toyplot
SUBDIR += py-wand
SUBDIR += py-webcolors
SUBDIR += py3-cairo
diff --git a/graphics/py-toyplot/Makefile b/graphics/py-toyplot/Makefile
new file mode 100644
index 000000000000..148b59ae0314
--- /dev/null
+++ b/graphics/py-toyplot/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= toyplot
+PORTVERSION= 0.6.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Modern plotting toolkit supporting electronic publishing
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.7:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}colormath>=2.1.1:${PORTSDIR}/math/py-colormath \
+ ${PYTHON_PKGNAMEPREFIX}multipledispatch>=0.4.7:${PORTSDIR}/devel/py-multipledispatch
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-toyplot/distinfo b/graphics/py-toyplot/distinfo
new file mode 100644
index 000000000000..223aa5db3024
--- /dev/null
+++ b/graphics/py-toyplot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (toyplot-0.6.0.tar.gz) = e7e562f9c202c84d52f9be9f23568f9938f8e0334e15637c964e14f7f82bf6f9
+SIZE (toyplot-0.6.0.tar.gz) = 68113
diff --git a/graphics/py-toyplot/pkg-descr b/graphics/py-toyplot/pkg-descr
new file mode 100644
index 000000000000..e278ee8527f9
--- /dev/null
+++ b/graphics/py-toyplot/pkg-descr
@@ -0,0 +1,10 @@
+Toyplot is a kid-sized plotting toolkit for Python with grownup-sized goals:
+
+* Develop beautiful interactive, animated plots that embrace the unique
+ capabilities of electronic publishing and support repoducibility.
+* Create the best possible data graphics out-of-the-box, maximizing data ink
+ and minimizing chartjunk.
+* Provide a clean, minimalist interface that scientists and engineers will
+ love.
+
+WWW: https://pypi.python.org/pypi/toyplot