aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-01-25 03:17:39 +0000
committerWen Heping <wen@FreeBSD.org>2024-01-25 03:19:13 +0000
commitcea6be3b48fa041c65b505f8383f86bfb15b6ad1 (patch)
treeb7b1e83b92410684b9d6e3f1cbd22a0e61d0b9d2 /graphics
parent476ef99027494c187c7aad6eb8b4b863cd57a039 (diff)
downloadports-cea6be3b48fa041c65b505f8383f86bfb15b6ad1.tar.gz
ports-cea6be3b48fa041c65b505f8383f86bfb15b6ad1.zip
graphics/mypaint: Fix build with python-3.11
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mypaint/files/patch-setup.py11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/mypaint/files/patch-setup.py b/graphics/mypaint/files/patch-setup.py
index 7b72a37085a4..b27b0ea541c6 100644
--- a/graphics/mypaint/files/patch-setup.py
+++ b/graphics/mypaint/files/patch-setup.py
@@ -1,5 +1,14 @@
---- setup.py.orig 2022-01-09 11:24:00 UTC
+--- setup.py.orig 2020-05-29 15:18:55 UTC
+++ setup.py
+@@ -632,7 +632,7 @@ class InstallScripts (install_scripts):
+ self.announce("installing %s as %s" % (src, targ_basename), level=2)
+ if self.dry_run:
+ return []
+- with open(src, "rU") as in_fp:
++ with open(src, "r") as in_fp:
+ with open(targ, "w") as out_fp:
+ line = in_fp.readline().rstrip()
+ if line.startswith("#!"):
@@ -867,7 +867,6 @@ def get_ext_modules():
'-Wall',
'-Wno-sign-compare',