aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEvgeniy Khramtsov <evgeniy@khramtsov.org>2021-05-28 11:06:00 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-18 19:27:50 +0000
commitd5717160159d93ebdf46742459c68c3e94ca3289 (patch)
tree06a53c540e541e5f3f3bab14cbc53346c0871000 /graphics
parentf5536c9ffda14d1e472154afef38a721f19f3263 (diff)
downloadports-d5717160159d93ebdf46742459c68c3e94ca3289.tar.gz
ports-d5717160159d93ebdf46742459c68c3e94ca3289.zip
graphics/cairo: unbreak without X11 after dbca720cdec9
gl-device-release.c:33:8: error: unknown type name 'Window' static Window ^ gl-device-release.c:34:21: error: unknown type name 'Display' create_test_window (Display *display, ^ gl-device-release.c:35:7: error: unknown type name 'GLXContext'; did you mean 'EGLContext'? GLXContext glx_context, ^~~~~~~~~~ EGLContext /usr/local/include/EGL/egl.h:64:15: note: 'EGLContext' declared here typedef void *EGLContext; ^ gl-device-release.c:36:7: error: unknown type name 'XVisualInfo' XVisualInfo *visual_info) ^ gl-oversized-surface.c:38:2: error: use of undeclared identifier 'GLX_RGBA' GLX_RGBA, ^ gl-oversized-surface.c:39:2: error: use of undeclared identifier 'GLX_RED_SIZE' GLX_RED_SIZE, 1, ^ gl-oversized-surface.c:40:2: error: use of undeclared identifier 'GLX_GREEN_SIZE' GLX_GREEN_SIZE, 1, ^ gl-oversized-surface.c:41:2: error: use of undeclared identifier 'GLX_BLUE_SIZE' GLX_BLUE_SIZE, 1, ^ gl-oversized-surface.c:42:2: error: use of undeclared identifier 'GLX_ALPHA_SIZE' GLX_ALPHA_SIZE, 1, ^ gl-surface-source.c:33:5: error: unknown type name 'Display' Display *dpy; ^ gl-surface-source.c:34:5: error: unknown type name 'GLXContext'; did you mean 'EGLContext'? GLXContext ctx; ^~~~~~~~~~ EGLContext /usr/local/include/EGL/egl.h:64:15: note: 'EGLContext' declared here typedef void *EGLContext; ^ gl-surface-source.c:42:5: error: implicit declaration of function 'glXDestroyContext' is invalid in C99 [-Werror,-Wimplicit-function-declaration] glXDestroyContext (arg->dpy, arg->ctx); ^ gl-surface-source.c:42:5: note: did you mean 'eglDestroyContext'? /usr/local/include/EGL/egl.h:156:31: note: 'eglDestroyContext' declared here EGLAPI EGLBoolean EGLAPIENTRY eglDestroyContext (EGLDisplay dpy, EGLContext ctx); ^ gl-surface-source.c:43:5: error: implicit declaration of function 'XCloseDisplay' is invalid in C99 [-Werror,-Wimplicit-function-declaration] XCloseDisplay (arg->dpy); ^ gl-device-release.c:38:5: error: use of undeclared identifier 'Colormap' Colormap colormap; ^ gl-device-release.c:39:5: error: use of undeclared identifier 'XSetWindowAttributes' XSetWindowAttributes window_attributes; ^ gl-device-release.c:40:5: error: use of undeclared identifier 'Window' Window window = None; ^ gl-device-release.c:42:5: error: use of undeclared identifier 'colormap' colormap = XCreateColormap (display, ^ gl-device-release.c:42:16: error: implicit declaration of function 'XCreateColormap' is invalid in C99 [-Werror,-Wimplicit-function-declaration] colormap = XCreateColormap (display, ^ gl-device-release.c:43:8: error: implicit declaration of function 'RootWindow' is invalid in C99 [-Werror,-Wimplicit-function-declaration] RootWindow (display, visual_info->screen), ^ gl-device-release.c:45:8: error: use of undeclared identifier 'AllocNone' AllocNone); ^ gl-oversized-surface.c:43:2: error: use of undeclared identifier 'GLX_DOUBLEBUFFER' GLX_DOUBLEBUFFER, ^ gl-oversized-surface.c:44:2: error: use of undeclared identifier 'None' None ^ gl-oversized-surface.c:47:5: error: use of undeclared identifier 'Display' Display *display; ^ gl-oversized-surface.c:47:14: error: use of undeclared identifier 'display' Display *display; ^ gl-oversized-surface.c:48:5: error: use of undeclared identifier 'XVisualInfo' XVisualInfo *visual_info; ^ gl-oversized-surface.c:48:18: error: use of undeclared identifier 'visual_info' XVisualInfo *visual_info; ^ gl-oversized-surface.c:49:5: error: unknown type name 'GLXContext'; did you mean 'EGLContext'? GLXContext glx_context; ^~~~~~~~~~ EGLContext /usr/local/include/EGL/egl.h:64:15: note: 'EGLContext' declared here typedef void *EGLContext; ^ gl-oversized-surface.c:54:5: error: use of undeclared identifier 'display' display = XOpenDisplay (NULL); ^ gl-surface-source.c:52:2: error: use of undeclared identifier 'GLX_RGBA' GLX_RGBA, ^ gl-surface-source.c:53:2: error: use of undeclared identifier 'GLX_RED_SIZE' GLX_RED_SIZE, 1, ^ gl-surface-source.c:54:2: error: use of undeclared identifier 'GLX_GREEN_SIZE' GLX_GREEN_SIZE, 1, ^ gl-surface-source.c:55:2: error: use of undeclared identifier 'GLX_BLUE_SIZE' GLX_BLUE_SIZE, 1, ^ gl-surface-source.c:56:2: error: use of undeclared identifier 'GLX_ALPHA_SIZE' GLX_ALPHA_SIZE, 1, ^ gl-surface-source.c:57:2: error: use of undeclared identifier 'GLX_DOUBLEBUFFER' GLX_DOUBLEBUFFER, ^ gl-surface-source.c:58:2: error: use of undeclared identifier 'None' None ^ gl-surface-source.c:60:5: error: use of undeclared identifier 'XVisualInfo' XVisualInfo *visinfo; ^ gl-surface-source.c:60:18: error: use of undeclared identifier 'visinfo' XVisualInfo *visinfo; ^ gl-device-release.c:46:5: error: use of undeclared identifier 'window_attributes' window_attributes.colormap = colormap; ^ gl-device-release.c:46:34: error: use of undeclared identifier 'colormap' window_attributes.colormap = colormap; ^ gl-device-release.c:47:5: error: use of undeclared identifier 'window_attributes' window_attributes.border_pixel = 0; ^ gl-device-release.c:48:5: error: use of undeclared identifier 'window' window = XCreateWindow (display, RootWindow (display, visual_info->screen), ^ gl-device-release.c:48:14: error: implicit declaration of function 'XCreateWindow' is invalid in C99 [-Werror,-Wimplicit-function-declaration] window = XCreateWindow (display, RootWindow (display, visual_info->screen), ^ gl-oversized-surface.c:54:15: error: implicit declaration of function 'XOpenDisplay' is invalid in C99 [-Werror,-Wimplicit-function-declaration] display = XOpenDisplay (NULL); ^ gl-oversized-surface.c:55:9: error: use of undeclared identifier 'display' if (display == NULL) ^ gl-oversized-surface.c:58:5: error: use of undeclared identifier 'visual_info' visual_info = glXChooseVisual (display, DefaultScreen (display), rgba_attribs); ^ gl-oversized-surface.c:58:19: error: implicit declaration of function 'glXChooseVisual' is invalid in C99 [-Werror,-Wimplicit-function-declaration] visual_info = glXChooseVisual (display, DefaultScreen (display), rgba_attribs); ^ gl-oversized-surface.c:58:45: error: implicit declaration of function 'DefaultScreen' is invalid in C99 [-Werror,-Wimplicit-function-declaration] visual_info = glXChooseVisual (display, DefaultScreen (display), rgba_attribs); gl-surface-source.c:61:5: error: unknown type name 'GLXContext'; did you mean 'EGLContext'? GLXContext ctx; ^~~~~~~~~~ EGLContext /usr/local/include/EGL/egl.h:64:15: note: 'EGLContext' declared here typedef void *EGLContext; ^ gl-surface-source.c:65:5: error: use of undeclared identifier 'Display' Display *dpy; ^ gl-surface-source.c:65:14: error: use of undeclared identifier 'dpy' Display *dpy; ^ gl-surface-source.c:67:5: error: use of undeclared identifier 'dpy' dpy = XOpenDisplay (NULL); ^ gl-surface-source.c:67:11: error: implicit declaration of function 'XOpenDisplay' is invalid in C99 [-Werror,-Wimplicit-function-declaration] dpy = XOpenDisplay (NULL); ^ gl-surface-source.c:68:9: error: use of undeclared identifier 'dpy' if (dpy == NULL) ^ gl-oversized-surface.c:58:60: error: use of undeclared identifier 'display' visual_info = glXChooseVisual (display, DefaultScreen (display), rgba_attribs); ^ PR: 256180 Reported by: shrdlu19@gmail.com Approved by: maintainer timeout (3 weeks)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cairo/files/patch-test_Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/graphics/cairo/files/patch-test_Makefile.am b/graphics/cairo/files/patch-test_Makefile.am
new file mode 100644
index 000000000000..92c772be88b9
--- /dev/null
+++ b/graphics/cairo/files/patch-test_Makefile.am
@@ -0,0 +1,14 @@
+https://gitlab.freedesktop.org/cairo/cairo/-/issues/101
+
+--- test/Makefile.am.orig 2021-05-28 10:52:08 UTC
++++ test/Makefile.am
+@@ -18,7 +18,9 @@ endif
+ endif
+
+ if CAIRO_HAS_GL_SURFACE
++if CAIRO_HAS_GLX_FUNCTIONS
+ test_sources += $(gl_surface_test_sources)
++endif
+ endif
+
+ if CAIRO_HAS_EGL_FUNCTIONS