aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:28:35 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:28:35 +0000
commitd7597637f763ed1745719c6474ca7799cc9e6284 (patch)
tree8db052e4cf4bc47b10367352fc6d5a766d40e0f6 /graphics
parent2a30ca0747f27df51ca3a6748d2fa9ea17a6e847 (diff)
downloadports-d7597637f763ed1745719c6474ca7799cc9e6284.tar.gz
ports-d7597637f763ed1745719c6474ca7799cc9e6284.zip
[new port] graphics/p5-SVG-Graph
PR: ports/74379 Submitted by: Fernan Aguero <fernan(at)iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=122451
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-SVG-Graph/Makefile35
-rw-r--r--graphics/p5-SVG-Graph/distinfo2
-rw-r--r--graphics/p5-SVG-Graph/pkg-descr6
-rw-r--r--graphics/p5-SVG-Graph/pkg-plist27
5 files changed, 71 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bc96470f8318..9845e859204f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -338,6 +338,7 @@
SUBDIR += p5-Imager-Plot
SUBDIR += p5-Imlib2
SUBDIR += p5-OpenGL
+ SUBDIR += p5-SVG-Graph
SUBDIR += p5-SWF-Builder
SUBDIR += p5-SWF-File
SUBDIR += p5-Tk-JPEG-Lite
diff --git a/graphics/p5-SVG-Graph/Makefile b/graphics/p5-SVG-Graph/Makefile
new file mode 100644
index 000000000000..683fe12aabf5
--- /dev/null
+++ b/graphics/p5-SVG-Graph/Makefile
@@ -0,0 +1,35 @@
+# vim:ts=8
+# New ports collection makefile for: p5-SVG-Graph
+# Date created: 25 November 2004
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVG-Graph
+PORTVERSION= 0.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Visualize your data in Scalable Vector Graphics (SVG) format
+
+BUILD_DEPENDS= ${SITE_PERL}/SVG.pm:${PORTSDIR}/textproc/p5-SVG \
+ ${SITE_PERL}/Statistics/Descriptive.pm:${PORTSDIR}/math/p5-Statistics-Descriptive \
+ ${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node \
+ ${SITE_PERL}/Math/Spline.pm:${PORTSDIR}/math/p5-Math-Spline \
+ ${SITE_PERL}/Math/Derivative.pm:${PORTSDIR}/math/p5-Math-Derivative
+
+PERL_CONFIGURE= yes
+
+MAN3= SVG::Graph.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-SVG-Graph/distinfo b/graphics/p5-SVG-Graph/distinfo
new file mode 100644
index 000000000000..ca1d18f27028
--- /dev/null
+++ b/graphics/p5-SVG-Graph/distinfo
@@ -0,0 +1,2 @@
+MD5 (SVG-Graph-0.01.tar.gz) = 3fbf3ae9aa6ea33fd548e63dd926ee2b
+SIZE (SVG-Graph-0.01.tar.gz) = 88374
diff --git a/graphics/p5-SVG-Graph/pkg-descr b/graphics/p5-SVG-Graph/pkg-descr
new file mode 100644
index 000000000000..6dc35379ec44
--- /dev/null
+++ b/graphics/p5-SVG-Graph/pkg-descr
@@ -0,0 +1,6 @@
+SVG::Graph is a suite of perl modules for plotting data. SVG::Graph
+currently supports plots of one-, two- and three-dimensional data, as
+well as N-ary rooted trees.
+
+SVG::Graph 0.01 is a pre-alpha release. Keep in mind that many of the
+glyphs are not very robust.
diff --git a/graphics/p5-SVG-Graph/pkg-plist b/graphics/p5-SVG-Graph/pkg-plist
new file mode 100644
index 000000000000..68f1ee2da4c8
--- /dev/null
+++ b/graphics/p5-SVG-Graph/pkg-plist
@@ -0,0 +1,27 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVG/Graph/.packlist
+%%SITE_PERL%%/SVG/Frame.pm
+%%SITE_PERL%%/SVG/Graph.pm
+%%SITE_PERL%%/SVG/Graph/Data.pm
+%%SITE_PERL%%/SVG/Graph/Frame.pm
+%%SITE_PERL%%/SVG/Graph/File.pm
+%%SITE_PERL%%/SVG/Graph/Glyph.pm
+%%SITE_PERL%%/SVG/Graph/Data/Node.pm
+%%SITE_PERL%%/SVG/Graph/Data/Tree.pm
+%%SITE_PERL%%/SVG/Graph/Data/Datum.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/axis.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/bubble.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/bezier.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/pictogram.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/barflex.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/bar.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/wedge.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/line.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/tree.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/heatmap.pm
+%%SITE_PERL%%/SVG/Graph/Glyph/scatter.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVG/Graph
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVG 2>/dev/null || true
+@dirrm %%SITE_PERL%%/SVG/Graph/Data
+@dirrm %%SITE_PERL%%/SVG/Graph/Glyph
+@dirrm %%SITE_PERL%%/SVG/Graph
+@unexec rmdir %D/%%SITE_PERL%%/SVG 2>/dev/null || true