aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 07:36:08 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 07:36:08 +0000
commitde6064a1368a5d7986a0e050de996b468542c4ca (patch)
treed919f1417bee40e7925e263c123c9ffc05f63cd9 /graphics
parente88dd7a0da54b2f31e635c5da8988862de23ca13 (diff)
downloadports-de6064a1368a5d7986a0e050de996b468542c4ca.tar.gz
ports-de6064a1368a5d7986a0e050de996b468542c4ca.zip
graphics/sdl_ttf: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_ttf/Makefile2
-rw-r--r--graphics/sdl_ttf/files/patch-configure13
2 files changed, 15 insertions, 0 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 6f90b561aa6f..1f9ee82e1c1f 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -22,6 +22,8 @@ USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+BINARY_ALIAS= freetype-config=true
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont \
diff --git a/graphics/sdl_ttf/files/patch-configure b/graphics/sdl_ttf/files/patch-configure
new file mode 100644
index 000000000000..49511310b535
--- /dev/null
+++ b/graphics/sdl_ttf/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2021-08-07 07:33:50 UTC
++++ configure
+@@ -12642,8 +12642,8 @@ echo "$as_me: error:
+ " >&2;}
+ { (exit 1); exit 1; }; }
+ else
+- CFLAGS="$CFLAGS `$FREETYPE_CONFIG $freetypeconf_args --cflags`"
+- LIBS="$LIBS `$FREETYPE_CONFIG $freetypeconf_args --libs`"
++ CFLAGS="$CFLAGS `pkg-config freetype2 --cflags`"
++ LIBS="$LIBS `pkg-config freetype2 --libs`"
+ fi
+
+ SDL_VERSION=1.2.4