aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-08-27 10:08:10 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-08-27 10:08:10 +0000
commite3ac632d46d5bb4e0ee67fdfbabb40193c0360a9 (patch)
treeda79158fb701a043845c1dacf7e02a925712c59e /graphics
parent936c2a7968ebc36efb88d8def2958e2b9502bf1a (diff)
downloadports-e3ac632d46d5bb4e0ee67fdfbabb40193c0360a9.tar.gz
ports-e3ac632d46d5bb4e0ee67fdfbabb40193c0360a9.zip
Update to upstream version 2.8, pet portlint
PR: 221786 Submitted by: lbartoletti@tuxfamily.org (maintainer)
Notes
Notes: svn path=/head/; revision=448816
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osgearth/Makefile8
-rw-r--r--graphics/osgearth/distinfo6
-rw-r--r--graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp21
-rw-r--r--graphics/osgearth/pkg-plist150
4 files changed, 119 insertions, 66 deletions
diff --git a/graphics/osgearth/Makefile b/graphics/osgearth/Makefile
index 3ca5f74836f6..1619cb25be7b 100644
--- a/graphics/osgearth/Makefile
+++ b/graphics/osgearth/Makefile
@@ -2,26 +2,28 @@
# $FreeBSD$
PORTNAME= osgearth
-PORTVERSION= 2.7
+PORTVERSION= 2.8
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
CATEGORIES= graphics geography
MAINTAINER= lbartoletti@tuxfamily.org
COMMENT= C++ terrain rendering toolkit for OpenSceneGraph
LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= minizip:archivers/minizip
LIB_DEPENDS= libosg.so:graphics/osg \
libgdal.so:graphics/gdal \
libcurl.so:ftp/curl
+USES= cmake pkgconfig sqlite
+
USE_GITHUB= yes
GH_ACCOUNT= gwaldron
USE_LDCONFIG= yes
-USES= cmake pkgconfig sqlite
+USE_GL+= gl glu
PLIST_SUB= OSGVERSION=3.4.0
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=${LOCALBASE}/include \
diff --git a/graphics/osgearth/distinfo b/graphics/osgearth/distinfo
index c6469a132b18..1f58281ddf0d 100644
--- a/graphics/osgearth/distinfo
+++ b/graphics/osgearth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463133065
-SHA256 (gwaldron-osgearth-osgearth-2.7_GH0.tar.gz) = cf973b664aeb79f70e48f5cd02ba670069ec273d71fe541604ed5b328d956d83
-SIZE (gwaldron-osgearth-osgearth-2.7_GH0.tar.gz) = 61837911
+TIMESTAMP = 1503080754
+SHA256 (gwaldron-osgearth-osgearth-2.8_GH0.tar.gz) = 78120338ead2976018cc877e93342403bafe1b032f2f8b7de3915ba6c5c2486a
+SIZE (gwaldron-osgearth-osgearth-2.8_GH0.tar.gz) = 77472117
diff --git a/graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp b/graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp
deleted file mode 100644
index 8c31bb782626..000000000000
--- a/graphics/osgearth/files/patch-src_osgEarth_ThreadingUtils.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/osgEarth/ThreadingUtils.cpp.orig 2016-02-10 18:21:28 UTC
-+++ src/osgEarth/ThreadingUtils.cpp
-@@ -23,6 +23,7 @@
- #else
- # include <unistd.h>
- # include <sys/syscall.h>
-+# include <sys/thr.h>
- #endif
-
- using namespace osgEarth::Threading;
-@@ -40,6 +41,10 @@ unsigned osgEarth::Threading::getCurrent
- return ::syscall(SYS_thread_selfid);
- #elif __ANDROID__
- return gettid();
-+#elif __FreeBSD__
-+ long lwpid;
-+ thr_self(&lwpid);
-+ return lwpid;
- #else
- return (unsigned)::syscall(SYS_gettid);
- #endif
diff --git a/graphics/osgearth/pkg-plist b/graphics/osgearth/pkg-plist
index a50a56572750..67d2bfbf30ac 100644
--- a/graphics/osgearth/pkg-plist
+++ b/graphics/osgearth/pkg-plist
@@ -1,3 +1,4 @@
+bin/osgearth_3pv
bin/osgearth_annotation
bin/osgearth_atlas
bin/osgearth_backfill
@@ -8,10 +9,14 @@ bin/osgearth_city
bin/osgearth_clamp
bin/osgearth_clipplane
bin/osgearth_colorfilter
+bin/osgearth_computerangecallback
bin/osgearth_controls
bin/osgearth_conv
bin/osgearth_createtile
+bin/osgearth_datetime
+bin/osgearth_deformation
bin/osgearth_elevation
+bin/osgearth_ephemeris
bin/osgearth_featureeditor
bin/osgearth_featurefilter
bin/osgearth_featureinfo
@@ -19,6 +24,8 @@ bin/osgearth_featurequery
bin/osgearth_features
bin/osgearth_fog
bin/osgearth_graticule
+bin/osgearth_horizon
+bin/osgearth_http
bin/osgearth_imageoverlay
bin/osgearth_los
bin/osgearth_manip
@@ -29,11 +36,15 @@ bin/osgearth_mrt
bin/osgearth_occlusionculling
bin/osgearth_overlayviewer
bin/osgearth_package
+bin/osgearth_pagingtest
bin/osgearth_pick
bin/osgearth_sequencecontrol
bin/osgearth_shadercomp
bin/osgearth_shadergen
bin/osgearth_sharedlayer
+bin/osgearth_skyview
+bin/osgearth_splat
+bin/osgearth_srstest
bin/osgearth_terrainprofile
bin/osgearth_tfs
bin/osgearth_tileindex
@@ -43,6 +54,8 @@ bin/osgearth_tracks
bin/osgearth_transform
bin/osgearth_version
bin/osgearth_viewer
+bin/osgearth_wfs
+bin/osgearth_xfbtest
include/osgEarth/AlphaEffect
include/osgEarth/AutoScale
include/osgEarth/Bounds
@@ -62,17 +75,17 @@ include/osgEarth/Config
include/osgEarth/Containers
include/osgEarth/Cube
include/osgEarth/CullingUtils
-include/osgEarth/DPLineSegmentIntersector
include/osgEarth/DateTime
-include/osgEarth/Decluttering
+include/osgEarth/DateTimeRange
include/osgEarth/DepthOffset
+include/osgEarth/DPLineSegmentIntersector
include/osgEarth/DrapeableNode
+include/osgEarth/DrapingCullSet
include/osgEarth/DrapingTechnique
include/osgEarth/DrawInstanced
include/osgEarth/ECEF
-include/osgEarth/ElevationField
-include/osgEarth/ElevationLOD
include/osgEarth/ElevationLayer
+include/osgEarth/ElevationLOD
include/osgEarth/ElevationQuery
include/osgEarth/Export
include/osgEarth/Extension
@@ -80,18 +93,20 @@ include/osgEarth/FadeEffect
include/osgEarth/FileUtils
include/osgEarth/GeoCommon
include/osgEarth/GeoData
+include/osgEarth/Geoid
include/osgEarth/GeoMath
+include/osgEarth/GeometryClamper
include/osgEarth/GeoTransform
-include/osgEarth/Geoid
-include/osgEarth/HTTPClient
+include/osgEarth/GLSLChunker
include/osgEarth/HeightFieldUtils
include/osgEarth/Horizon
-include/osgEarth/IOTypes
+include/osgEarth/HTTPClient
include/osgEarth/ImageLayer
include/osgEarth/ImageMosaic
include/osgEarth/ImageToHeightFieldConverter
include/osgEarth/ImageUtils
include/osgEarth/IntersectionPicker
+include/osgEarth/IOTypes
include/osgEarth/JsonUtils
include/osgEarth/Layer
include/osgEarth/LineFunctor
@@ -110,12 +125,14 @@ include/osgEarth/MaskLayer
include/osgEarth/MaskNode
include/osgEarth/MaskSource
include/osgEarth/MemCache
+include/osgEarth/Memory
include/osgEarth/ModelLayer
include/osgEarth/ModelSource
include/osgEarth/NativeProgramAdapter
include/osgEarth/NodeUtils
include/osgEarth/Notify
include/osgEarth/ObjectIndex
+include/osgEarth/optional
include/osgEarth/OverlayDecorator
include/osgEarth/OverlayNode
include/osgEarth/PhongLightingEffect
@@ -124,52 +141,63 @@ include/osgEarth/PrimitiveIntersector
include/osgEarth/Profile
include/osgEarth/Profiler
include/osgEarth/Progress
+include/osgEarth/QuadTree
include/osgEarth/Random
include/osgEarth/Registry
+include/osgEarth/ResourceReleaser
include/osgEarth/Revisioning
+include/osgEarth/ScreenSpaceLayout
include/osgEarth/ShaderFactory
include/osgEarth/ShaderGenerator
include/osgEarth/ShaderLoader
-include/osgEarth/ShaderUtils
include/osgEarth/Shaders
+include/osgEarth/ShaderUtils
+include/osgEarth/Shadowing
include/osgEarth/SharedSARepo
include/osgEarth/SpatialReference
include/osgEarth/StateSetCache
include/osgEarth/StateSetLOD
+include/osgEarth/Status
include/osgEarth/StringUtils
include/osgEarth/TaskService
include/osgEarth/Terrain
include/osgEarth/TerrainEffect
include/osgEarth/TerrainEngineNode
+include/osgEarth/TerrainEngineRequirements
include/osgEarth/TerrainLayer
include/osgEarth/TerrainOptions
+include/osgEarth/TerrainTileModel
+include/osgEarth/TerrainTileModelFactory
include/osgEarth/TerrainTileNode
include/osgEarth/Tessellator
include/osgEarth/TextureCompositor
include/osgEarth/ThreadingUtils
include/osgEarth/TileHandler
include/osgEarth/TileKey
+include/osgEarth/TileKeyDataStore
+include/osgEarth/TilePatchCallback
include/osgEarth/TileSource
include/osgEarth/TileVisitor
include/osgEarth/TimeControl
+include/osgEarth/tinystr.h
+include/osgEarth/tinyxml.h
include/osgEarth/TraversalData
-include/osgEarth/URI
include/osgEarth/Units
+include/osgEarth/URI
include/osgEarth/Utils
include/osgEarth/Version
include/osgEarth/VerticalDatum
include/osgEarth/Viewpoint
include/osgEarth/VirtualProgram
include/osgEarth/XmlUtils
-include/osgEarth/optional
-include/osgEarth/tinystr.h
-include/osgEarth/tinyxml.h
include/osgEarthAnnotation/AnnotationData
include/osgEarthAnnotation/AnnotationEditing
+include/osgEarthAnnotation/AnnotationExtension
include/osgEarthAnnotation/AnnotationNode
include/osgEarthAnnotation/AnnotationRegistry
include/osgEarthAnnotation/AnnotationSettings
include/osgEarthAnnotation/AnnotationUtils
+include/osgEarthAnnotation/BboxDrawable
include/osgEarthAnnotation/CircleNode
include/osgEarthAnnotation/Common
include/osgEarthAnnotation/Decoration
@@ -178,14 +206,14 @@ include/osgEarthAnnotation/EllipseNode
include/osgEarthAnnotation/Export
include/osgEarthAnnotation/FeatureEditing
include/osgEarthAnnotation/FeatureNode
+include/osgEarthAnnotation/GeoPositionNode
+include/osgEarthAnnotation/GeoPositionNodeAutoScaler
include/osgEarthAnnotation/HighlightDecoration
include/osgEarthAnnotation/ImageOverlay
include/osgEarthAnnotation/ImageOverlayEditor
include/osgEarthAnnotation/LabelNode
include/osgEarthAnnotation/LocalGeometryNode
-include/osgEarthAnnotation/LocalizedNode
include/osgEarthAnnotation/ModelNode
-include/osgEarthAnnotation/OrthoNode
include/osgEarthAnnotation/PlaceNode
include/osgEarthAnnotation/RectangleNode
include/osgEarthAnnotation/ScaleDecoration
@@ -207,7 +235,6 @@ include/osgEarthDrivers/engine_mp/MPGeometry
include/osgEarthDrivers/engine_mp/MPShaders
include/osgEarthDrivers/engine_mp/MPTerrainEngineNode
include/osgEarthDrivers/engine_mp/MPTerrainEngineOptions
-include/osgEarthDrivers/engine_mp/QuickReleaseGLObjects
include/osgEarthDrivers/engine_mp/SingleKeyNodeFactory
include/osgEarthDrivers/engine_mp/TerrainNode
include/osgEarthDrivers/engine_mp/TileGroup
@@ -217,30 +244,50 @@ include/osgEarthDrivers/engine_mp/TileModelFactory
include/osgEarthDrivers/engine_mp/TileNode
include/osgEarthDrivers/engine_mp/TileNodeRegistry
include/osgEarthDrivers/engine_mp/TilePagedLOD
+include/osgEarthDrivers/engine_rex/Common
+include/osgEarthDrivers/engine_rex/EngineContext
+include/osgEarthDrivers/engine_rex/GeometryPool
+include/osgEarthDrivers/engine_rex/Loader
+include/osgEarthDrivers/engine_rex/LoadTileData
+include/osgEarthDrivers/engine_rex/MaskGenerator
+include/osgEarthDrivers/engine_rex/MPTexture
+include/osgEarthDrivers/engine_rex/RenderBindings
+include/osgEarthDrivers/engine_rex/RexTerrainEngineNode
+include/osgEarthDrivers/engine_rex/RexTerrainEngineOptions
+include/osgEarthDrivers/engine_rex/SelectionInfo
+include/osgEarthDrivers/engine_rex/Shaders
+include/osgEarthDrivers/engine_rex/SurfaceNode
+include/osgEarthDrivers/engine_rex/TileDrawable
+include/osgEarthDrivers/engine_rex/TileNode
+include/osgEarthDrivers/engine_rex/TileNodeRegistry
+include/osgEarthDrivers/engine_rex/Unloader
include/osgEarthDrivers/feature_elevation/FeatureElevationOptions
include/osgEarthDrivers/feature_ogr/FeatureCursorOGR
include/osgEarthDrivers/feature_ogr/OGRFeatureOptions
include/osgEarthDrivers/feature_raster/RasterFeatureOptions
include/osgEarthDrivers/feature_tfs/TFSFeatureOptions
include/osgEarthDrivers/feature_wfs/WFSFeatureOptions
+include/osgEarthDrivers/featurefilter_intersect/IntersectFeatureFilterOptions
+include/osgEarthDrivers/featurefilter_join/JoinFeatureFilterOptions
include/osgEarthDrivers/gdal/GDALOptions
include/osgEarthDrivers/kml/KML
include/osgEarthDrivers/kml/KMLOptions
include/osgEarthDrivers/mask_feature/FeatureMaskOptions
include/osgEarthDrivers/mbtiles/MBTilesOptions
include/osgEarthDrivers/model_feature_geom/FeatureGeomModelOptions
-include/osgEarthDrivers/model_feature_stencil/FeatureStencilModelOptions
include/osgEarthDrivers/model_simple/SimpleModelOptions
include/osgEarthDrivers/ocean_simple/SimpleOceanOptions
include/osgEarthDrivers/osg/ColorRampOptions
include/osgEarthDrivers/osg/OSGOptions
include/osgEarthDrivers/quadkey/QuadKeyOptions
include/osgEarthDrivers/refresh/RefreshOptions
+include/osgEarthDrivers/scriptengine_javascript/duk_config.h
+include/osgEarthDrivers/scriptengine_javascript/duktape.h
include/osgEarthDrivers/scriptengine_javascript/DuktapeEngine
include/osgEarthDrivers/scriptengine_javascript/JSGeometry
-include/osgEarthDrivers/scriptengine_javascript/duktape.h
include/osgEarthDrivers/sky_gl/GLSkyOptions
include/osgEarthDrivers/sky_simple/SimpleSkyOptions
+include/osgEarthDrivers/skyview/SkyViewOptions
include/osgEarthDrivers/splat_mask/SplatMaskOptions
include/osgEarthDrivers/template_matclass/TemplateMatClassOptions
include/osgEarthDrivers/tilecache/TileCacheOptions
@@ -257,7 +304,6 @@ include/osgEarthFeatures/AltitudeFilter
include/osgEarthFeatures/BufferFilter
include/osgEarthFeatures/BuildGeometryFilter
include/osgEarthFeatures/BuildTextFilter
-include/osgEarthFeatures/BuildTextOperator
include/osgEarthFeatures/CentroidFilter
include/osgEarthFeatures/Common
include/osgEarthFeatures/ConvertTypeFilter
@@ -279,7 +325,7 @@ include/osgEarthFeatures/FilterContext
include/osgEarthFeatures/GeometryCompiler
include/osgEarthFeatures/GeometryUtils
include/osgEarthFeatures/LabelSource
-include/osgEarthFeatures/MeshClamper
+include/osgEarthFeatures/MVT
include/osgEarthFeatures/OgrUtils
include/osgEarthFeatures/OptimizerHints
include/osgEarthFeatures/PolygonizeLines
@@ -288,14 +334,33 @@ include/osgEarthFeatures/ScaleFilter
include/osgEarthFeatures/ScatterFilter
include/osgEarthFeatures/Script
include/osgEarthFeatures/ScriptEngine
+include/osgEarthFeatures/ScriptFilter
include/osgEarthFeatures/Session
include/osgEarthFeatures/SubstituteModelFilter
include/osgEarthFeatures/TessellateOperator
include/osgEarthFeatures/TextSymbolizer
include/osgEarthFeatures/TransformFilter
include/osgEarthFeatures/VirtualFeatureSource
+include/osgEarthSplat/Coverage
+include/osgEarthSplat/Export
+include/osgEarthSplat/LandCover
+include/osgEarthSplat/LandCoverTerrainEffect
+include/osgEarthSplat/LandCoverTilePatchCallback
+include/osgEarthSplat/LandUseTileSource
+include/osgEarthSplat/NoiseTextureFactory
+include/osgEarthSplat/SplatCatalog
+include/osgEarthSplat/SplatCoverageLegend
+include/osgEarthSplat/SplatExtension
+include/osgEarthSplat/SplatOptions
+include/osgEarthSplat/SplatShaders
+include/osgEarthSplat/SplatTerrainEffect
+include/osgEarthSplat/Surface
+include/osgEarthSplat/Zone
include/osgEarthSymbology/AGG.h
include/osgEarthSymbology/AltitudeSymbol
+include/osgEarthSymbology/BBoxSymbol
+include/osgEarthSymbology/BillboardResource
+include/osgEarthSymbology/BillboardSymbol
include/osgEarthSymbology/Color
include/osgEarthSymbology/Common
include/osgEarthSymbology/CoverageSymbol
@@ -303,10 +368,10 @@ include/osgEarthSymbology/CssUtils
include/osgEarthSymbology/Expression
include/osgEarthSymbology/ExtrusionSymbol
include/osgEarthSymbology/Fill
-include/osgEarthSymbology/GEOS
include/osgEarthSymbology/Geometry
include/osgEarthSymbology/GeometryFactory
include/osgEarthSymbology/GeometryRasterizer
+include/osgEarthSymbology/GEOS
include/osgEarthSymbology/IconResource
include/osgEarthSymbology/IconSymbol
include/osgEarthSymbology/InstanceResource
@@ -341,9 +406,9 @@ include/osgEarthUtil/ArcGIS
include/osgEarthUtil/AtlasBuilder
include/osgEarthUtil/AutoClipPlaneHandler
include/osgEarthUtil/BrightnessContrastColorFilter
-include/osgEarthUtil/CMYKColorFilter
include/osgEarthUtil/ChromaKeyColorFilter
include/osgEarthUtil/ClampCallback
+include/osgEarthUtil/CMYKColorFilter
include/osgEarthUtil/Common
include/osgEarthUtil/ContourMap
include/osgEarthUtil/Controls
@@ -355,92 +420,98 @@ include/osgEarthUtil/Export
include/osgEarthUtil/FeatureQueryTool
include/osgEarthUtil/Fog
include/osgEarthUtil/Formatter
-include/osgEarthUtil/GLSLColorFilter
include/osgEarthUtil/GammaColorFilter
include/osgEarthUtil/GeodeticGraticule
+include/osgEarthUtil/GLSLColorFilter
include/osgEarthUtil/GraticuleExtension
include/osgEarthUtil/GraticuleNode
include/osgEarthUtil/GraticuleOptions
include/osgEarthUtil/GraticuleTerrainEffect
include/osgEarthUtil/HSLColorFilter
include/osgEarthUtil/HTM
-include/osgEarthUtil/LODBlending
include/osgEarthUtil/LatLongFormatter
-include/osgEarthUtil/LineOfSight
include/osgEarthUtil/LinearLineOfSight
+include/osgEarthUtil/LineOfSight
+include/osgEarthUtil/LODBlending
include/osgEarthUtil/LogarithmicDepthBuffer
+include/osgEarthUtil/MeasureTool
include/osgEarthUtil/MGRSFormatter
include/osgEarthUtil/MGRSGraticule
-include/osgEarthUtil/MeasureTool
include/osgEarthUtil/MouseCoordsTool
include/osgEarthUtil/NightColorFilter
include/osgEarthUtil/ObjectLocator
include/osgEarthUtil/Ocean
include/osgEarthUtil/PolyhedralLineOfSight
+include/osgEarthUtil/RadialLineOfSight
include/osgEarthUtil/RGBColorFilter
include/osgEarthUtil/RTTPicker
-include/osgEarthUtil/RadialLineOfSight
include/osgEarthUtil/Shaders
include/osgEarthUtil/Shadowing
+include/osgEarthUtil/SimplePager
include/osgEarthUtil/SimplexNoise
include/osgEarthUtil/Sky
include/osgEarthUtil/SpatialData
include/osgEarthUtil/StarData
+include/osgEarthUtil/TerrainProfile
include/osgEarthUtil/TFS
include/osgEarthUtil/TFSPackager
+include/osgEarthUtil/TileIndex
+include/osgEarthUtil/TileIndexBuilder
include/osgEarthUtil/TMS
include/osgEarthUtil/TMSBackFiller
include/osgEarthUtil/TMSPackager
-include/osgEarthUtil/TerrainProfile
-include/osgEarthUtil/TileIndex
-include/osgEarthUtil/TileIndexBuilder
include/osgEarthUtil/UTMGraticule
include/osgEarthUtil/VerticalScale
include/osgEarthUtil/WFS
include/osgEarthUtil/WMS
lib/libosgEarth.so
lib/libosgEarth.so.0
-lib/libosgEarth.so.2.6.0
+lib/libosgEarth.so.2.8.0
lib/libosgEarthAnnotation.so
lib/libosgEarthAnnotation.so.0
-lib/libosgEarthAnnotation.so.2.6.0
+lib/libosgEarthAnnotation.so.2.8.0
lib/libosgEarthFeatures.so
lib/libosgEarthFeatures.so.0
-lib/libosgEarthFeatures.so.2.6.0
+lib/libosgEarthFeatures.so.2.8.0
+lib/libosgEarthSplat.so
+lib/libosgEarthSplat.so.0
+lib/libosgEarthSplat.so.2.8.0
lib/libosgEarthSymbology.so
lib/libosgEarthSymbology.so.0
-lib/libosgEarthSymbology.so.2.6.0
+lib/libosgEarthSymbology.so.2.8.0
lib/libosgEarthUtil.so
lib/libosgEarthUtil.so.0
-lib/libosgEarthUtil.so.2.6.0
+lib/libosgEarthUtil.so.2.8.0
lib/osgPlugins-%%OSGVERSION%%/osgdb_earth.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_kml.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_agglite.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis_map_cache.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_billboard.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_arcgis.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bing.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_bumpmap.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_cache_filesystem.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_colorramp.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_debug.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_detail.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_byo.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_mp.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_engine_rex.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_elevation.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_ogr.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_raster.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_tfs.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_feature_wfs.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_featurefilter_intersect.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_featurefilter_join.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_gdal.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_label_annotation.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mapinspector.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mask_feature.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_mbtiles.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_feature_geom.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_feature_stencil.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_model_simple.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_monitor.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_noise.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_normalmap.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_ocean_simple.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_osg.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_quadkey.so
@@ -448,7 +519,7 @@ lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_refresh.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_scriptengine_javascript.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_gl.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_sky_simple.so
-lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_splat.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_skyview.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_splat_mask.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_template_matclass.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_terrainshader.so
@@ -465,3 +536,4 @@ lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wcs.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_wms.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_xyz.so
lib/osgPlugins-%%OSGVERSION%%/osgdb_osgearth_yahoo.so
+lib/osgPlugins-%%OSGVERSION%%/osgdb_template.so