aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-26 18:26:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-26 18:26:14 +0000
commitf3ace4251bf81537fd95588af145d9d6d6e40008 (patch)
tree6b4799b0cf7b3d20af9184999a4aa0c2ebcba9ce /graphics
parent387330411881d2d22bd6749ac2a3caafb0d8c0fb (diff)
downloadports-f3ace4251bf81537fd95588af145d9d6d6e40008.tar.gz
ports-f3ace4251bf81537fd95588af145d9d6d6e40008.zip
- Switch to options helpers
- While here, add some NO_ARCHes Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=395389
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ayam/Makefile5
-rw-r--r--graphics/cairomm/Makefile6
-rw-r--r--graphics/darktable/Makefile4
-rw-r--r--graphics/dataplot/Makefile6
-rw-r--r--graphics/figurine/Makefile14
-rw-r--r--graphics/generic_image_decoder/Makefile6
-rw-r--r--graphics/geoapi/Makefile6
-rw-r--r--graphics/gimp-elsamuko-script/Makefile7
-rw-r--r--graphics/hobbes-icons-xpm/Makefile7
-rw-r--r--graphics/impressive/Makefile8
10 files changed, 23 insertions, 46 deletions
diff --git a/graphics/ayam/Makefile b/graphics/ayam/Makefile
index aa14c8dbd481..2fb6364d0b49 100644
--- a/graphics/ayam/Makefile
+++ b/graphics/ayam/Makefile
@@ -33,8 +33,6 @@ MAKE_JOBS_UNSAFE= yes
AYAM_PLUGINS= csphere mfio
PLUGINS_DIR= ${PREFIX}/lib/${PORTNAME}
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/tcl/ayam.tcl
@${REINPLACE_CMD} -e 's|^MF3DCFLAGS =|MF3DCFLAGS = -fPIC|g' \
@@ -92,7 +90,7 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/lib/ayam-splash.gif ${STAGEDIR}${DATADIR}
# docs
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Setup.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/doc/ayam.pdf ${STAGEDIR}${DOCSDIR}
@@ -103,6 +101,5 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html/pics
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/doc/html/pics/* \
${STAGEDIR}${DOCSDIR}/html/pics
-.endif
.include <bsd.port.mk>
diff --git a/graphics/cairomm/Makefile b/graphics/cairomm/Makefile
index 103d8d207288..8de17c75a6c7 100644
--- a/graphics/cairomm/Makefile
+++ b/graphics/cairomm/Makefile
@@ -25,12 +25,8 @@ OPTIONS_DEFINE= DOCS
DOCS_CONFIGURE_ARGS_OFF= --disable-documentation
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MDOCS)
-post-configure:
+post-configure-DOCS-off:
@${TOUCH} -f ${WRKSRC}/docs/reference/html/index.html
-.endif
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcairomm-1.0.so.1.4.0
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 99ef82fc3d7f..b6e59c000f32 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -103,14 +103,12 @@ CMAKE_BUILD_TYPE= RelWithDebInfo
STRIP=
.endif
-.if ! ${PORT_OPTIONS:MDOCS}
-post-install:
+post-install-DOCS-off:
${RM} ${STAGEDIR}${DOCSDIR}/AUTHORS
${RM} ${STAGEDIR}${DOCSDIR}/LICENSE
${RM} ${STAGEDIR}${DOCSDIR}/README
${RM} ${STAGEDIR}${DOCSDIR}/TRANSLATORS
${RM} ${STAGEDIR}${DOCSDIR}/darktablerc.html
${RMDIR} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index 9e562740b7f4..c60122455e7f 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -52,13 +52,11 @@ post-extract:
pre-patch:
@${REINPLACE_CMD} -e 's/MAXOBV=1000000/MAXOBV=${MAXOBV}/' \
- ${WRKSRC}/DPCOPA.INC
+ ${WRKSRC}/DPCOPA.INC
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/dpsnapsh.pdf \
${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/figurine/Makefile b/graphics/figurine/Makefile
index 3b2271d09c65..ba5790b3e80c 100644
--- a/graphics/figurine/Makefile
+++ b/graphics/figurine/Makefile
@@ -24,22 +24,18 @@ PLIST_FILES= bin/figurine \
PORTDOCS= *
-.include <bsd.port.options.mk>
-
# Optimizations produce bad assembly code on sparc64
-.if ${ARCH} == "sparc64"
-CFLAGS+= -O0
-.endif
+CFLAGS_sparc64= -O0
post-patch:
-.if !${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e "s|Doc examples src|src|" \
- ${WRKSRC}/Makefile.in
-.endif
@${REINPLACE_CMD} -e 's|datadir = @datadir@|datadir = @datadir@/doc|' \
${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in \
${WRKSRC}/Doc/Makefile.in \
${WRKSRC}/examples/Makefile.in
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} -e "s|Doc examples src|src|" \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/graphics/generic_image_decoder/Makefile b/graphics/generic_image_decoder/Makefile
index 652b1919951c..64b492b7d0f0 100644
--- a/graphics/generic_image_decoder/Makefile
+++ b/graphics/generic_image_decoder/Makefile
@@ -20,8 +20,6 @@ PORTDOCS= gid.txt
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-extract:
${CP} ${FILESDIR}/construct.gpr ${WRKSRC}
${MKDIR} ${WRKSRC}/src ${WRKDIR}/data
@@ -48,9 +46,9 @@ do-install:
${STAGEDIR}${PREFIX}/lib/generic_image_decoder
(cd ${WRKSRC}/test && ${INSTALL_PROGRAM} to_bmp mini \
${STAGEDIR}${PREFIX}/bin)
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/gid.txt ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/geoapi/Makefile b/graphics/geoapi/Makefile
index b6c81d1c2ee9..7b8978409486 100644
--- a/graphics/geoapi/Makefile
+++ b/graphics/geoapi/Makefile
@@ -12,6 +12,7 @@ COMMENT= Java interface API based upon OGC Standards
USES= zip
NO_BUILD= yes
+NO_ARCH= yes
USE_JAVA= yes
NO_WRKSUBDIR= yes
@@ -20,18 +21,15 @@ DOCS= README.txt
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
.for jar in ${JARFILES}
${INSTALL_DATA} ${WRKDIR}/${jar}.jar ${STAGEDIR}${JAVAJARDIR}
.endfor
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKDIR}/javadoc \
&& ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/\{} \; \
&& ${FIND} . -type f -exec ${INSTALL_DATA} \{} ${STAGEDIR}${DOCSDIR}/\{} \;
-.endif
.include <bsd.port.mk>
diff --git a/graphics/gimp-elsamuko-script/Makefile b/graphics/gimp-elsamuko-script/Makefile
index 941640afca50..a05ecf5b6df2 100644
--- a/graphics/gimp-elsamuko-script/Makefile
+++ b/graphics/gimp-elsamuko-script/Makefile
@@ -23,24 +23,23 @@ OPTIONS_DEFINE= DOCS
USES= zip
NO_BUILD= yes
+NO_ARCH= yes
GIMP_SCRIPTS_DIR?= share/gimp/scripts
# installation dir
PLIST_SUB= GIMP_SCRIPTS_DIR=${GIMP_SCRIPTS_DIR}
-.include <bsd.port.options.mk>
-
# installed docs
PORTDOCS= *
do-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} \*.scm \
${STAGEDIR}${PREFIX}/${GIMP_SCRIPTS_DIR})
+
# install docs
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/z_README ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/graphics/hobbes-icons-xpm/Makefile b/graphics/hobbes-icons-xpm/Makefile
index 56c882beb361..ef616cf8e73a 100644
--- a/graphics/hobbes-icons-xpm/Makefile
+++ b/graphics/hobbes-icons-xpm/Makefile
@@ -12,24 +12,21 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Collection of over 3000 icons in XPM3 format
NO_BUILD= yes
+NO_ARCH= yes
LIBDIR= ${STAGEDIR}${PREFIX}/include/X11/pixmaps
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${MKDIR} ${LIBDIR}
${CP} -R ${WRKSRC}/* ${LIBDIR}/
-${RM} ${LIBDIR}/README
-${RM} ${LIBDIR}/readem.shar
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/*.shar ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 2f50b8e33a34..93f2c81d083c 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= vg@FreeBSD.org
COMMENT= The stylish way of giving presentations
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
@@ -23,6 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
USES= ghostscript:run python
NO_BUILD= yes
+NO_ARCH= yes
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
@@ -30,14 +32,12 @@ PORTDOCS= ${PORTNAME}.html demo.pdf
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>