aboutsummaryrefslogtreecommitdiff
path: root/hebrew
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
commit72c08ec487edbe98662f3278bee17f8726ee4ce4 (patch)
treea3c6d7d2a4a492c3e55a418f3fa370e951b5ccc7 /hebrew
parenta600d4522cadfa512ce465f98566cee7b9bec843 (diff)
downloadports-72c08ec487edbe98662f3278bee17f8726ee4ce4.tar.gz
ports-72c08ec487edbe98662f3278bee17f8726ee4ce4.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Notes
Notes: svn path=/head/; revision=278527
Diffstat (limited to 'hebrew')
-rw-r--r--hebrew/hunspell/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/hebrew/hunspell/Makefile b/hebrew/hunspell/Makefile
index 901d9763e65e..527aee2418e2 100644
--- a/hebrew/hunspell/Makefile
+++ b/hebrew/hunspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hunspell
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= hebrew textproc
MASTER_SITES= http://hspell.ivrix.org.il/
DISTNAME= hspell-${PORTVERSION}
@@ -16,22 +17,21 @@ COMMENT= Hunspell hebrew dictionary
BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
-GNU_CONFIGURE= yes
+ALL_TARGET= myspell
CONFIGURE_ARGS= --enable-fatverb
+GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
-ALL_TARGET= myspell
-PLIST_FILES= share/hunspell/he.aff \
- share/hunspell/he.dic
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/he.aff \
+ %%DATADIR%%/he.dic
+PLIST_DIRSTRY= %%DATADIR%%
post-patch:
- @${REINPLACE_CMD} 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/pmerge
+ @${REINPLACE_CMD} 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/pmerge
+
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKSRC}/he.aff \
- ${WRKSRC}/he.dic \
- ${PREFIX}/share/hunspell/
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/he.aff ${WRKSRC}/he.dic ${DATADIR}/
.include <bsd.port.mk>