aboutsummaryrefslogtreecommitdiff
path: root/hungarian
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-28 12:36:28 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-28 12:36:28 +0000
commit413eae843b7e2417f02a6aaee89c17d627a0f436 (patch)
treeddcd26117ed6c63b3b90686865715d227f6986e9 /hungarian
parent7dca4ce1a0e8ef22636cfe0783cee3e1adbcf999 (diff)
downloadports-413eae843b7e2417f02a6aaee89c17d627a0f436.tar.gz
ports-413eae843b7e2417f02a6aaee89c17d627a0f436.zip
- Update to 1.1.10
PR: ports/115783 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer)
Notes
Notes: svn path=/head/; revision=198452
Diffstat (limited to 'hungarian')
-rw-r--r--hungarian/hunspell/Makefile3
-rw-r--r--hungarian/hunspell/distinfo6
-rw-r--r--hungarian/hunspell/files/patch-src_hunspell_suggestmgr.hxx27
3 files changed, 31 insertions, 5 deletions
diff --git a/hungarian/hunspell/Makefile b/hungarian/hunspell/Makefile
index 6f649804a566..6714beee4ad1 100644
--- a/hungarian/hunspell/Makefile
+++ b/hungarian/hunspell/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hunspell
-PORTVERSION= 1.1.9
+PORTVERSION= 1.1.10
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
http://magyarispell.sourceforge.net/:data
@@ -36,7 +36,6 @@ do-extract:
cd ${WRKDIR} && ${TAR} -xzf ${_DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX};\
${UNZIP_CMD} -qo ${_DISTDIR}/hu_HU.zip -d ${WRKDIR}
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/tools/hunspell.cxx
diff --git a/hungarian/hunspell/distinfo b/hungarian/hunspell/distinfo
index 53b65895c0f7..64b348866eee 100644
--- a/hungarian/hunspell/distinfo
+++ b/hungarian/hunspell/distinfo
@@ -1,6 +1,6 @@
-MD5 (hunspell-1.1.9.tar.gz) = ff56cf42ebf13dd3b8437194f43c6c7a
-SHA256 (hunspell-1.1.9.tar.gz) = c36ed98189da373f3f24e7be97425454e6706cc3e0d07ff39f8c1bcd6689d543
-SIZE (hunspell-1.1.9.tar.gz) = 684426
+MD5 (hunspell-1.1.10.tar.gz) = e1fe2a3de7eedf5e9ec8e62f9ecbdddd
+SHA256 (hunspell-1.1.10.tar.gz) = a241057dad469f4e61027816d800f2935f68b86a6155188e4ccb5280232f646c
+SIZE (hunspell-1.1.10.tar.gz) = 723968
MD5 (hu_HU.zip) = c5a0af97a41c1ad65b3f48824b575ad1
SHA256 (hu_HU.zip) = ab039056c7b38a07981e0b1dd7ea0c2dbfd38326392981e6893d3325376e9908
SIZE (hu_HU.zip) = 1197277
diff --git a/hungarian/hunspell/files/patch-src_hunspell_suggestmgr.hxx b/hungarian/hunspell/files/patch-src_hunspell_suggestmgr.hxx
new file mode 100644
index 000000000000..0a381fae172c
--- /dev/null
+++ b/hungarian/hunspell/files/patch-src_hunspell_suggestmgr.hxx
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- src/hunspell/suggestmgr.hxx.orig
++++ src/hunspell/suggestmgr.hxx
+@@ -61,8 +61,8 @@
+
+ private:
+ int testsug(char** wlst, const char * candidate, int wl, int ns, int cpdsuggest,
+- int * timer, time_t * timelimit);
+- int checkword(const char *, int, int, int *, time_t *);
++ int * timer, clock_t * timelimit);
++ int checkword(const char *, int, int, int *, clock_t *);
+ int check_forbidden(const char *, int);
+
+ int capchars(char **, const char *, int, int);
+@@ -89,8 +89,8 @@
+ int movechar_utf(char **, const w_char *, int, int, int);
+
+ int mapchars(char**, const char *, int, int);
+- int map_related(const char *, int, char ** wlst, int, int, const mapentry*, int, int *, time_t *);
+- int map_related_utf(w_char *, int, int, int, char ** wlst, int, const mapentry*, int, int *, time_t *);
++ int map_related(const char *, int, char ** wlst, int, int, const mapentry*, int, int *, clock_t *);
++ int map_related_utf(w_char *, int, int, int, char ** wlst, int, const mapentry*, int, int *, clock_t *);
+ int ngram(int n, char * s1, const char * s2, int opt);
+ int mystrlen(const char * word);
+ int leftcommonsubstring(char * s1, const char * s2);