aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee-facebook
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-03-29 14:15:04 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-03-29 14:15:04 +0000
commit6d78b5bcdbe7d2fb242dd382cdb43f306c5b46a9 (patch)
tree6cb4b52996f88255e6259dfbf5ec82bf6527e33e /irc/bitlbee-facebook
parent9c33a9eabd4e283d9deacffe770b12de74514b83 (diff)
downloadports-6d78b5bcdbe7d2fb242dd382cdb43f306c5b46a9.tar.gz
ports-6d78b5bcdbe7d2fb242dd382cdb43f306c5b46a9.zip
irc/bitlbee-facebook: update to latest commit, bump PORTREVISION
This fixes especially https://github.com/bitlbee/bitlbee-facebook/issues/138. Reported by: cognet
Notes
Notes: svn path=/head/; revision=437203
Diffstat (limited to 'irc/bitlbee-facebook')
-rw-r--r--irc/bitlbee-facebook/Makefile5
-rw-r--r--irc/bitlbee-facebook/distinfo6
-rw-r--r--irc/bitlbee-facebook/files/patch-facebook_facebook.c27
3 files changed, 6 insertions, 32 deletions
diff --git a/irc/bitlbee-facebook/Makefile b/irc/bitlbee-facebook/Makefile
index 7b0329d3cf44..1d756c3f977c 100644
--- a/irc/bitlbee-facebook/Makefile
+++ b/irc/bitlbee-facebook/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bitlbee-facebook
PORTVERSION= 1.0.0
DISTVERSIONPREFIX=v
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= irc
@@ -22,7 +22,8 @@ USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_GITHUB= yes
-GH_ACCOUNT= bitlbee
+GH_ACCOUNT= gahr
+GH_TAGNAME= 20170329
MAKE_JOBS_UNSAFE= yes
diff --git a/irc/bitlbee-facebook/distinfo b/irc/bitlbee-facebook/distinfo
index ab1cfb936fae..d6513971e0da 100644
--- a/irc/bitlbee-facebook/distinfo
+++ b/irc/bitlbee-facebook/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484122554
-SHA256 (bitlbee-bitlbee-facebook-v1.0.0_GH0.tar.gz) = 20e0c41393be151735463b206625c91977706db144ff8ff1d4d726e1f33fd124
-SIZE (bitlbee-bitlbee-facebook-v1.0.0_GH0.tar.gz) = 62389
+TIMESTAMP = 1490796410
+SHA256 (gahr-bitlbee-facebook-v1.0.0-20170329_GH0.tar.gz) = 0e7644f789b24570ce20cb96bd3fc21afee31c063bfc60d0586e5b8fc7ce37f4
+SIZE (gahr-bitlbee-facebook-v1.0.0-20170329_GH0.tar.gz) = 65531
diff --git a/irc/bitlbee-facebook/files/patch-facebook_facebook.c b/irc/bitlbee-facebook/files/patch-facebook_facebook.c
deleted file mode 100644
index b4a572e9c64b..000000000000
--- a/irc/bitlbee-facebook/files/patch-facebook_facebook.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- facebook/facebook.c.orig 2016-01-16 15:20:59 UTC
-+++ facebook/facebook.c
-@@ -1082,3 +1082,24 @@ init_plugin(void)
- root_command_add("fbcreate", 0, fb_cmd_fbcreate, 0);
- root_command_add("fbjoin", 0, fb_cmd_fbjoin, 0);
- }
-+
-+
-+#ifdef BITLBEE_ABI_VERSION_CODE
-+G_MODULE_EXPORT struct plugin_info *
-+init_plugin_info(void);
-+
-+G_MODULE_EXPORT struct plugin_info *
-+init_plugin_info(void)
-+{
-+ static struct plugin_info info = {
-+ BITLBEE_ABI_VERSION_CODE,
-+ "facebook",
-+ PACKAGE_VERSION,
-+ "Facebook protocol plugin",
-+ "dequis <dx@dxzone.com.ar> (maintainer), James Geboski <jgeboski@gmail.com> (original author)",
-+ PACKAGE_URL
-+ };
-+
-+ return &info;
-+}
-+#endif /* BITLBEE_ABI_VERSION_CODE */