aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee/Makefile
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@FreeBSD.org>2010-10-28 16:20:38 +0000
committerHenrik Brix Andersen <brix@FreeBSD.org>2010-10-28 16:20:38 +0000
commitf7fe6d747c9bdf1a58bd63aa8337cafe7f150cee (patch)
tree157e52afc166bcd1c107f609a817ff648c1844ab /irc/bitlbee/Makefile
parentf47bcd02e844de1a68dbdf72694cb8990c99b539 (diff)
downloadports-f7fe6d747c9bdf1a58bd63aa8337cafe7f150cee.tar.gz
ports-f7fe6d747c9bdf1a58bd63aa8337cafe7f150cee.zip
- Update to v3.0
- Add LICENSE information
Notes
Notes: svn path=/head/; revision=263695
Diffstat (limited to 'irc/bitlbee/Makefile')
-rw-r--r--irc/bitlbee/Makefile26
1 files changed, 18 insertions, 8 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index 7b82fcf683a9..5920834dfede 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bitlbee
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 3.0
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
${MASTER_SITE_LOCAL}
@@ -32,11 +31,13 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= DEBUG "Enable debug support" Off \
IPV6 "Enable IPv6 support" On \
OPENSSL "Use OpenSSL rather than GnuTLS" Off \
+ OTR "Enable OTR encryption support" Off \
MSN "Enable MSN protocol support" On \
JABBER "Enable Jabber (XMPP) protocol support" On \
OSCAR "Enable OSCAR (ICQ, AIM) protocol support" On \
YAHOO "Enable Yahoo! protocol support" On \
- TWITTER "Enable Twitter protocol support" On
+ TWITTER "Enable Twitter protocol support" On \
+ LIBPURPLE "Use libpurple for protocol support" Off
CONFIGURE_ARGS= --config=/var/db/bitlbee --strip=0
@@ -66,6 +67,13 @@ CONFIGURE_ARGS+=--ssl=gnutls
LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
.endif
+.if defined(WITH_OTR)
+CONFIGURE_ARGS+=--otr=1
+LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr
+.else
+CONFIGURE_ARGS+=--otr=0
+.endif
+
.if defined(WITH_MSN)
CONFIGURE_ARGS+=--msn=1
.else
@@ -96,6 +104,13 @@ CONFIGURE_ARGS+=--twitter=1
CONFIGURE_ARGS+=--twitter=0
.endif
+.if defined(WITH_LIBPURPLE)
+CONFIGURE_ARGS+=--purple=1
+LIB_DEPENDS+= purple.7:${PORTSDIR}/net-im/libpurple
+.else
+CONFIGURE_ARGS+=--purple=0
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e "s|^EFLAGS=|EFLAGS=${LDFLAGS}|" \
@@ -108,11 +123,6 @@ post-patch:
@${REINPLACE_CMD} \
-e "s:/var/lib/bitlbee:/var/db/bitlbee:" \
${WRKSRC}/doc/bitlbee.8
-.if ${OSVERSION} < 700042
- @${REINPLACE_CMD} \
- -e "s:-iquote:-I:g" \
- ${WRKSRC}/configure
-.endif
post-install:
${MKDIR} ${PREFIX}/etc/bitlbee