aboutsummaryrefslogtreecommitdiff
path: root/irc/eggdrop-devel
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-06-14 20:59:47 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-06-14 20:59:47 +0000
commitcdb292fbf9ce40a2ae107c9487a539f1959356c2 (patch)
treec496c2197ea0f2a3ea4d94349766bdfc4a64cc07 /irc/eggdrop-devel
parentc48a6fe55b723e245eb17677aca4cd981c3f72c0 (diff)
downloadports-cdb292fbf9ce40a2ae107c9487a539f1959356c2.tar.gz
ports-cdb292fbf9ce40a2ae107c9487a539f1959356c2.zip
Eggdrop is the world's most popular open source Internet Relay Chat (IRC) bot.
Originally created by Robey Pointer in December 1993, it has spawned an almost cult like following of users. It is a feature rich program designed to be easily used and expanded upon (using Tcl scripting) by both novice and advanced IRC users on a variety of hardware and software platforms.
Notes
Notes: svn path=/head/; revision=299285
Diffstat (limited to 'irc/eggdrop-devel')
-rw-r--r--irc/eggdrop-devel/Makefile120
-rw-r--r--irc/eggdrop-devel/distinfo2
-rw-r--r--irc/eggdrop-devel/files/patch-eggdrop.conf29
-rw-r--r--irc/eggdrop-devel/files/pkg-message.in10
-rw-r--r--irc/eggdrop-devel/pkg-descr7
-rw-r--r--irc/eggdrop-devel/pkg-plist185
6 files changed, 353 insertions, 0 deletions
diff --git a/irc/eggdrop-devel/Makefile b/irc/eggdrop-devel/Makefile
new file mode 100644
index 000000000000..0f476293a1f6
--- /dev/null
+++ b/irc/eggdrop-devel/Makefile
@@ -0,0 +1,120 @@
+# New ports collection makefile for: eggdrop-devel
+# Date created: June 13, 2011
+# Whom: Beech Rintoul <beech@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= eggdrop
+PORTVERSION= 1.8
+CATEGORIES= irc
+MASTER_SITES= http://www.freebsdnorth.com/distfiles/ \
+ LOCAL/beech
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}${PORTVERSION}
+DISTFILES= ${PORTNAME}${PORTVERSION}-snapshot.tar.gz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= The most popular open source Internet Relay Chat bot
+
+LICENSE= GPLv2
+
+USE_TCL= 85+
+GNU_CONFIGURE= yes
+
+MAKE_JOBS_UNSAFE= yes
+
+MAN1= eggdrop.1
+
+SUB_FILES= pkg-message
+
+CONFLICTS= eggdrop-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/eggdrop.conf \
+ > ${WRKSRC}/eggdrop.conf.sample
+
+post-configure:
+ @(cd ${WRKSRC}; ${MAKE} config)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/eggdrop ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/man1/eggdrop.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/eggdrop.conf.sample ${PREFIX}/etc
+ @${MKDIR} ${PREFIX}/lib/eggdrop
+.for f in assoc.so blowfish.so channels.so compress.so console.so ctcp.so \
+ dns.so filesys.so irc.so notes.so seen.so server.so share.so \
+ transfer.so uptime.so
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/eggdrop
+.endfor
+ @${MKDIR} ${DATADIR}/help
+.for f in assoc.mod/help/assoc.help channels.mod/help/chaninfo.help \
+ channels.mod/help/channels.help console.mod/help/console.help \
+ compress.mod/help/compress.help ctcp.mod/help/ctcp.help \
+ filesys.mod/help/filesys.help irc.mod/help/irc.help \
+ notes.mod/help/notes.help seen.mod/help/seen.help \
+ server.mod/help/server.help share.mod/help/share.help \
+ transfer.mod/help/transfer.help uptime.mod/help/uptime.help
+ ${INSTALL_DATA} ${WRKSRC}/src/mod/${f} ${DATADIR}/help
+.endfor
+ @${MKDIR} ${DATADIR}/help/set
+.for f in channels.mod/help/set/channels.help \
+ compress.mod/help/set/compress.help \
+ console.mod/help/set/console.help ctcp.mod/help/set/ctcp.help \
+ filesys.mod/help/set/filesys.help irc.mod/help/set/irc.help \
+ notes.mod/help/set/notes.help server.mod/help/set/server.help \
+ share.mod/help/set/share.help transfer.mod/help/set/transfer.help
+ ${INSTALL_DATA} ${WRKSRC}/src/mod/$f ${DATADIR}/help/set
+.endfor
+ @${MKDIR} ${DATADIR}/help/msg
+.for f in irc.mod/help/msg/irc.help notes.mod/help/msg/notes.help \
+ seen.mod/help/msg/seen.help
+ ${INSTALL_DATA} ${WRKSRC}/src/mod/$f ${DATADIR}/help/msg
+.endfor
+ @${MKDIR} ${DATADIR}/language
+ ${INSTALL_DATA} ${WRKSRC}/language/core.*.lang ${DATADIR}/language
+ @cd ${WRKSRC}/src/mod \
+ && ${FIND} . -name "*.lang" -exec ${INSTALL_DATA} "{}" \
+ ${DATADIR}/language ";"
+ @${MKDIR} ${DATADIR}/scripts
+.for f in CONTENTS action.fix.tcl autobotchk alltools.tcl botchk \
+ cmd_resolve.tcl compat.tcl dccwhois.tcl getops.tcl klined.tcl notes2.tcl ques5.tcl \
+ quotepass.tcl quotepong.tcl sentinel.tcl userinfo.tcl weed
+ ${INSTALL_DATA} ${WRKSRC}/scripts/${f} ${DATADIR}/scripts
+.endfor
+ @${MKDIR} ${DATADIR}/scripts/help
+.for f in cmd_resolve.help userinfo.help
+ ${INSTALL_DATA} ${WRKSRC}/scripts/help/${f} ${DATADIR}/scripts/help
+.endfor
+ @${MKDIR} ${DATADIR}/scripts/help/msg
+.for f in userinfo.help
+ ${INSTALL_DATA} ${WRKSRC}/scripts/help/msg/${f} ${DATADIR}/scripts/help/msg
+.endfor
+.for f in cmds1.help cmds2.help core.help
+ ${INSTALL_DATA} ${WRKSRC}/help/${f} ${DATADIR}/help
+.endfor
+.for f in cmds1.help
+ ${INSTALL_DATA} ${WRKSRC}/help/set/${f} ${DATADIR}/help/set
+.endfor
+ @${MKDIR} ${DATADIR}/text
+.for f in banner motd
+ ${INSTALL_DATA} ${WRKSRC}/text/${f} ${DATADIR}/text
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ABOUT BANS BOTNET BUG-REPORT COMPILE-GUIDE CONTENTS \
+ FIRST-SCRIPT KNOWN-PROBLEMS MODULES PARTYLINE PATCH-HOWTO \
+ TEXT-SUBSTITUTIONS TRICKS Changes1.8 USERS WEIRD-MESSAGES \
+ tcl-commands.doc
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${DOCSDIR}/html
+ cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html ${DOCSDIR}/html
+ @${MKDIR} ${DOCSDIR}/settings
+ cd ${WRKSRC}/doc/settings && $(RM) -rf CVS \
+ && ${INSTALL_DATA} * ${DOCSDIR}/settings
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/irc/eggdrop-devel/distinfo b/irc/eggdrop-devel/distinfo
new file mode 100644
index 000000000000..0bdc9f175f71
--- /dev/null
+++ b/irc/eggdrop-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (eggdrop1.8-snapshot.tar.gz) = 46d4f247cf29bec4881831e1b32dd9ec839b2879185203e179797127fd179ee0
+SIZE (eggdrop1.8-snapshot.tar.gz) = 1302711
diff --git a/irc/eggdrop-devel/files/patch-eggdrop.conf b/irc/eggdrop-devel/files/patch-eggdrop.conf
new file mode 100644
index 000000000000..8490199bc5d0
--- /dev/null
+++ b/irc/eggdrop-devel/files/patch-eggdrop.conf
@@ -0,0 +1,29 @@
+--- eggdrop.conf 2010-07-05 14:07:05.000000000 +0200
++++ eggdrop.conf 2011-01-07 06:13:49.000000000 +0100
+@@ -1,4 +1,4 @@
+-#! /path/to/executable/eggdrop
++#!%%PREFIX%%/bin/eggdrop
+ # ^- This should contain a fully qualified path to your Eggdrop executable.
+ #
+ # $Id: eggdrop.conf,v 1.66 2010/07/05 12:07:05 pseudo Exp $
+@@ -444,7 +444,7 @@
+ # If you run the bot from the compilation directory, you will want to set
+ # this to "". If you use 'make install' (like all good kiddies do ;), this
+ # is a fine default. Otherwise, use your head :)
+-set mod-path "modules/"
++set mod-path "%%PREFIX%%/lib/eggdrop/"
+
+
+ #### BLOWFISH MODULE ####
+@@ -842,6 +842,11 @@
+ another.example.com:7000:password
+ }
+
++# Set this option, if you want a SSL connection to the IRC Server(s) specified
++# above. This setting applies to all servers, so make sure they all support SSL
++# connections. Eggdrop has to be compiled with SSL support for this to work!
++set use-ssl 0
++
+ # Number of seconds to wait between transmitting queued lines to the server.
+ # Lower this value at your own risk. ircd is known to start flood control
+ # at 512 bytes/2 seconds.
diff --git a/irc/eggdrop-devel/files/pkg-message.in b/irc/eggdrop-devel/files/pkg-message.in
new file mode 100644
index 000000000000..68f969678c0c
--- /dev/null
+++ b/irc/eggdrop-devel/files/pkg-message.in
@@ -0,0 +1,10 @@
+========================================================================
+
+This Port of Eggdrop differs from a normal eggdrop installation, because
+it does respect hier(7). That means your eggdrop.conf goes to
+%%PREFIX%%/etc/eggdrop.conf and .chan, .notes, .user files go to
+%%PREFIX%%/share/eggdrop. Modules will go to %%PREFIX%%/lib/eggdrop and
+documentation can be found in %%PREFIX%%/share/doc/eggdrop, scripts go
+to %%PREFIX%%/share/eggdrop/scripts.
+
+========================================================================
diff --git a/irc/eggdrop-devel/pkg-descr b/irc/eggdrop-devel/pkg-descr
new file mode 100644
index 000000000000..6adc4e16b02d
--- /dev/null
+++ b/irc/eggdrop-devel/pkg-descr
@@ -0,0 +1,7 @@
+Eggdrop is the world's most popular open source Internet Relay Chat (IRC) bot.
+Originally created by Robey Pointer in December 1993, it has spawned an almost
+cult like following of users. It is a feature rich program designed to be
+easily used and expanded upon (using Tcl scripting) by both novice and
+advanced IRC users on a variety of hardware and software platforms.
+
+WWW: http://www.eggheads.org/
diff --git a/irc/eggdrop-devel/pkg-plist b/irc/eggdrop-devel/pkg-plist
new file mode 100644
index 000000000000..c2c0998eebd1
--- /dev/null
+++ b/irc/eggdrop-devel/pkg-plist
@@ -0,0 +1,185 @@
+bin/eggdrop
+etc/eggdrop.conf.sample
+lib/eggdrop/assoc.so
+lib/eggdrop/blowfish.so
+lib/eggdrop/channels.so
+lib/eggdrop/compress.so
+lib/eggdrop/console.so
+lib/eggdrop/ctcp.so
+lib/eggdrop/dns.so
+lib/eggdrop/filesys.so
+lib/eggdrop/irc.so
+lib/eggdrop/notes.so
+lib/eggdrop/seen.so
+lib/eggdrop/server.so
+lib/eggdrop/share.so
+lib/eggdrop/transfer.so
+lib/eggdrop/uptime.so
+%%DOCSDIR%%/ABOUT
+%%DOCSDIR%%/BANS
+%%DOCSDIR%%/BOTNET
+%%DOCSDIR%%/BUG-REPORT
+%%DOCSDIR%%/COMPILE-GUIDE
+%%DOCSDIR%%/CONTENTS
+%%DOCSDIR%%/Changes1.8
+%%DOCSDIR%%/FIRST-SCRIPT
+%%DOCSDIR%%/KNOWN-PROBLEMS
+%%DOCSDIR%%/MODULES
+%%DOCSDIR%%/PARTYLINE
+%%DOCSDIR%%/PATCH-HOWTO
+%%DOCSDIR%%/TEXT-SUBSTITUTIONS
+%%DOCSDIR%%/TRICKS
+%%DOCSDIR%%/USERS
+%%DOCSDIR%%/WEIRD-MESSAGES
+%%DOCSDIR%%/html/about.html
+%%DOCSDIR%%/html/app-problems.html
+%%DOCSDIR%%/html/app-textsub.html
+%%DOCSDIR%%/html/app-tricks.html
+%%DOCSDIR%%/html/app-weird.html
+%%DOCSDIR%%/html/bans.html
+%%DOCSDIR%%/html/botnet.html
+%%DOCSDIR%%/html/compiling.html
+%%DOCSDIR%%/html/egg-core.html
+%%DOCSDIR%%/html/faqs.html
+%%DOCSDIR%%/html/features.html
+%%DOCSDIR%%/html/index.html
+%%DOCSDIR%%/html/install.html
+%%DOCSDIR%%/html/mod-assoc.html
+%%DOCSDIR%%/html/mod-blowfish.html
+%%DOCSDIR%%/html/mod-channels.html
+%%DOCSDIR%%/html/mod-compress.html
+%%DOCSDIR%%/html/mod-console.html
+%%DOCSDIR%%/html/mod-ctcp.html
+%%DOCSDIR%%/html/mod-dns.html
+%%DOCSDIR%%/html/mod-filesys.html
+%%DOCSDIR%%/html/mod-irc.html
+%%DOCSDIR%%/html/mod-notes.html
+%%DOCSDIR%%/html/mod-seen.html
+%%DOCSDIR%%/html/mod-server.html
+%%DOCSDIR%%/html/mod-share.html
+%%DOCSDIR%%/html/mod-transfer.html
+%%DOCSDIR%%/html/mod-uptime.html
+%%DOCSDIR%%/html/mod-woobie.html
+%%DOCSDIR%%/html/news.html
+%%DOCSDIR%%/html/party.html
+%%DOCSDIR%%/html/patch-howto.html
+%%DOCSDIR%%/html/readme.html
+%%DOCSDIR%%/html/starting.html
+%%DOCSDIR%%/html/tcl-commands.html
+%%DOCSDIR%%/html/users.html
+%%DOCSDIR%%/settings/CONTENTS
+%%DOCSDIR%%/settings/core.settings
+%%DOCSDIR%%/settings/mod.assoc
+%%DOCSDIR%%/settings/mod.blowfish
+%%DOCSDIR%%/settings/mod.channels
+%%DOCSDIR%%/settings/mod.compress
+%%DOCSDIR%%/settings/mod.console
+%%DOCSDIR%%/settings/mod.ctcp
+%%DOCSDIR%%/settings/mod.dns
+%%DOCSDIR%%/settings/mod.filesys
+%%DOCSDIR%%/settings/mod.irc
+%%DOCSDIR%%/settings/mod.notes
+%%DOCSDIR%%/settings/mod.seen
+%%DOCSDIR%%/settings/mod.server
+%%DOCSDIR%%/settings/mod.share
+%%DOCSDIR%%/settings/mod.transfer
+%%DOCSDIR%%/settings/mod.uptime
+%%DOCSDIR%%/settings/mod.woobie
+%%DOCSDIR%%/tcl-commands.doc
+%%DATADIR%%/help/assoc.help
+%%DATADIR%%/help/chaninfo.help
+%%DATADIR%%/help/channels.help
+%%DATADIR%%/help/cmds1.help
+%%DATADIR%%/help/cmds2.help
+%%DATADIR%%/help/compress.help
+%%DATADIR%%/help/console.help
+%%DATADIR%%/help/core.help
+%%DATADIR%%/help/ctcp.help
+%%DATADIR%%/help/filesys.help
+%%DATADIR%%/help/irc.help
+%%DATADIR%%/help/msg/irc.help
+%%DATADIR%%/help/msg/notes.help
+%%DATADIR%%/help/msg/seen.help
+%%DATADIR%%/help/notes.help
+%%DATADIR%%/help/seen.help
+%%DATADIR%%/help/server.help
+%%DATADIR%%/help/set/channels.help
+%%DATADIR%%/help/set/cmds1.help
+%%DATADIR%%/help/set/compress.help
+%%DATADIR%%/help/set/console.help
+%%DATADIR%%/help/set/ctcp.help
+%%DATADIR%%/help/set/filesys.help
+%%DATADIR%%/help/set/irc.help
+%%DATADIR%%/help/set/notes.help
+%%DATADIR%%/help/set/server.help
+%%DATADIR%%/help/set/share.help
+%%DATADIR%%/help/set/transfer.help
+%%DATADIR%%/help/share.help
+%%DATADIR%%/help/transfer.help
+%%DATADIR%%/help/uptime.help
+%%DATADIR%%/language/assoc.danish.lang
+%%DATADIR%%/language/assoc.english.lang
+%%DATADIR%%/language/assoc.finnish.lang
+%%DATADIR%%/language/assoc.french.lang
+%%DATADIR%%/language/assoc.german.lang
+%%DATADIR%%/language/console.danish.lang
+%%DATADIR%%/language/console.english.lang
+%%DATADIR%%/language/console.finnish.lang
+%%DATADIR%%/language/console.french.lang
+%%DATADIR%%/language/console.german.lang
+%%DATADIR%%/language/core.danish.lang
+%%DATADIR%%/language/core.english.lang
+%%DATADIR%%/language/core.finnish.lang
+%%DATADIR%%/language/core.french.lang
+%%DATADIR%%/language/core.german.lang
+%%DATADIR%%/language/filesys.danish.lang
+%%DATADIR%%/language/filesys.english.lang
+%%DATADIR%%/language/filesys.finnish.lang
+%%DATADIR%%/language/filesys.french.lang
+%%DATADIR%%/language/filesys.german.lang
+%%DATADIR%%/language/notes.danish.lang
+%%DATADIR%%/language/notes.english.lang
+%%DATADIR%%/language/notes.finnish.lang
+%%DATADIR%%/language/notes.french.lang
+%%DATADIR%%/language/notes.german.lang
+%%DATADIR%%/language/transfer.danish.lang
+%%DATADIR%%/language/transfer.english.lang
+%%DATADIR%%/language/transfer.finnish.lang
+%%DATADIR%%/language/transfer.french.lang
+%%DATADIR%%/language/transfer.german.lang
+%%DATADIR%%/scripts/CONTENTS
+%%DATADIR%%/scripts/action.fix.tcl
+%%DATADIR%%/scripts/alltools.tcl
+%%DATADIR%%/scripts/autobotchk
+%%DATADIR%%/scripts/botchk
+%%DATADIR%%/scripts/cmd_resolve.tcl
+%%DATADIR%%/scripts/compat.tcl
+%%DATADIR%%/scripts/dccwhois.tcl
+%%DATADIR%%/scripts/getops.tcl
+%%DATADIR%%/scripts/help/cmd_resolve.help
+%%DATADIR%%/scripts/help/msg/userinfo.help
+%%DATADIR%%/scripts/help/userinfo.help
+%%DATADIR%%/scripts/klined.tcl
+%%DATADIR%%/scripts/notes2.tcl
+%%DATADIR%%/scripts/ques5.tcl
+%%DATADIR%%/scripts/quotepass.tcl
+%%DATADIR%%/scripts/quotepong.tcl
+%%DATADIR%%/scripts/sentinel.tcl
+%%DATADIR%%/scripts/userinfo.tcl
+%%DATADIR%%/scripts/weed
+%%DATADIR%%/text/banner
+%%DATADIR%%/text/motd
+@dirrmtry share/licenses
+@dirrm %%DATADIR%%/text
+@dirrm %%DATADIR%%/scripts/help/msg
+@dirrm %%DATADIR%%/scripts/help
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/language
+@dirrm %%DATADIR%%/help/set
+@dirrm %%DATADIR%%/help/msg
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/settings
+@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrm lib/eggdrop