aboutsummaryrefslogtreecommitdiff
path: root/irc/epic4
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:35:18 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:35:18 +0000
commit41df51b901376c288e0f3e07f351a976a0c9bfec (patch)
tree52b9a3d025c01518fdcf242dc87c1cd46066c40a /irc/epic4
parent2edb4e18ac5718d6f70776448c70ae97dff2877b (diff)
downloadports-41df51b901376c288e0f3e07f351a976a0c9bfec.tar.gz
ports-41df51b901376c288e0f3e07f351a976a0c9bfec.zip
Convert to OPTIONS framework.
Fix misformatted IGNORE message. Tighten up CONFLICTS. PR: ports/92925 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> Approved by: Josh Paetzel <josh@tcbug.org> (maintainer)
Notes
Notes: svn path=/head/; revision=155700
Diffstat (limited to 'irc/epic4')
-rw-r--r--irc/epic4/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index fe56408aa0c9..6761d32bb3a2 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -21,12 +21,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= josh@tcbug.org
COMMENT= The (E)nhanced (P)rogrammable (I)RC-II (C)lient
-CONFLICTS= epic5-*
+CONFLICTS= epic5-[0-9]*
GNU_CONFIGURE= yes
MAN1= epic.1
USE_OPENSSL= yes
+OPTIONS= IPV6 "IPv6 support" on \
+ TCL "TCL support" on \
+ PERL "Perl scripting support" off
+
.include <bsd.port.pre.mk>
## WITHOUT_IPV6: disable IPv6 support
@@ -51,7 +55,7 @@ CONFIGURE_ARGS+= --with-tcl
#
.if defined(WITH_PERL)
.if ${PERL_LEVEL} < 500601
-IGNORE= "Perl 5.6.1 or newer is required; we recommend perl 5.8.5"
+IGNORE= requires perl 5.6.1 or newer; we recommend perl 5.8.5
.endif
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE