aboutsummaryrefslogtreecommitdiff
path: root/irc/ezbounce
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-16 15:18:19 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-16 15:18:19 +0000
commit96f17868bac1609ff8cc8ac889cb6dc4aafce01b (patch)
tree3e315404d5051650d5e7e9c378f93a32110a1fc6 /irc/ezbounce
parenta5b3bd232f64ce92e65a0ce00e8c65a4437d7d10 (diff)
downloadports-96f17868bac1609ff8cc8ac889cb6dc4aafce01b.tar.gz
ports-96f17868bac1609ff8cc8ac889cb6dc4aafce01b.zip
Respect CFLAGS,
Unbreak with gcc 3.4
Notes
Notes: svn path=/head/; revision=116408
Diffstat (limited to 'irc/ezbounce')
-rw-r--r--irc/ezbounce/Makefile6
-rw-r--r--irc/ezbounce/files/patch-linkedlist.h20
2 files changed, 22 insertions, 4 deletions
diff --git a/irc/ezbounce/Makefile b/irc/ezbounce/Makefile
index c03e26be16a6..aa3c42f7cbc6 100644
--- a/irc/ezbounce/Makefile
+++ b/irc/ezbounce/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A highly configurable IRC Proxy
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
MAN1= ezbounce.1
@@ -35,10 +36,6 @@ PLIST_SUB+= SSL="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
pre-everything::
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@@ -51,6 +48,7 @@ pre-everything::
post-patch:
@${SED} -e "s:/path/to:${PREFIX}/sbin:" ${WRKSRC}/sample.conf > \
${WRKSRC}/ezb.conf.default
+ ${REINPLACE_CMD} -e "s,-O2,${CFLAGS}," ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ezbounce ${PREFIX}/sbin
diff --git a/irc/ezbounce/files/patch-linkedlist.h b/irc/ezbounce/files/patch-linkedlist.h
new file mode 100644
index 000000000000..be5f1a3a74e6
--- /dev/null
+++ b/irc/ezbounce/files/patch-linkedlist.h
@@ -0,0 +1,20 @@
+--- lib/linkedlist.h.orig Mon Aug 16 16:53:58 2004
++++ lib/linkedlist.h Mon Aug 16 17:08:25 2004
+@@ -89,7 +89,7 @@
+ list_iterator(__list_core * x) : __list_iter(x) { }
+ T * next() { return (T *) __list_iter::next(); }
+ T * remove() { return (T *) __list_iter::remove(); }
+- T * get(void) { return (T *) __list_iter::get(); }
++ //T * get(void) { return (T *) __list_iter::get(); }
+ T * set(int x) { return (T *) __list_iter::set(x); }
+ };
+
+@@ -97,7 +97,7 @@
+ {
+ public:
+ int add(T *x) { return __list_core::add((void *) x); }
+- int add(int w, T * x) { return __list_core::insert(w, (void *) x); }
++ //int add(int w, T * x) { return __list_core::insert(w, (void *) x); }
+ T * get(int idx) { return (T *) __list_core::get(idx); }
+ T * remove(int idx) { return (T *) __list_core::remove(idx); }
+ bool remove(T * d) { return __list_core::remove(d); }