aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-06 20:06:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-09-06 20:06:24 +0000
commit4c0fcf3190771c28fb68ea7267a50d8f8bb044b9 (patch)
tree4a140541b27c3db7c330d8ffd2c4b97ec8f44b29 /irc/p5-POE-Component-IRC/Makefile
parentcde81be9bca6b918cf6bdf54b8171d3c6ccce9f3 (diff)
downloadports-4c0fcf3190771c28fb68ea7267a50d8f8bb044b9.tar.gz
ports-4c0fcf3190771c28fb68ea7267a50d8f8bb044b9.zip
Update to 6.90
- Add LICENSE_FILE - Sort *_DEPENDS - Add missing OPTIONS_DEFINE=EXAMPLES - Add NO_ARCH - Convert to options target helper Changes: http://search.cpan.org/dist/POE-Component-IRC/Changes
Notes
Notes: svn path=/head/; revision=449367
Diffstat (limited to 'irc/p5-POE-Component-IRC/Makefile')
-rw-r--r--irc/p5-POE-Component-IRC/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
index 33268508d6a9..951333716fa5 100644
--- a/irc/p5-POE-Component-IRC/Makefile
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= POE-Component-IRC
-PORTVERSION= 6.88
-PORTREVISION= 1
+PORTVERSION= 6.90
CATEGORIES= irc devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:BINGOS
@@ -14,23 +13,26 @@ COMMENT= Fully event-driven IRC client module
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= p5-POE>=1.311:devel/p5-POE \
- p5-POE-Component-Syndicator>=0.01:devel/p5-POE-Component-Syndicator \
- p5-POE-Filter-IRCD>=2.42:irc/p5-POE-Filter-IRCD \
+BUILD_DEPENDS= p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
+ p5-POE>=1.311:devel/p5-POE \
p5-POE-Component-Client-DNS>=0.99:dns/p5-POE-Component-Client-DNS \
- p5-POE-Component-SSLify>0:security/p5-POE-Component-SSLify \
- p5-IRC-Utils>=0.12:irc/p5-IRC-Utils \
- p5-List-MoreUtils>0:lang/p5-List-MoreUtils
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-Test-Differences>=0:devel/p5-Test-Differences
+ p5-POE-Component-SSLify>=0:security/p5-POE-Component-SSLify \
+ p5-POE-Component-Syndicator>=0.01:devel/p5-POE-Component-Syndicator \
+ p5-POE-Filter-IRCD>=2.42:irc/p5-POE-Filter-IRCD
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Differences>=0.610:devel/p5-Test-Differences
+
+OPTIONS_DEFINE= EXAMPLES
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
PORTEXAMPLES= *
-post-install:
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}