aboutsummaryrefslogtreecommitdiff
path: root/irc/quassel-core
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-10-29 17:01:30 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-10-29 17:01:30 +0000
commit49c90d66592ab11833676bf378abebff776bb533 (patch)
tree148b9331f417dc3b2a017c0f1e5fb37a48f18650 /irc/quassel-core
parenta4d3d31ce2266c5912a6a885557e813ca52ff36c (diff)
downloadports-49c90d66592ab11833676bf378abebff776bb533.tar.gz
ports-49c90d66592ab11833676bf378abebff776bb533.zip
irc/quassel: split into two ports (client and server)
irc/quassel-core provides the server back-end. irc/quassel provides the client front-end. irc/quassel can also be built with the MONO option enabled to also install the client and server combined into a single monolithic binary. Submitted by: Chris Rees <crees@physics.org> (in part) Approved by: adamw (mentor, implicit)
Notes
Notes: svn path=/head/; revision=424921
Diffstat (limited to 'irc/quassel-core')
-rw-r--r--irc/quassel-core/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/irc/quassel-core/Makefile b/irc/quassel-core/Makefile
new file mode 100644
index 000000000000..fa57c26872d8
--- /dev/null
+++ b/irc/quassel-core/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -core
+
+COMMENT= Qt 5 based distributed IRC client (core/server only)
+
+LIB_DEPENDS= libqca-qt5.so:devel/qca-qt5
+
+MASTERDIR= ${.CURDIR}/../quassel
+
+USE_QT5= buildtools_build core network qmake_build script sql sql-sqlite3_run
+CMAKE_ARGS+= -DWITH_KDE=off \
+ -DUSE_QT5=on \
+ -DWANT_CORE=on \
+ -DWANT_QTCLIENT=off \
+ -DWANT_MONO=off
+
+USE_RC_SUBR= quasselcore
+USERS= quasselcore
+GROUPS= ${USERS}
+SUB_FILES= pkg-message
+PLIST= ${.CURDIR}/pkg-plist
+PLIST_FILES= bin/quasselcore
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quasselcore
+
+.include "${MASTERDIR}/Makefile"