aboutsummaryrefslogtreecommitdiff
path: root/irc/quassel
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-10-27 15:34:56 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-10-27 15:34:56 +0000
commit896e7d8294238b4a1952844668227d263afab813 (patch)
treea43695f5fe19869baa8a7643326f5b18ec8d419f /irc/quassel
parenta40bac5fe1e9bd12a6b03a94e9563192caff3ba5 (diff)
downloadports-896e7d8294238b4a1952844668227d263afab813.tar.gz
ports-896e7d8294238b4a1952844668227d263afab813.zip
irc/quasssel: Patch CMakeLists.txt to fix build against SSL with Qt 5.6
PR: 213581 Submitted by: Christian Schwarz (me@cschwarz.com) Submitted by: tcberner Reviewed by: mat Approved by: adamw (mentor, implicit) Obtained from: https://github.com/quassel/quassel/commit/4768c9e99f99b581d4e32e797db91d0182391696 MFH: 2016Q4 Differential Revision: https://reviews.freebsd.org/D8294
Notes
Notes: svn path=/head/; revision=424771
Diffstat (limited to 'irc/quassel')
-rw-r--r--irc/quassel/Makefile1
-rw-r--r--irc/quassel/files/patch-CMakeLists.txt19
2 files changed, 20 insertions, 0 deletions
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 2b6d5704536f..a1205c6c2dd9 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quassel
PORTVERSION= 0.12.4
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.quassel-irc.org/pub/
diff --git a/irc/quassel/files/patch-CMakeLists.txt b/irc/quassel/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..514bc730931c
--- /dev/null
+++ b/irc/quassel/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+From 4768c9e99f99b581d4e32e797db91d0182391696 Mon Sep 17 00:00:00 2001
+From: martin <martin.sandsmark@kde.org>
+Date: Tue, 7 Jun 2016 00:37:22 +0200
+Subject: [PATCH] Fix the SSL check with Qt 5.6 and GCC 5 (#199)
+
+--- CMakeLists.txt.orig 2016-04-24 20:36:58 UTC
++++ CMakeLists.txt
+@@ -428,6 +428,11 @@ endif()
+ cmake_push_check_state(RESET)
+ set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
++
++if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
++ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
++endif()
++
+ check_cxx_source_compiles("
+ #include \"qglobal.h\"
+ #if defined QT_NO_SSL