aboutsummaryrefslogtreecommitdiff
path: root/irc/rbot
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-12-14 20:58:10 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-12-14 20:58:10 +0000
commita6364ac160ccde7a2b4da12e7d93f35ece39b1f9 (patch)
tree73d68b5faf177dedd4189b12806e3c376cb0a337 /irc/rbot
parent54c093ebb8956e7b2756e1eff4d8df81cd7327b6 (diff)
downloadports-a6364ac160ccde7a2b4da12e7d93f35ece39b1f9.tar.gz
ports-a6364ac160ccde7a2b4da12e7d93f35ece39b1f9.zip
Update to 20160325 and fix with newer ruby versions.
Reported by: swills
Notes
Notes: svn path=/head/; revision=456373
Diffstat (limited to 'irc/rbot')
-rw-r--r--irc/rbot/Makefile10
-rw-r--r--irc/rbot/distinfo6
-rw-r--r--irc/rbot/files/patch-setup.rb19
-rw-r--r--irc/rbot/pkg-plist6
4 files changed, 33 insertions, 8 deletions
diff --git a/irc/rbot/Makefile b/irc/rbot/Makefile
index 0a392353df91..82aca7c247dc 100644
--- a/irc/rbot/Makefile
+++ b/irc/rbot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rbot
-PORTVERSION= 20150311
+PORTVERSION= 20160325
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= irc ruby
@@ -16,6 +16,9 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/GPLv2
LICENSE_FILE_MIT= ${WRKSRC}/COPYING.rbot
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/tokyocabinet.so:databases/ruby-tokyocabinet \
+ rubygem-gettext>=0:devel/rubygem-gettext \
+ rubygem-htmlentities>=0:textproc/rubygem-htmlentities \
+ rubygem-hpricot>=0:www/rubygem-hpricot \
rubygem-mechanize>=0:www/rubygem-mechanize \
rubygem-tzinfo>=0:devel/rubygem-tzinfo \
rubygem-oauth>=0:net/rubygem-oauth \
@@ -28,7 +31,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GITHUB= yes
GH_ACCOUNT= ruby-${PORTNAME}
-GH_TAGNAME= 545f217
+GH_TAGNAME= e358601cc521d8aced941eb928fae2d8c53cf0c2
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
@@ -37,9 +40,6 @@ PORTDOCS= REQUIREMENTS ChangeLog
OPTIONS_DEFINE= DOCS
-BROKEN_RUBY22= yes
-BROKEN_RUBY23= yes
-
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/irc/rbot/distinfo b/irc/rbot/distinfo
index 9cbf31a91e72..70ad48cca173 100644
--- a/irc/rbot/distinfo
+++ b/irc/rbot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480789250
-SHA256 (ruby-rbot-rbot-20160326-545f217_GH0.tar.gz) = 3398506106c81fe5454ea839eaeac77301101abc6d575c012add24f4a83110ae
-SIZE (ruby-rbot-rbot-20160326-545f217_GH0.tar.gz) = 751667
+TIMESTAMP = 1513283166
+SHA256 (ruby-rbot-rbot-20160325-e358601cc521d8aced941eb928fae2d8c53cf0c2_GH0.tar.gz) = ae638f53607ad0f1d365ff3c4408ef3c27c8e0f5e83ae355742185c1076ec96e
+SIZE (ruby-rbot-rbot-20160325-e358601cc521d8aced941eb928fae2d8c53cf0c2_GH0.tar.gz) = 762685
diff --git a/irc/rbot/files/patch-setup.rb b/irc/rbot/files/patch-setup.rb
new file mode 100644
index 000000000000..45853292e8fe
--- /dev/null
+++ b/irc/rbot/files/patch-setup.rb
@@ -0,0 +1,19 @@
+--- setup.rb.orig 2017-12-14 20:26:49 UTC
++++ setup.rb
+@@ -282,7 +282,6 @@ class ConfigTable
+ 'site-ruby-common' => 'siteruby', # For backward compatibility
+ 'site-ruby' => 'siterubyver', # For backward compatibility
+ 'bin-dir' => 'bindir',
+- 'bin-dir' => 'bindir',
+ 'rb-dir' => 'rbdir',
+ 'so-dir' => 'sodir',
+ 'data-dir' => 'datadir',
+@@ -786,7 +785,7 @@ class ToplevelInstaller
+ else
+ require 'rbconfig'
+ end
+- ::Config::CONFIG
++ ::RbConfig::CONFIG
+ end
+
+ def initialize(ardir_root, config)
diff --git a/irc/rbot/pkg-plist b/irc/rbot/pkg-plist
index c9049f78186b..e411686f8392 100644
--- a/irc/rbot/pkg-plist
+++ b/irc/rbot/pkg-plist
@@ -7,6 +7,8 @@ bin/rbotdb
%%RUBY_SITELIBDIR%%/rbot/core/config.rb
%%RUBY_SITELIBDIR%%/rbot/core/filters_ui.rb
%%RUBY_SITELIBDIR%%/rbot/core/irclog.rb
+%%RUBY_SITELIBDIR%%/rbot/core/journal.rb
+%%RUBY_SITELIBDIR%%/rbot/core/journal_irclog.rb
%%RUBY_SITELIBDIR%%/rbot/core/unicode.rb
%%RUBY_SITELIBDIR%%/rbot/core/userdata.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/agent.rb
@@ -15,12 +17,16 @@ bin/rbotdb
%%RUBY_SITELIBDIR%%/rbot/core/utils/httputil.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/parse_time.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/utils.rb
+%%RUBY_SITELIBDIR%%/rbot/core/utils/where_is.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/wordlist.rb
%%RUBY_SITELIBDIR%%/rbot/core/webservice.rb
%%RUBY_SITELIBDIR%%/rbot/core/wordlist_ui.rb
%%RUBY_SITELIBDIR%%/rbot/irc.rb
%%RUBY_SITELIBDIR%%/rbot/ircbot.rb
%%RUBY_SITELIBDIR%%/rbot/ircsocket.rb
+%%RUBY_SITELIBDIR%%/rbot/journal.rb
+%%RUBY_SITELIBDIR%%/rbot/journal/mongo.rb
+%%RUBY_SITELIBDIR%%/rbot/journal/postgres.rb
%%RUBY_SITELIBDIR%%/rbot/language.rb
%%RUBY_SITELIBDIR%%/rbot/load-gettext.rb
%%RUBY_SITELIBDIR%%/rbot/maskdb.rb