aboutsummaryrefslogtreecommitdiff
path: root/irc/srvx/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 23:40:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 23:40:15 +0000
commit42df5aefce691ec74c6172f3e3a83b899f28c271 (patch)
tree38bf1f3a05063b58f1390c5c800779c9be4cfb61 /irc/srvx/Makefile
parent7265ee7c46fe1ff2ee1662ee7ba450729992904f (diff)
downloadports-42df5aefce691ec74c6172f3e3a83b899f28c271.tar.gz
ports-42df5aefce691ec74c6172f3e3a83b899f28c271.zip
- Update to 1.4.1
PR: 124314 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=214404
Diffstat (limited to 'irc/srvx/Makefile')
-rw-r--r--irc/srvx/Makefile83
1 files changed, 37 insertions, 46 deletions
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index 47f55429e5a4..54741e2ac579 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -6,16 +6,37 @@
#
PORTNAME= srvx
-PORTVERSION= 1.3
+PORTVERSION= 1.3.1
CATEGORIES= irc net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= srvx
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= Srvx IRC services
+COMMENT= A set of services for ircu P10 protocol networks
+
+OPTIONS= PROTOCOL_BAHAMUT "Enables Bahamut protocol (P10 is default)" "on" \
+ DEBUG "Enables debug mode" "off"
+
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-getopt
+
+SUB_FILES= pkg-message
+
+PORTDOCS= chanserv.help \
+ global.help \
+ mod-helpserv.help \
+ mod-memoserv.help \
+ mod-sockcheck.help \
+ modcmd.help \
+ nickserv.help \
+ opserv.help \
+ saxdb.help \
+ sendmail.help
+PLIST_FILES= bin/srvx \
+ etc/srvx.conf.example \
+ etc/sockcheck.conf.example
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
@@ -25,47 +46,17 @@ CONFIGURE_ARGS+= --enable-debug
CONFIGURE_ARGS+= --with-protocol=bahamut
.endif
-PLIST_FILES= bin/srvx \
- etc/srvx.conf.example \
- etc/sockcheck.conf.example \
- share/doc/${PORTNAME}/chanserv.help \
- share/doc/${PORTNAME}/global.help \
- share/doc/${PORTNAME}/mod-helpserv.help \
- share/doc/${PORTNAME}/mod-memoserv.help \
- share/doc/${PORTNAME}/mod-sockcheck.help \
- share/doc/${PORTNAME}/modcmd.help \
- share/doc/${PORTNAME}/nickserv.help \
- share/doc/${PORTNAME}/opserv.help \
- share/doc/${PORTNAME}/saxdb.help \
- share/doc/${PORTNAME}/sendmail.help
-PLIST_DIRS= share/doc/${PORTNAME}
-
-pre-fetch:
- @ ${ECHO} ""
- @ ${ECHO} "--------------------------------------------------------------------------------"
- @ ${ECHO} ""
- @ ${ECHO} "The following build options are availabe:"
- @ ${ECHO} ""
- @ ${ECHO} " WITH_PROTOCOL_BAHAMUT=yes Enables Bahamut protocol"
- @ ${ECHO} " (P10 is default)."
- @ ${ECHO} ""
- @ ${ECHO} " WITH_DEBUG=yes Enables debug mode."
- @ ${ECHO} ""
- @ ${ECHO} "--------------------------------------------------------------------------------"
- @ ${ECHO} ""
-
-post-install:
- @ ${ECHO} ""
- @ ${ECHO} " When you 'make deinstall', any files generated by ${PORTNAME} (logs, etc)"
- @ ${ECHO} " will remain in ${PREFIX}/etc/. These files must be removed manually."
- @ ${ECHO} ""
- @ ${ECHO} " ${PORTNAME} .help files are located in ${DOCSDIR}."
- @ ${ECHO} ""
-
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|= "srvx.conf"|= "${PREFIX}/etc/srx.conf"|g' \
+ ${WRKSRC}/src/main.c
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/srvx ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/*.conf.example ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/*.help ${DOCSDIR}
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>