aboutsummaryrefslogtreecommitdiff
path: root/irc/srvx
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-22 08:27:03 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-22 08:27:03 +0000
commitca5125658ce1e526f53b4ec987a23c50b72b576c (patch)
tree87dbb12ba87fefac94175255b2a7d65fd7813e7c /irc/srvx
parent31497a2a38216c0ee9829b3d67e1f9aa935ec20f (diff)
downloadports-ca5125658ce1e526f53b4ec987a23c50b72b576c.tar.gz
ports-ca5125658ce1e526f53b4ec987a23c50b72b576c.zip
- Fix parallel (-jX) builds, drop vile MAKE_JOBS_UNSAFE
- Define LICENSE (GPLv2), move OPTIONS block down a bit - Rename one option (PROTOCOL_BAHAMUT -> BAHAMUT) - Drop an article from COMMENT, contract PORTDOCS - Pad pkg-message display; do misc. cleanups while here - Reformat port description; terminate WWW with a slash Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Notes
Notes: svn path=/head/; revision=325176
Diffstat (limited to 'irc/srvx')
-rw-r--r--irc/srvx/Makefile40
-rw-r--r--irc/srvx/files/patch-Makefile.in23
-rw-r--r--irc/srvx/pkg-descr20
3 files changed, 42 insertions, 41 deletions
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index b9aec66b69a0..e7156fba3e37 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -7,45 +7,29 @@ CATEGORIES= irc net
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A set of services for ircu P10 protocol networks
+COMMENT= Services for ircu P10 protocol networks
-MAKE_JOBS_UNSAFE=yes
-
-OPTIONS_DEFINE= PROTOCOL_BAHAMUT DEBUG
-OPTIONS_DEFAULT= PROTOCOL_BAHAMUT
-PROTOCOL_BAHAMUT_DESC= Enables Bahamut protocol (P10 is default)
+LICENSE= GPLv2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-getopt
SUB_FILES= pkg-message
-PORTDOCS= chanserv.help \
- global.help \
- mod-helpserv.help \
- mod-memoserv.help \
- mod-sockcheck.help \
- modcmd.help \
- nickserv.help \
- opserv.help \
- saxdb.help \
- sendmail.help
-PLIST_FILES= bin/srvx \
- etc/srvx.conf.example \
- etc/sockcheck.conf.example
+PLIST_FILES= bin/srvx etc/srvx.conf.example etc/sockcheck.conf.example
+PORTDOCS= *
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= BAHAMUT DEBUG
+OPTIONS_DEFAULT= BAHAMUT
+BAHAMUT_DESC= Enable Bahamut protocol (P10 is default)
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+DEBUG_CONFIGURE_ON= --enable-debug
+BAHAMUT_CONFIGURE_ON= --with-protocol=bahamut
-.if ${PORT_OPTIONS:MPROTOCOL_BAHAMUT}
-CONFIGURE_ARGS+= --with-protocol=bahamut
-.endif
+.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|= "srvx.conf"|= "${PREFIX}/etc/srx.conf"|g' \
+ @${REINPLACE_CMD} -e 's|srvx\.conf|${PREFIX}/etc/srx.conf|' \
${WRKSRC}/src/main.c
do-install:
@@ -55,6 +39,8 @@ do-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/*.help ${DOCSDIR}
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/irc/srvx/files/patch-Makefile.in b/irc/srvx/files/patch-Makefile.in
new file mode 100644
index 000000000000..2eeb57699e97
--- /dev/null
+++ b/irc/srvx/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in.orig 2006-05-14 10:52:30.000000000 +0800
++++ Makefile.in 2013-08-22 16:08:40.000000000 +0800
+@@ -186,6 +186,7 @@
+ SUBDIRS = @MY_SUBDIRS@
+ DIST_SUBDIRS = src rx
+ all: all-recursive
++ cp ./src/srvx $(srcdir)/src/*.help .
+
+ .SUFFIXES:
+ am--refresh:
+@@ -601,12 +602,6 @@
+ mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
+ tags tags-recursive uninstall uninstall-am uninstall-info-am
+
+-
+-all: srvx
+-
+-srvx: src/srvx
+- cp ./src/srvx $(srcdir)/src/*.help .
+-
+ install-exec-local:
+ $(INSTALL) -d -m 755 $(prefix)
+ $(INSTALL) -m 744 ./src/srvx $(prefix)
diff --git a/irc/srvx/pkg-descr b/irc/srvx/pkg-descr
index ffa238486302..0292a6c7f355 100644
--- a/irc/srvx/pkg-descr
+++ b/irc/srvx/pkg-descr
@@ -1,15 +1,7 @@
-srvx is a set of IRC services for ircu P10 protocol networks; it
-is developed by a team of programmers affiliated with the GameSurge
-IRC Network. srvx is designed to be a fast, extensible, scalable
-and reliable provider of NickServ, ChanServ, HelpServ, OperServ,
-and Global services as well as advanced proxy detection.
+srvx is a set of IRC services for ircu P10 protocol networks; it is
+developed by a team of programmers affiliated with the GameSurge IRC
+Network. srvx is designed to be a fast, extensible, scalable, and
+reliable provider of NickServ, ChanServ, HelpServ, OperServ, and Global
+services as well as advanced proxy detection.
-srvx is open source software; the source is available for download under
-the terms and conditions of the GNU General Public License, commonly known
-as the GNU GPL.
-
-The authors can be contacted via irc on irc.gamesurge.net in channel #srvx.
-Note that only one of the many authors is listed below, see website for a
-full list.
-
-WWW: http://www.srvx.net
+WWW: http://www.srvx.net/