aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-02-26 16:00:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-02-26 16:00:38 +0000
commitab5465da21c3b50e969a75aed4ddf9bf9f69a55a (patch)
treec9f6cd68a6ee541639019665f315a036dbef1261 /irc/weechat/Makefile
parent3f2433da29c4c72188229e40259c3e22e324a688 (diff)
downloadports-ab5465da21c3b50e969a75aed4ddf9bf9f69a55a.tar.gz
ports-ab5465da21c3b50e969a75aed4ddf9bf9f69a55a.zip
Readd removed ${PORTSDIR} in dependency chain too early there are still fixes
needed in bsd.ports.mk to allow removing them entirely
Notes
Notes: svn path=/head/; revision=409617
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index d7bc4509a685..f337961ab5d2 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -18,8 +18,8 @@ USES= cmake iconv localbase ncurses tar:bzip2
CMAKE_ARGS+= -DENABLE_GUILE=no \
-DICONV_INCLUDE_PATH=${ICONV_INCLUDE_PATH}
-LIB_DEPENDS+= libcurl.so:ftp/curl \
- libgcrypt.so:security/libgcrypt
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA JAVASCRIPT CHARSET BACKTRACE ASPELL \
GNUTLS CA_BUNDLE NLS ICON MANPAGES DOCS
@@ -37,12 +37,12 @@ PYTHON_DESC= Python scripting language support
RUBY_DESC= Ruby scripting language support
ASPELL_CMAKE_OFF= -DENABLE_ASPELL=no
-ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
BACKTRACE_USES= execinfo
CA_BUNDLE_CMAKE_ON= -DCA_FILE=${LOCALBASE}/share/certs/ca-root-nss.crt
-CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
CHARSET_CMAKE_OFF= -DENABLE_CHARSET=no
@@ -50,11 +50,11 @@ DOCS_CMAKE_ON= -DENABLE_DOC=yes
JAVASCRIPT_CMAKE_OFF= -DENABLE_JAVASCRIPT=no
JAVASCRIPT_CMAKE_ON= -DENABLE_JAVASCRIPT=yes
-JAVASCRIPT_LIB_DEPENDS= libv8.so:lang/v8
+JAVASCRIPT_LIB_DEPENDS= libv8.so:${PORTSDIR}/lang/v8
GNUTLS_CMAKE_OFF= -DENABLE_GNUTLS=no
GNUTLS_USES= pkgconfig
-GNUTLS_LIB_DEPENDS= libgnutls.so.28:security/gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so.28:${PORTSDIR}/security/gnutls
LUA_CMAKE_OFF= -DENABLE_LUA=no
LUA_CMAKE_ON= -DBSD_LUA_LIBDIR=${LUA_LIBDIR} \
@@ -89,10 +89,10 @@ TCL_USES= tcl:85+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MMANPAGES}
-BUILD_DEPENDS+= xsltproc:textproc/libxslt \
- docbook-xsl>=0:textproc/docbook-xsl \
- asciidoc:textproc/asciidoc \
- source-highlight>=3.1.5:textproc/source-highlight
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
+ asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
.endif
post-patch: