aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-05-14 14:27:49 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-05-14 14:27:49 +0000
commitc64be2313bc083bd7149e5910d60d0bd6d48f22f (patch)
treeeaf78cc2961ce126ad8e36a31ea4e195a3397db8 /irc/weechat
parent86479bf740c133c52c304c2fb8d386cea63a6389 (diff)
downloadports-c64be2313bc083bd7149e5910d60d0bd6d48f22f.tar.gz
ports-c64be2313bc083bd7149e5910d60d0bd6d48f22f.zip
irc/weechat: Update to 1.8
- Bugfix and new features release
Notes
Notes: svn path=/head/; revision=440880
Diffstat (limited to 'irc/weechat')
-rw-r--r--irc/weechat/Makefile2
-rw-r--r--irc/weechat/distinfo6
-rw-r--r--irc/weechat/files/patch-CMakeLists.txt11
-rw-r--r--irc/weechat/pkg-plist1
4 files changed, 11 insertions, 9 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 52e19afaedc2..0d426fa0b91a 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= weechat
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8
CATEGORIES= irc
MASTER_SITES= https://weechat.org/files/src/
diff --git a/irc/weechat/distinfo b/irc/weechat/distinfo
index 359a76f3d7ee..a9d650b7e433 100644
--- a/irc/weechat/distinfo
+++ b/irc/weechat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493064823
-SHA256 (weechat-1.7.1.tar.xz) = 3f7e04793ce21796369199573d84a04ea23313942af880d2c9600bdc73571c30
-SIZE (weechat-1.7.1.tar.xz) = 1836844
+TIMESTAMP = 1494767076
+SHA256 (weechat-1.8.tar.xz) = b65fc54e965399e31a30448b5f6c8067fcd6ad369e9908ff7c1fd45669c5e017
+SIZE (weechat-1.8.tar.xz) = 1871964
diff --git a/irc/weechat/files/patch-CMakeLists.txt b/irc/weechat/files/patch-CMakeLists.txt
index 9f1f8a1ba02b..fcbd4ed972cf 100644
--- a/irc/weechat/files/patch-CMakeLists.txt
+++ b/irc/weechat/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2016-05-01 10:50:12 UTC
+--- CMakeLists.txt.orig 2017-05-13 05:07:57 UTC
+++ CMakeLists.txt
@@ -64,6 +64,10 @@ else()
set(LIBDIR ${CMAKE_INSTALL_PREFIX}/lib/${PROJECT_NAME})
@@ -11,12 +11,13 @@
if(NOT DEFINED SHAREDIR)
set(SHAREDIR ${CMAKE_INSTALL_PREFIX}/share)
endif()
-@@ -88,10 +92,12 @@ option(ENABLE_GNUTLS "Enable SSLv3/T
+@@ -88,11 +92,13 @@ option(ENABLE_GNUTLS "Enable SSLv3/T
option(ENABLE_LARGEFILE "Enable Large File Support" ON)
option(ENABLE_ALIAS "Enable Alias plugin" ON)
option(ENABLE_ASPELL "Enable Aspell plugin" ON)
+option(ENABLE_BACKTRACE "Enable backtraces (via libexecinfo)" ON)
option(ENABLE_ENCHANT "Enable Enchant lib for Aspell plugin" OFF)
+ option(ENABLE_BUFLIST "Enable Buflist plugin" ON)
option(ENABLE_CHARSET "Enable Charset plugin" ON)
option(ENABLE_EXEC "Enable Exec plugin" ON)
option(ENABLE_FIFO "Enable FIFO plugin" ON)
@@ -24,7 +25,7 @@
option(ENABLE_IRC "Enable IRC plugin" ON)
option(ENABLE_LOGGER "Enable Logger plugin" ON)
option(ENABLE_RELAY "Enable Relay plugin" ON)
-@@ -167,6 +173,7 @@ endif()
+@@ -168,6 +174,7 @@ endif()
# Check for libgcrypt
find_package(GCRYPT REQUIRED)
add_definitions(-DHAVE_GCRYPT)
@@ -32,7 +33,7 @@
list(APPEND EXTRA_LIBS ${GCRYPT_LDFLAGS})
# Check for GnuTLS
-@@ -185,10 +192,12 @@ endif()
+@@ -186,10 +193,12 @@ endif()
find_package(ZLIB REQUIRED)
add_definitions(-DHAVE_ZLIB)
@@ -49,7 +50,7 @@
endif()
# Check for CURL
-@@ -247,7 +256,7 @@ set(exec_prefix "\${prefix}")
+@@ -248,7 +257,7 @@ set(exec_prefix "\${prefix}")
set(libdir "\${exec_prefix}/lib")
set(includedir "\${prefix}/include")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/weechat.pc.in ${CMAKE_CURRENT_BINARY_DIR}/weechat.pc @ONLY)
diff --git a/irc/weechat/pkg-plist b/irc/weechat/pkg-plist
index af4e0af4c602..9b4091eab2c6 100644
--- a/irc/weechat/pkg-plist
+++ b/irc/weechat/pkg-plist
@@ -2,6 +2,7 @@ bin/weechat
bin/weechat-curses
include/weechat/weechat-plugin.h
lib/weechat/plugins/alias.so
+lib/weechat/plugins/buflist.so
lib/weechat/plugins/exec.so
lib/weechat/plugins/fifo.so
lib/weechat/plugins/irc.so