aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-fish/files
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-03-29 16:47:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-03-29 16:47:39 +0000
commit757a28ef9bba586d47f05842df48fc66d2ec5de6 (patch)
treef78a3561e8e6b4fa90d142f4bbc7851eca1c111e /irc/xchat-fish/files
parentfe9f2ce3ee3f21bea560bf02a064033ce68a6839 (diff)
downloadports-757a28ef9bba586d47f05842df48fc66d2ec5de6.tar.gz
ports-757a28ef9bba586d47f05842df48fc66d2ec5de6.zip
- update to 0.98
- take maintainership
Notes
Notes: svn path=/head/; revision=210089
Diffstat (limited to 'irc/xchat-fish/files')
-rw-r--r--irc/xchat-fish/files/Makefile18
-rw-r--r--irc/xchat-fish/files/patch-FiSH.c10
2 files changed, 28 insertions, 0 deletions
diff --git a/irc/xchat-fish/files/Makefile b/irc/xchat-fish/files/Makefile
new file mode 100644
index 000000000000..96a5ea486341
--- /dev/null
+++ b/irc/xchat-fish/files/Makefile
@@ -0,0 +1,18 @@
+# Makefile
+# $FreeBSD$
+
+CC?= cc
+CFLAGS?= -O2 -Wall
+CCFLAGS+= $(CFLAGS) -shared -fPIC -DPIC
+LDFLAGS+= -export-dynamic -shared
+LIBS?=
+
+all:
+ $(CC) $(CCFLAGS) -c SHA-256.c
+ $(CC) $(CCFLAGS) -c base64.c
+ $(CC) $(CCFLAGS) -c blowfish.c
+ $(CC) $(CCFLAGS) -c cfgopts.c
+ $(CC) $(CCFLAGS) -c DH1080.c
+ $(CC) $(CCFLAGS) -c FiSH.c
+ $(CC) $(LDFLAGS) -o xfish.so FiSH.o SHA-256.o base64.o blowfish.o cfgopts.o DH1080.o -lmiracl ${LIBS}
+
diff --git a/irc/xchat-fish/files/patch-FiSH.c b/irc/xchat-fish/files/patch-FiSH.c
new file mode 100644
index 000000000000..16c598bc91ee
--- /dev/null
+++ b/irc/xchat-fish/files/patch-FiSH.c
@@ -0,0 +1,10 @@
+--- FiSH.c.orig 2006-03-15 22:17:58.000000000 +0100
++++ FiSH.c 2008-03-29 17:27:33.000000000 +0100
+@@ -4,6 +4,7 @@
+
+
+ #include "xchat-plugin.h"
++#include <ctype.h>
+ #include "FiSH.h"
+
+ static xchat_plugin *ph=0; // plugin handle