aboutsummaryrefslogtreecommitdiff
path: root/irc/znc
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-01-18 18:58:34 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-01-18 18:58:34 +0000
commit6e90301e5393a9cffb223c198bb7cacf6c5f77e4 (patch)
tree5c669cf6aae48962151279e49e83451442e83092 /irc/znc
parentf5876c4a592e2d738929c1fdc8f6e2baea844741 (diff)
downloadports-6e90301e5393a9cffb223c198bb7cacf6c5f77e4.tar.gz
ports-6e90301e5393a9cffb223c198bb7cacf6c5f77e4.zip
Update to upstream release 1.6.2, cleanup port
Cleanups: - USE_OPENSSL - Convert to OPTION helpers - Remove no longer necessary patch for modperl - Sort OPTIONs - Correct compiler flags detection in configure script PR: 205473 Submitted by: matthew@reztek.cz Reviewed by: riggs Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=406604
Diffstat (limited to 'irc/znc')
-rw-r--r--irc/znc/Makefile58
-rw-r--r--irc/znc/distinfo4
-rw-r--r--irc/znc/files/patch-configure15
-rw-r--r--irc/znc/files/patch-modules-modperl-Makefile_inc11
-rw-r--r--irc/znc/files/patch-src_Csocket.cpp2
5 files changed, 38 insertions, 52 deletions
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index ce9861173659..22f78b36f2cb 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= znc
-PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTVERSION= 1.6.2
CATEGORIES= irc ipv6
MASTER_SITES= http://znc.in/releases/ \
http://znc.in/releases/archive/
@@ -18,58 +17,42 @@ GNU_CONFIGURE= yes
USE_RC_SUBR= znc
USES= compiler:c++11-lib cpe gmake iconv pkgconfig
-NO_OPTIONS_SORT= yes
-
-OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL CHARSET DOCS
+OPTIONS_DEFINE= CHARSET CYRUS DEBUG DOCS IPV6 OPENSSL PERL PYTHON TCL
OPTIONS_DEFAULT= OPENSSL PERL
OPTIONS_SUB= yes
+CHARSET_DESC= Character encoding support via ICU
CYRUS_DESC= Cyrus SASL module
DEBUG_DESC= Debugging support
PERL_DESC= Perl scripting module
PYTHON_DESC= Python scripting module
-CHARSET_DESC= Character encoding support via ICU
TCL_DESC= Tcl scripting module
+CHARSET_CONFIGURE_OFF= --disable-charset
+CHARSET_LIB_DEPENDS= libicuuc.so.55:${PORTSDIR}/devel/icu \
+ libicudata.so.55:${PORTSDIR}/devel/icu
CYRUS_CONFIGURE_ON= --enable-cyrus
CYRUS_LDFLAGS= -L${LOCALBASE}/lib
CYRUS_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
DEBUG_CONFIGURE_ON= --enable-debug
IPV6_CONFIGURE_OFF= --disable-ipv6
+OPENSSL_CONFIGURE_OFF= --disable-openssl
+OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+OPENSSL_USE= openssl=yes
PERL_BUILD_DEPENDS= swig30>=3.0.0:${PORTSDIR}/devel/swig30
PERL_CONFIGURE_ENABLE= perl
PERL_CONFIGURE_ON= --enable-swig
+PERL_USE= perl5=build,run
PERL_USES= perl5
PYTHON_BUILD_DEPENDS= swig30>=3.0.0:${PORTSDIR}/devel/swig30
PYTHON_CONFIGURE_ON= --enable-python=python-${PYTHON_VER} --enable-swig
+PYTHON_USE= perl5=build
PYTHON_USES= perl5 python:3
-OPENSSL_CONFIGURE_OFF= --disable-openssl
-CHARSET_CONFIGURE_OFF= --disable-charset
-CHARSET_LIB_DEPENDS= libicuuc.so.55:${PORTSDIR}/devel/icu \
- libicudata.so.55:${PORTSDIR}/devel/icu
TCL_CONFIGURE_ENABLE= tcl
+TCL_CONFIGURE_ON= --with-tcl=${TCL_LIBDIR}
+TCL_USES= tcl
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-USE_PERL5+= run build
-.endif
-
-.if ${PORT_OPTIONS:MTCL}
-USES+= tcl
-CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USE_PERL5+= build
-.endif
-
-PORTDOCS= README.md
+PORTDOCS= README.md
pre-configure:
# No need to cast to char** in AM_ICONV, fixes charset/iconv detection
@@ -77,14 +60,15 @@ pre-configure:
@${REINPLACE_CMD} -e \
's#(char \*\*)##g' \
${WRKSRC}/configure
+
# Instead of using bundled swig generated files, delete them to force
# regeneration using swig 2.0.11+ (fixes port compilation using clang)
-.if ${PORT_OPTIONS:MPERL}
+#
+pre-configure-PERL-on:
@${RM} ${WRKSRC}/modules/modperl/ZNC.cpp
-.endif
-.if ${PORT_OPTIONS:MPYTHON}
+
+pre-configure-PYTHON-on:
@${RM} ${WRKSRC}/modules/modpython/_znc_core.cpp
-.endif
post-patch:
@${REINPLACE_CMD} -e \
@@ -93,13 +77,11 @@ post-patch:
@${REINPLACE_CMD} -e \
's#/usr/local#${LOCALBASE}#' ${WRKSRC}/configure
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}"
-.endif
.include <bsd.port.mk>
diff --git a/irc/znc/distinfo b/irc/znc/distinfo
index e83134f68a3c..358f4a975753 100644
--- a/irc/znc/distinfo
+++ b/irc/znc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (znc-1.6.1.tar.gz) = ba49397364f48d6d32ae5242bc1166f21d972f85dd390d6bbe68a63ecbb6c140
-SIZE (znc-1.6.1.tar.gz) = 1463397
+SHA256 (znc-1.6.2.tar.gz) = eef17727c0c6433fed1affba0ea76ec7fd60198d2f3c234d8529bd5fb26f0593
+SIZE (znc-1.6.2.tar.gz) = 1463898
diff --git a/irc/znc/files/patch-configure b/irc/znc/files/patch-configure
new file mode 100644
index 000000000000..75a64fd971b4
--- /dev/null
+++ b/irc/znc/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig 2015-11-15 17:54:23 UTC
++++ configure
+@@ -3388,10 +3388,8 @@ appendLD () {
+
+ case "${host_os}" in
+ freebsd*)
+- # -D__GNU_LIBRARY__ makes this work on fbsd 4.11
+- appendCXX -I/usr/local/include -D__GNU_LIBRARY__
+- appendLib -L/usr/local/lib -lcompat
+- appendMod -L/usr/local/lib
++ appendCXX -I/usr/local/include
++ appendLD -L/usr/local/lib
+ ;;
+ solaris*)
+ appendLib -lsocket -lnsl -lresolv
diff --git a/irc/znc/files/patch-modules-modperl-Makefile_inc b/irc/znc/files/patch-modules-modperl-Makefile_inc
deleted file mode 100644
index 3c4c6045de58..000000000000
--- a/irc/znc/files/patch-modules-modperl-Makefile_inc
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/modperl/Makefile.inc.orig 2015-02-12 20:51:46.000000000 +0000
-+++ modules/modperl/Makefile.inc 2015-02-26 02:56:35.000000000 +0000
-@@ -6,7 +6,7 @@
- PERL_LD := $(shell $(PERL) -MExtUtils::Embed -e ldopts)
- # Perl API is ugly, casting string literals to char* and redeclaring functions :(
- PERL_CXX += -Wno-write-strings -Wno-redundant-decls -Wno-missing-declarations
--PERL_CXX += -Wno-type-limits -Wno-sign-compare -Wno-strict-overflow -Wno-unused-value
-+PERL_CXX += -Wno-sign-compare -Wno-strict-overflow -Wno-unused-value
- # perl 5.20 will fix this warning: https://rt.perl.org/Public/Bug/Display.html?id=120670
- PERL_CXX += -Wno-reserved-user-defined-literal -Wno-literal-suffix
- # This is for SWIG
diff --git a/irc/znc/files/patch-src_Csocket.cpp b/irc/znc/files/patch-src_Csocket.cpp
index 708e7154fc34..a4ccb11c74ed 100644
--- a/irc/znc/files/patch-src_Csocket.cpp
+++ b/irc/znc/files/patch-src_Csocket.cpp
@@ -1,4 +1,4 @@
---- src/Csocket.cpp.orig 2015-04-16 15:00:34 UTC
+--- src/Csocket.cpp.orig 2015-11-15 17:54:20 UTC
+++ src/Csocket.cpp
@@ -47,6 +47,7 @@
#include <stdio.h>