aboutsummaryrefslogtreecommitdiff
path: root/irc/znc
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-11-28 23:02:15 +0000
committerJase Thew <jase@FreeBSD.org>2012-11-28 23:02:15 +0000
commitcaf90266b56cdfc8bcf2a175e2ee5f74eb4d494a (patch)
tree1623a650e2815b2bbe440a71f81171275c3cd0af /irc/znc
parent3d0db4d5f11139b0a0735e92f7d67a98f1a8501c (diff)
downloadports-caf90266b56cdfc8bcf2a175e2ee5f74eb4d494a.tar.gz
ports-caf90266b56cdfc8bcf2a175e2ee5f74eb4d494a.zip
- Update to 1.0
- Convert to new OPTIONSng - Add UPDATING entry noting the automatic modification of configuration file Changes: http://wiki.znc.in/ChangeLog/1.0 Feature safe: yes
Notes
Notes: svn path=/head/; revision=307945
Diffstat (limited to 'irc/znc')
-rw-r--r--irc/znc/Makefile98
-rw-r--r--irc/znc/distinfo4
-rw-r--r--irc/znc/files/patch-configure15
-rw-r--r--irc/znc/files/patch-modules-modperl-Makefile_inc11
-rw-r--r--irc/znc/pkg-message11
-rw-r--r--irc/znc/pkg-plist64
6 files changed, 119 insertions, 84 deletions
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index 78c734284177..4d5fb8a36639 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= znc
-PORTVERSION= 0.206
+PORTVERSION= 1.0
CATEGORIES= irc ipv6
MASTER_SITES= http://znc.in/releases/
@@ -11,40 +11,35 @@ COMMENT= An advanced IRC bouncer
LICENSE= GPLv2
-FETCH_ARGS?= -Fpr
+FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_PKGCONFIG= build
+USE_ICONV= yes
WANT_PERL= yes
-OPTIONS= DEBUG "Enable debugging" off \
- IPV6 "Enable IPv6 support" on \
- CARES "Use c-ares resolver library" off \
- OPENSSL "Enable OpenSSL support" on \
- EXTRA "Build extra modules" off \
- PERL "Enable Perl module support" on \
- TCL "Enable TCL module support" off \
- TCLALLOWALL "Allow non-admin users to load TCL module" off \
- PYTHON "Enable Python module support" off \
- SASL "Enable SASL module support (requires EXTRA)" off
+NO_OPTIONS_SORT= yes
+
+OPTIONS_DEFINE= DEBUG IPV6 OPENSSL CYRUS PERL PYTHON TCL
+OPTIONS_DEFAULT= OPENSSL PERL
+
+DEBUG_DESC= Debugging support
+PERL_DESC= Perl scripting module
+PYTHON_DESC= Python scripting module
+TCL_DESC= Tcl scripting module
+CYRUS_DESC= Cyrus SASL module
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITHOUT_IPV6)
+.if empty(PORT_OPTIONS:MIPV6)
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITH_CARES)
-LIB_DEPENDS+= cares.2:${PORTSDIR}/dns/c-ares
-.else
-CONFIGURE_ARGS+= --disable-c-ares
-.endif
-
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
PLIST_SUB+= OPENSSL=""
@@ -53,16 +48,16 @@ CONFIGURE_ARGS+= --disable-openssl
PLIST_SUB+= OPENSSL="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
CONFIGURE_ARGS+= --enable-perl
USE_PERL5= yes
PLIST_SUB+= PERL=""
-BUILD_DEPENDS+= swig>=1.3.40:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20
.else
PLIST_SUB+= PERL="@comment "
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
USE_TCL= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
CONFIGURE_ARGS+= --enable-tcl --with-tcl=${TCL_LIBDIR}
@@ -72,44 +67,43 @@ CONFIGURE_ARGS+= --without-tcl
PLIST_SUB+= TCL="@comment "
.endif
-.if defined(WITH_TCLALLOWALL)
-.if defined(WITHOUT_TCL)
-IGNORE= tcl allow all support requires TCL. Please re-run 'make config' and enable TCL
-.endif
-CXXFLAGS+= -DMOD_MODTCL_ALLOW_EVERYONE
-.endif
-
-.if defined(WITH_PYTHON)
-USE_PYTHON= 3.1
+.if ${PORT_OPTIONS:MPYTHON}
+USE_PYTHON= 3.1-3.2
USE_PERL5_BUILD= yes
PLIST_SUB+= PYTHON=""
CONFIGURE_ARGS+= --enable-python=python-${PYTHON_VER}
-BUILD_DEPENDS+= swig>=1.3.40:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20
.else
PLIST_SUB+= PYTHON="@comment "
.endif
-.if defined(WITH_SASL)
-.if defined(WITHOUT_EXTRA)
-IGNORE= sasl module requires EXTRA. Please re-run 'make config' and enable EXTRA
-.endif
-LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
-CONFIGURE_ARGS+= --enable-sasl
+.if ${PORT_OPTIONS:MCYRUS}
+LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+CONFIGURE_ARGS+= --enable-cyrus
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= SASL=""
-.else
-PLIST_SUB+= SASL="@comment "
-.endif
-
-.if defined(WITH_EXTRA)
-USE_ICONV= yes
-CONFIGURE_ARGS+= --enable-extra
-PLIST_SUB+= EXTRA=""
+PLIST_SUB+= CYRUS=""
.else
-PLIST_SUB+= EXTRA="@comment "
+PLIST_SUB+= CYRUS="@comment "
.endif
MANCOMPRESSED= yes
-MAN1= znc.1 znc-buildmod.1 znc-config.1
+MAN1= znc.1 znc-buildmod.1
+
+PORTDOCS= README.md
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}"
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>
diff --git a/irc/znc/distinfo b/irc/znc/distinfo
index 9ee57589b501..123dd7270710 100644
--- a/irc/znc/distinfo
+++ b/irc/znc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (znc-0.206.tar.gz) = 39977850ab624374b2573a8bdc4d0280687c1334649a089f035ff979bafb996d
-SIZE (znc-0.206.tar.gz) = 655140
+SHA256 (znc-1.0.tar.gz) = a85539da42697b26e4d46205def36bb799f83d6aeef401d53c49ee674142062a
+SIZE (znc-1.0.tar.gz) = 1222361
diff --git a/irc/znc/files/patch-configure b/irc/znc/files/patch-configure
new file mode 100644
index 000000000000..44420036be37
--- /dev/null
+++ b/irc/znc/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig 2012-11-06 16:02:24.000000000 +0000
++++ configure 2012-11-28 12:03:59.905827557 +0000
+@@ -4567,10 +4567,10 @@
+ $ac_path_SWIG -python -py3 -c++ -shadow -I"$srcdir"/swig_lib/python conftest-python.i >&5 && \
+ echo "python wrapper created" >&5 && \
+ echo "testing std::set... ">&5 && \
+- grep SInt_discard conftest.py >& /dev/null && \
++ (grep SInt_discard conftest.py) >/dev/null 2>&1 && \
+ echo "std::set works" >&5 && \
+ echo "testing PyInt_FromSize_t..." >&5 && \
+- grep '#define PyInt_FromSize_t' conftest-python_wrap.cxx >& /dev/null && \
++ (grep '#define PyInt_FromSize_t' conftest-python_wrap.cxx) >/dev/null 2>&1 && \
+ echo "PyInt_FromSize_t is defined" >&5 && \
+ $ac_path_SWIG -perl -c++ -shadow -I"$srcdir"/swig_lib/perl5 conftest-perl.i >&5 && \
+ echo "perl wrapper created" >&5 && \
diff --git a/irc/znc/files/patch-modules-modperl-Makefile_inc b/irc/znc/files/patch-modules-modperl-Makefile_inc
new file mode 100644
index 000000000000..377fdc46d892
--- /dev/null
+++ b/irc/znc/files/patch-modules-modperl-Makefile_inc
@@ -0,0 +1,11 @@
+--- modules/modperl/Makefile.inc.orig 2012-11-28 11:59:30.509460980 +0000
++++ modules/modperl/Makefile.inc 2012-11-28 12:00:07.142992057 +0000
+@@ -6,7 +6,7 @@
+ PERL_LD := $(shell $(PERL) -MExtUtils::Embed -e ldopts)
+ # Perl API is ugly, casting string literals to char* and redeclaring functions :(
+ PERL_CXX += -Wno-write-strings -Wno-redundant-decls -Wno-missing-declarations
+-PERL_CXX += -Wno-type-limits -Wno-sign-compare -Wno-strict-overflow -Wno-unused-value
++PERL_CXX += -Wno-sign-compare -Wno-strict-overflow -Wno-unused-value
+ # This is for SWIG
+ PERL_CXX += -DSWIG_TYPE_TABLE=znc
+ modperlCXXFLAGS := $(PERL_CXX) -Wno-unused-function
diff --git a/irc/znc/pkg-message b/irc/znc/pkg-message
new file mode 100644
index 000000000000..14ad9d92788f
--- /dev/null
+++ b/irc/znc/pkg-message
@@ -0,0 +1,11 @@
+*****************************************************************************
+
+If you are upgrading znc from a version prior to 1.0, please be aware that
+znc will modify your configuration file to incorporate support for new
+functionality.
+
+Please visit the following URL for more information:
+
+http://wiki.znc.in/ChangeLog/1.0
+
+*****************************************************************************
diff --git a/irc/znc/pkg-plist b/irc/znc/pkg-plist
index 693de9decbf9..15e882d2dbfc 100644
--- a/irc/znc/pkg-plist
+++ b/irc/znc/pkg-plist
@@ -1,6 +1,5 @@
bin/znc
bin/znc-buildmod
-bin/znc-config
include/znc/Buffer.h
include/znc/Chan.h
include/znc/Client.h
@@ -9,6 +8,7 @@ include/znc/Csocket.h
include/znc/ExecSock.h
include/znc/FileUtils.h
include/znc/HTTPSock.h
+include/znc/IRCNetwork.h
include/znc/IRCSock.h
include/znc/Listener.h
include/znc/MD5.h
@@ -25,58 +25,57 @@ include/znc/ZNCDebug.h
include/znc/ZNCString.h
include/znc/defines.h
include/znc/main.h
+include/znc/version.h
include/znc/znc.h
include/znc/zncconfig.h
-lib/znc/admin.so
lib/znc/adminlog.so
lib/znc/autoattach.so
+lib/znc/autocycle.so
lib/znc/autoop.so
lib/znc/autoreply.so
+lib/znc/autovoice.so
lib/znc/awaynick.so
+lib/znc/block_motd.so
lib/znc/blockuser.so
lib/znc/bouncedcc.so
lib/znc/buffextras.so
lib/znc/chansaver.so
+lib/znc/charset.so
+lib/znc/clearbufferonmsg.so
lib/znc/clientnotify.so
+lib/znc/controlpanel.so
+lib/znc/ctcpflood.so
+lib/znc/dcc.so
lib/znc/disconkick.so
lib/znc/fail2ban.so
+lib/znc/flooddetach.so
lib/znc/identfile.so
+lib/znc/imapauth.so
lib/znc/keepnick.so
lib/znc/kickrejoin.so
lib/znc/lastseen.so
+lib/znc/listsockets.so
+lib/znc/log.so
+lib/znc/missingmotd.so
lib/znc/nickserv.so
lib/znc/notes.so
+lib/znc/notify_connect.so
lib/znc/partyline.so
lib/znc/perform.so
lib/znc/q.so
lib/znc/raw.so
lib/znc/route_replies.so
lib/znc/sample.so
+lib/znc/sasl.so
+lib/znc/send_raw.so
+lib/znc/shell.so
lib/znc/simple_away.so
lib/znc/stickychan.so
lib/znc/watch.so
lib/znc/webadmin.so
-%%EXTRA%%lib/znc/antiidle.so
-%%EXTRA%%lib/znc/autocycle.so
-%%EXTRA%%lib/znc/autovoice.so
-%%EXTRA%%%%OPENSSL%%lib/znc/away.so
-%%EXTRA%%lib/znc/block_motd.so
-%%EXTRA%%lib/znc/charset.so
-%%EXTRA%%lib/znc/clearbufferonmsg.so
-%%EXTRA%%lib/znc/ctcpflood.so
-%%EXTRA%%lib/znc/dcc.so
-%%EXTRA%%lib/znc/droproot.so
-%%EXTRA%%lib/znc/email.so
-%%EXTRA%%lib/znc/fakeonline.so
-%%EXTRA%%lib/znc/flooddetach.so
-%%EXTRA%%lib/znc/imapauth.so
-%%EXTRA%%lib/znc/listsockets.so
-%%EXTRA%%lib/znc/log.so
-%%EXTRA%%lib/znc/motdfile.so
-%%EXTRA%%lib/znc/notify_connect.so
-%%EXTRA%%%%SASL%%lib/znc/saslauth.so
-%%EXTRA%%lib/znc/send_raw.so
-%%EXTRA%%lib/znc/shell.so
+libdata/pkgconfig/znc.pc
+%%CYRUS%%lib/znc/cyrusauth.so
+%%OPENSSL%%lib/znc/awaystore.so
%%OPENSSL%%lib/znc/cert.so
%%OPENSSL%%lib/znc/certauth.so
%%OPENSSL%%lib/znc/crypt.so
@@ -96,26 +95,29 @@ lib/znc/webadmin.so
%%TCL%%lib/znc/modtcl.so
%%TCL%%share/znc/modtcl/binds.tcl
%%TCL%%share/znc/modtcl/modtcl.tcl
-libdata/pkgconfig/znc.pc
%%DATADIR%%/modules/blockuser/tmpl/blockuser_WebadminUser.tmpl
%%DATADIR%%/modules/cert/tmpl/index.tmpl
%%DATADIR%%/modules/certauth/tmpl/index.tmpl
%%DATADIR%%/modules/lastseen/tmpl/index.tmpl
%%DATADIR%%/modules/lastseen/tmpl/lastseen_WebadminUser.tmpl
+%%DATADIR%%/modules/listsockets/tmpl/index.tmpl
%%DATADIR%%/modules/notes/files/trash.gif
%%DATADIR%%/modules/notes/tmpl/index.tmpl
%%DATADIR%%/modules/perform/tmpl/index.tmpl
+%%DATADIR%%/modules/send_raw/files/select.js
+%%DATADIR%%/modules/send_raw/tmpl/index.tmpl
%%DATADIR%%/modules/stickychan/tmpl/index.tmpl
%%DATADIR%%/modules/stickychan/tmpl/stickychan_WebadminChan.tmpl
+%%DATADIR%%/modules/webadmin/files/webadmin.js
%%DATADIR%%/modules/webadmin/tmpl/add_edit_chan.tmpl
+%%DATADIR%%/modules/webadmin/tmpl/add_edit_network.tmpl
%%DATADIR%%/modules/webadmin/tmpl/add_edit_user.tmpl
+%%DATADIR%%/modules/webadmin/tmpl/del_network.tmpl
%%DATADIR%%/modules/webadmin/tmpl/del_user.tmpl
%%DATADIR%%/modules/webadmin/tmpl/index.tmpl
%%DATADIR%%/modules/webadmin/tmpl/listusers.tmpl
%%DATADIR%%/modules/webadmin/tmpl/settings.tmpl
%%DATADIR%%/modules/webadmin/tmpl/traffic.tmpl
-%%EXTRA%%share/znc/modules/listsockets/tmpl/index.tmpl
-%%EXTRA%%share/znc/modules/send_raw/tmpl/index.tmpl
%%DATADIR%%/webskins/_default_/pub/_default_.css
%%DATADIR%%/webskins/_default_/pub/favicon.ico
%%DATADIR%%/webskins/_default_/pub/global.css
@@ -175,14 +177,20 @@ libdata/pkgconfig/znc.pc
@dirrmtry %%DATADIR%%/webskins/_default_
@dirrmtry %%DATADIR%%/webskins
@dirrmtry %%DATADIR%%/modules/webadmin/tmpl
+@dirrmtry %%DATADIR%%/modules/webadmin/files
@dirrmtry %%DATADIR%%/modules/webadmin
@dirrmtry %%DATADIR%%/modules/stickychan/tmpl
@dirrmtry %%DATADIR%%/modules/stickychan
+@dirrmtry %%DATADIR%%/modules/send_raw/tmpl
+@dirrmtry %%DATADIR%%/modules/send_raw/files
+@dirrmtry %%DATADIR%%/modules/send_raw
@dirrmtry %%DATADIR%%/modules/perform/tmpl
@dirrmtry %%DATADIR%%/modules/perform
@dirrmtry %%DATADIR%%/modules/notes/tmpl
@dirrmtry %%DATADIR%%/modules/notes/files
@dirrmtry %%DATADIR%%/modules/notes
+@dirrmtry %%DATADIR%%/modules/listsockets/tmpl
+@dirrmtry %%DATADIR%%/modules/listsockets
@dirrmtry %%DATADIR%%/modules/lastseen/tmpl
@dirrmtry %%DATADIR%%/modules/lastseen
@dirrmtry %%DATADIR%%/modules/certauth/tmpl
@@ -191,10 +199,6 @@ libdata/pkgconfig/znc.pc
@dirrmtry %%DATADIR%%/modules/cert
@dirrmtry %%DATADIR%%/modules/blockuser/tmpl
@dirrmtry %%DATADIR%%/modules/blockuser
-%%EXTRA%%@dirrmtry share/znc/modules/send_raw/tmpl
-%%EXTRA%%@dirrmtry share/znc/modules/send_raw
-%%EXTRA%%@dirrmtry share/znc/modules/listsockets/tmpl
-%%EXTRA%%@dirrmtry share/znc/modules/listsockets
%%TCL%%@dirrmtry share/znc/modtcl
@dirrmtry %%DATADIR%%/modules
@dirrmtry %%DATADIR%%