aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /irc
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'irc')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile2
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist2
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile8
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist2
-rw-r--r--irc/p5-POE-Component-IRC/Makefile2
-rw-r--r--irc/p5-Parse-IRC/Makefile8
8 files changed, 11 insertions, 21 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
index 71ccf8a136e2..4349523c53d2 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -25,10 +25,8 @@ OPTIONS_DEFINE= EXAMPLES
PORTEXAMPLES= *
SHEBANG_FILES= examples/*.pl
-.include <bsd.port.options.mk>
-
post-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
index a84c5ec0c831..0e8791e6a799 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
@@ -20,6 +20,8 @@ PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist
index f484756843e5..109f2f194ffe 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist
@@ -1,3 +1,3 @@
%%SITE_PERL%%/POE/Component/IRC/Plugin/QueryDNS.pm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
%%PERL5_MAN3%%/POE::Component::IRC::Plugin::QueryDNS.3.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
index c73bbc112805..cd373990106c 100644
--- a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
@@ -29,10 +29,8 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES
-.include <bsd.port.options.mk>
-
post-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
index c3881d349a54..4ea74d84f3ea 100644
--- a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/Makefile
@@ -16,16 +16,14 @@ BUILD_DEPENDS= p5-POE>=1.004:${PORTSDIR}/devel/p5-POE \
p5-POE-Component-Client-HTTP>=0.73:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
p5-XML-RSS>=1.1:${PORTSDIR}/textproc/p5-XML-RSS \
p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message
-RUN_DEPENDS:= p5-POE>=1.004:${PORTSDIR}/devel/p5-POE \
- p5-POE-Component-IRC>=5.07:${PORTSDIR}/irc/p5-POE-Component-IRC \
- p5-POE-Component-Client-HTTP>=0.73:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
- p5-XML-RSS>=1.1:${PORTSDIR}/textproc/p5-XML-RSS \
- p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist
index 0b0c58f86f58..2f9eb6098faa 100644
--- a/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Plugin-RSS-Headlines/pkg-plist
@@ -1,3 +1,3 @@
%%SITE_PERL%%/POE/Component/IRC/Plugin/RSS/Headlines.pm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
%%PERL5_MAN3%%/POE::Component::IRC::Plugin::RSS::Headlines.3.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
index ed18b89d9d8b..62ab7121a945 100644
--- a/irc/p5-POE-Component-IRC/Makefile
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -31,7 +31,7 @@ USE_PERL5= configure
PORTEXAMPLES= *
post-install:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-Parse-IRC/Makefile b/irc/p5-Parse-IRC/Makefile
index 1a98e96788d7..dd094223efac 100644
--- a/irc/p5-Parse-IRC/Makefile
+++ b/irc/p5-Parse-IRC/Makefile
@@ -17,10 +17,4 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501600
-BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.59:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>