aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-21 09:16:10 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-21 09:16:10 +0000
commit30d5c2f0acc55f30fc46e57f92bb395e5d7a4622 (patch)
treeea7b8f55d98aa5230e33d3a3c31101a2847e03f7 /irc
parentc1b7b44ee322938fd006eb2b2092ff0758e4601e (diff)
downloadports-30d5c2f0acc55f30fc46e57f92bb395e5d7a4622.tar.gz
ports-30d5c2f0acc55f30fc46e57f92bb395e5d7a4622.zip
- Fix build with amd64/7.x
PR: ports/120340 Submitted by: Stefan `Sec` Zehl <sec@42.org> Approved by: maintainer timeout (two weeks)
Notes
Notes: svn path=/head/; revision=207692
Diffstat (limited to 'irc')
-rw-r--r--irc/ircII/Makefile9
-rw-r--r--irc/ircII/files/patch-source_mksiginc.c15
2 files changed, 17 insertions, 7 deletions
diff --git a/irc/ircII/Makefile b/irc/ircII/Makefile
index b6b3a541bb24..c88b4622ac9a 100644
--- a/irc/ircII/Makefile
+++ b/irc/ircII/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ircii
PORTVERSION= 20060725
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.warped.com/pub/ircII/ \
ftp://ftp.irc.org/irc/clients/unix/ircII/
@@ -23,10 +24,4 @@ MAN1= irc.1 ircII.1 ircbug.1
PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" && ${OSVERSION} >= 700000
-BROKEN= Doesn't build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/ircII/files/patch-source_mksiginc.c b/irc/ircII/files/patch-source_mksiginc.c
new file mode 100644
index 000000000000..ab64430bc7e3
--- /dev/null
+++ b/irc/ircII/files/patch-source_mksiginc.c
@@ -0,0 +1,15 @@
+--- source/mksiginc.c.orig 2004-02-16 01:00:58.000000000 -0900
++++ source/mksiginc.c 2008-02-14 00:14:47.000000000 -0900
+@@ -38,8 +38,11 @@
+ #ifndef NSIG
+ #define NSIG 64
+ #endif
+-
++#if defined(SIGRTMAX) && (SIGRTMAX > NSIG)
++#define MAXSIG SIGRTMAX+1
++#else
+ #define MAXSIG NSIG+1
++#endif
+ char *signames[MAXSIG];
+
+ int main(int, char *[], char *[]);