aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-01-28 20:40:54 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-01-28 20:40:54 +0000
commit4c68bc907874cb10afaa729253d8dea75b14648d (patch)
treee043add122963222248ab003bd18fac97ca67d7a /irc
parent17897b24474a763424e48f57377a209d2cd680c1 (diff)
downloadports-4c68bc907874cb10afaa729253d8dea75b14648d.tar.gz
ports-4c68bc907874cb10afaa729253d8dea75b14648d.zip
- Resolve build failure after update of irc/irssi to 1.0.0 [1]
- Bump PORTREVISION [1] - strip(1) installed modules - Add USES+=gettext-runtime as we link against it - Add USE_GNOME+=glib20 as we link against it PR: 215829 [1] Submitted by: p5B2E9A8F@t-online.de Obtained from: upstream commit d56d614b89ecc34845e0f5971c545b893c2c359a Approved by: jadawin@ (maintainer timeout, 3+ weeks)
Notes
Notes: svn path=/head/; revision=432650
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-xmpp/Makefile7
-rw-r--r--irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a41
2 files changed, 47 insertions, 1 deletions
diff --git a/irc/irssi-xmpp/Makefile b/irc/irssi-xmpp/Makefile
index 632689e89b92..23a749613041 100644
--- a/irc/irssi-xmpp/Makefile
+++ b/irc/irssi-xmpp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= irssi-xmpp
PORTVERSION= 0.53
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://cybione.org/~irssi-xmpp/files/
@@ -15,7 +16,8 @@ BUILD_DEPENDS= irssi:irc/irssi
LIB_DEPENDS= libloudmouth-1.so:net-im/loudmouth
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= pkgconfig
+USES= gettext-runtime pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
DATADIR= ${PREFIX}/share/irssi
@@ -30,4 +32,7 @@ post-patch:
@${REINPLACE_CMD} -E 's|cd (.+) && (\$${MAKE})|\2 -C \1|' \
${WRKSRC}/Makefile ${WRKSRC}/src/Makefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/irssi/modules/*.so
+
.include <bsd.port.mk>
diff --git a/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a b/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a
new file mode 100644
index 000000000000..0a3919917512
--- /dev/null
+++ b/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a
@@ -0,0 +1,41 @@
+From d56d614b89ecc34845e0f5971c545b893c2c359a Mon Sep 17 00:00:00 2001
+From: benaryorg <binary@benary.org>
+Date: Fri, 20 Jan 2017 06:31:28 +0100
+Subject: [PATCH] fix #18 - build with irssi 1.0
+
+Signed-off-by: benaryorg <binary@benary.org>
+---
+ src/core/xmpp-servers.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/core/xmpp-servers.c b/src/core/xmpp-servers.c
+index 405ecd9..b6d9bd5 100644
+--- src/core/xmpp-servers.c
++++ src/core/xmpp-servers.c
+@@ -151,7 +151,7 @@ xmpp_server_init_connect(SERVER_CONNECT_REC *connrec)
+ server->connect_pid = -1;
+
+ if (server->connrec->port <= 0)
+- server->connrec->port = (server->connrec->use_ssl) ?
++ server->connrec->port = (server->connrec->use_tls) ?
+ LM_CONNECTION_DEFAULT_PORT_SSL : LM_CONNECTION_DEFAULT_PORT;
+
+ if (conn->real_jid == NULL)
+@@ -335,7 +335,7 @@ lm_open_cb(LmConnection *connection, gboolean success,
+ g_free(host);
+ } else
+ signal_emit("server connecting", 1, server);
+- if (server->connrec->use_ssl)
++ if (server->connrec->use_tls)
+ signal_emit("xmpp server status", 2, server,
+ "Using SSL encryption.");
+ else if (lm_ssl_get_use_starttls(lm_connection_get_ssl(server->lmconn)))
+@@ -470,7 +470,7 @@ xmpp_server_connect(XMPP_SERVER_REC *server)
+ return;
+ error = NULL;
+ err_msg = NULL;
+- if (server->connrec->use_ssl) {
++ if (server->connrec->use_tls) {
+ if (!set_ssl(server->lmconn, &error, server, FALSE)) {
+ err_msg = "Cannot init ssl";
+ goto err;