aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-09 09:19:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-09 09:19:20 +0000
commit4edb36c604394cf902834972aa620a781de4d84e (patch)
treef78f7788bdb6bcb05de56b48b600cdc5c9c4b4eb /irc
parent17054724ba0744af92846572276564336199cc86 (diff)
downloadports-4edb36c604394cf902834972aa620a781de4d84e.tar.gz
ports-4edb36c604394cf902834972aa620a781de4d84e.zip
- Update to 0.13.5
PR: 134289 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=233514
Diffstat (limited to 'irc')
-rw-r--r--irc/xaric/Makefile13
-rw-r--r--irc/xaric/distinfo6
-rw-r--r--irc/xaric/files/patch-iflist.c11
-rw-r--r--irc/xaric/files/patch-misc.c20
-rw-r--r--irc/xaric/files/patch-numbers.c19
-rw-r--r--irc/xaric/files/patch-xscandir.c11
-rw-r--r--irc/xaric/pkg-plist6
7 files changed, 13 insertions, 73 deletions
diff --git a/irc/xaric/Makefile b/irc/xaric/Makefile
index a970ada72e10..8234f4d684b7 100644
--- a/irc/xaric/Makefile
+++ b/irc/xaric/Makefile
@@ -6,20 +6,27 @@
#
PORTNAME= xaric
-PORTVERSION= 0.13.2
+PORTVERSION= 0.13.5
CATEGORIES= irc
-MASTER_SITES= http://rf.cx/software/xaric/releases/
+MASTER_SITES= http://xaric.org/software/xaric/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= IRC Client similer to BitchX or ircII
+USE_GNOME= gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= xaric.1
+PLIST_FILES= bin/xaric \
+ %%DATADIR%%/help/copying \
+ %%DATADIR%%/help/help \
+ %%DATADIR%%/help/warranty
+PLIST_DIRS= %%DATADIR%%/help \
+ %%DATADIR%%
post-patch:
- ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-ggdb3||g' ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xaric ${PREFIX}/bin
diff --git a/irc/xaric/distinfo b/irc/xaric/distinfo
index 8736580cd7c0..89b442b04819 100644
--- a/irc/xaric/distinfo
+++ b/irc/xaric/distinfo
@@ -1,3 +1,3 @@
-MD5 (xaric-0.13.2.tar.gz) = aa345a3bbd8cfffdbb933fc27d868937
-SHA256 (xaric-0.13.2.tar.gz) = 9447b99ac4474d5d40b08f37c30ccdd5632e23fd991978473e5844f1c824a66d
-SIZE (xaric-0.13.2.tar.gz) = 449916
+MD5 (xaric-0.13.5.tar.gz) = 2c6ac8e3f3fe2ec2e6d4ffc076784a09
+SHA256 (xaric-0.13.5.tar.gz) = 36fb68e0c01b85e7613bd7ca68abd9023c05bef41a195192ea3648d27c95e4ba
+SIZE (xaric-0.13.5.tar.gz) = 454516
diff --git a/irc/xaric/files/patch-iflist.c b/irc/xaric/files/patch-iflist.c
deleted file mode 100644
index 9d6d64d3c896..000000000000
--- a/irc/xaric/files/patch-iflist.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- iflist.c.orig Sun Jan 8 08:18:32 2006
-+++ iflist.c Sun Jan 8 08:18:36 2006
-@@ -184,7 +184,7 @@
- c->thr_ifcb = callback;
- c->thr_data = data;
-
-- return THR_CREATE(ifaces_r, c);
-+ return (int)THR_CREATE(ifaces_r, c);
- }
-
- /**
diff --git a/irc/xaric/files/patch-misc.c b/irc/xaric/files/patch-misc.c
deleted file mode 100644
index 501384097ad9..000000000000
--- a/irc/xaric/files/patch-misc.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- misc.c.orig Wed Nov 30 11:06:26 2005
-+++ misc.c Sun Jan 8 21:45:27 2006
-@@ -104,7 +104,7 @@
-
- char *convert_time(time_t ltime)
- {
-- time_t days = 0, hours = 0, minutes = 0, seconds = 0;
-+ unsigned int days = 0, hours = 0, minutes = 0, seconds = 0;
- static char buffer[100];
-
- *buffer = '\0';
-@@ -114,7 +114,7 @@
- ltime = (ltime - minutes) / 60;
- hours = ltime % 24;
- days = (ltime - hours) / 24;
-- sprintf(buffer, "%2ldd %2ldh %2ldm %2lds", days, hours, minutes, seconds);
-+ sprintf(buffer, "%2ud %2uh %2um %2us", days, hours, minutes, seconds);
- return (*buffer ? buffer : empty_str);
- }
-
diff --git a/irc/xaric/files/patch-numbers.c b/irc/xaric/files/patch-numbers.c
deleted file mode 100644
index 34e658aac16d..000000000000
--- a/irc/xaric/files/patch-numbers.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- numbers.c.orig Wed Nov 30 11:06:26 2005
-+++ numbers.c Sun Jan 8 22:22:04 2006
-@@ -980,14 +980,14 @@
-
- case 329: /* #define CREATION_TIME 329 */
- {
-- time_t tme;
-+ unsigned long tme;
- char *this_sucks;
- struct channel *chan = NULL;
-
- if (!ArgList[1] || !*ArgList[1])
- break;
- sscanf(ArgList[1], "%lu", &tme);
-- this_sucks = ctime(&tme);
-+ this_sucks = ctime((time_t *)&tme);
- this_sucks[strlen(this_sucks) - 1] = '\0';
-
- message_from(ArgList[0], LOG_CRAP);
diff --git a/irc/xaric/files/patch-xscandir.c b/irc/xaric/files/patch-xscandir.c
deleted file mode 100644
index 39fa6ecbac75..000000000000
--- a/irc/xaric/files/patch-xscandir.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xscandir.c.orig Sun Jan 8 07:58:21 2006
-+++ xscandir.c Sun Jan 8 08:00:46 2006
-@@ -84,7 +84,7 @@
- static int the_longest;
-
- /* used by scandir to select entries */
--static int dselect(const struct dirent *d)
-+static int dselect(struct dirent *d)
- {
- int t;
-
diff --git a/irc/xaric/pkg-plist b/irc/xaric/pkg-plist
deleted file mode 100644
index ecc510fb6036..000000000000
--- a/irc/xaric/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/xaric
-%%DATADIR%%/help/copying
-%%DATADIR%%/help/help
-%%DATADIR%%/help/warranty
-@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%