aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /irc
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/dancer-services/Makefile3
-rw-r--r--irc/irssi-devel/Makefile2
-rw-r--r--irc/kvirc-devel/Makefile2
-rw-r--r--irc/kvirc/Makefile2
-rw-r--r--irc/olirc/Makefile2
-rw-r--r--irc/xchat-gnome/Makefile2
-rw-r--r--irc/xchat2/Makefile2
8 files changed, 8 insertions, 9 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 82e07ee50b95..1df0a47a4218 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -74,7 +74,7 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
.endif
.if defined(WITH_IPV6)
-USE_AUTOCONF_VER=253
+USE_AUTOTOOLS= autoconf:253
.endif
.if ${ARCH} == "alpha" || ${ARCH} == "ia64" || ${ARCH} == "amd64"
diff --git a/irc/dancer-services/Makefile b/irc/dancer-services/Makefile
index 7946a391a7c3..886ec95df417 100644
--- a/irc/dancer-services/Makefile
+++ b/irc/dancer-services/Makefile
@@ -15,8 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= The IRC services (nickserv, chanserv, etc.) for dancer-ircd
-WANT_AUTOMAKE_VER=15
-WANT_AUTOCONF_VER=253
+USE_AUTOTOOLS= automake:15:env autoconf:253:env
USE_RC_SUBR= yes
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 5c945ff0efdc..6f67724746c9 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= irssi-0.8*
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/irc/kvirc-devel/Makefile b/irc/kvirc-devel/Makefile
index eb7d296899d9..f0d1f41db352 100644
--- a/irc/kvirc-devel/Makefile
+++ b/irc/kvirc-devel/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
CONFIGURE_TARGET=
CONFIGURE_ARGS+= --mandir=${PREFIX}/man
PLIST_SUB= VER=${PORTVERSION}
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index eb7d296899d9..f0d1f41db352 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
CONFIGURE_TARGET=
CONFIGURE_ARGS+= --mandir=${PREFIX}/man
PLIST_SUB= VER=${PORTVERSION}
diff --git a/irc/olirc/Makefile b/irc/olirc/Makefile
index 7f163d8d907e..69e017a57c28 100644
--- a/irc/olirc/Makefile
+++ b/irc/olirc/Makefile
@@ -21,7 +21,7 @@ PLIST_FILES= bin/olirc
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
do-install:
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 2c12159abf91..1d3e57c4ecbe 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack libgnomeui
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-nls \
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index e33d70c5250a..a724f2516cd9 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"