aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-08-23 06:29:43 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-08-23 06:29:43 +0000
commit9a10f238374b0165294c39ff511b993a8849c7a9 (patch)
tree9e3ba747e5a1c90cf69b7f412e9e845e60739f7c /irc
parent198442c6e28bfc0b4296a4f8efeae018dd4646e0 (diff)
downloadports-9a10f238374b0165294c39ff511b993a8849c7a9.tar.gz
ports-9a10f238374b0165294c39ff511b993a8849c7a9.zip
Fix a bug caused by passing insufficient arguments to strncmp(). This
was non-fatal for the compiler in -stable because strncmp() is not prototyped, but it fails on -current. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=64865
Diffstat (limited to 'irc')
-rw-r--r--irc/party/Makefile1
-rw-r--r--irc/party/files/patch-ac11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/party/Makefile b/irc/party/Makefile
index 6efc00a17268..ac49216bc4db 100644
--- a/irc/party/Makefile
+++ b/irc/party/Makefile
@@ -7,6 +7,7 @@
PORTNAME= party
PORTVERSION= 2.12
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.vocito.com/downloads/software/party/ \
ftp://ftp.vocito.com/pub/vocito.com/software/party/
diff --git a/irc/party/files/patch-ac b/irc/party/files/patch-ac
new file mode 100644
index 000000000000..ee8a7c887d04
--- /dev/null
+++ b/irc/party/files/patch-ac
@@ -0,0 +1,11 @@
+--- proc.c.orig Thu Aug 22 23:22:19 2002
++++ proc.c Thu Aug 22 23:22:31 2002
+@@ -50,7 +50,7 @@
+ /* If a filter is running, and it is different, kill it */
+ if (out_fd != 1)
+ {
+- if (!strncmp(ofilter,opt[OPT_FILTER].str))
++ if (!strncmp(ofilter,opt[OPT_FILTER].str, BFSZ))
+ return(0);
+ else
+ stop_filter();