aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2017-01-03 14:12:28 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2017-01-03 14:12:28 +0000
commitd7ba24939553ad1597f1b6db2856a64ffef3d3dd (patch)
treecff071b1ca132391db301e4d6363d44fb41c7c0e /irc
parentc13b66d776c5887c35fab475c49c96caea81081e (diff)
downloadports-d7ba24939553ad1597f1b6db2856a64ffef3d3dd.tar.gz
ports-d7ba24939553ad1597f1b6db2856a64ffef3d3dd.zip
Fix build with libressl
PR: 215363 Submitted by: w.schwarzenfeld@utanet.at Reviewed by: pkubaj@anongoth.pl (maintainer) Approved by: jadawin (mentor) Differential Revision: https://reviews.freebsd.org/D8824
Notes
Notes: svn path=/head/; revision=430473
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile4
-rw-r--r--irc/hexchat/files/patch-src__common__ssl.c18
2 files changed, 18 insertions, 4 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index af995256cbe9..ab47c2a22679 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -78,10 +78,6 @@ TEXTFE_CONFIGURE_ENABLE=textfe
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-WITH_OPENSSL_PORT= yes
-.endif
-
.if ${PORT_OPTIONS:MCA_BUNDLE}
CA_BUNDLE= "${LOCALBASE}/share/certs/ca-root-nss.crt"
.else
diff --git a/irc/hexchat/files/patch-src__common__ssl.c b/irc/hexchat/files/patch-src__common__ssl.c
index 5af87feaeb54..56caccadcab8 100644
--- a/irc/hexchat/files/patch-src__common__ssl.c
+++ b/irc/hexchat/files/patch-src__common__ssl.c
@@ -1,5 +1,23 @@
--- src/common/ssl.c.orig 2016-12-10 14:30:51 UTC
+++ src/common/ssl.c
+@@ -176,7 +176,7 @@ _SSL_get_cert_info (struct cert_info *ce
+ return 1;
+
+ alg = OBJ_obj2nid (algor->algorithm);
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
+ sign_alg = OBJ_obj2nid (peer_cert->sig_alg->algorithm);
+ #else
+ sign_alg = X509_get_signature_nid (peer_cert);
+@@ -306,7 +306,7 @@ _SSL_socket (SSL_CTX *ctx, int sd)
+
+ SSL_set_fd (ssl, sd);
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
+ method = ctx->method;
+ #else
+ method = SSL_CTX_get_ssl_method (ctx);
@@ -328,7 +328,7 @@ _SSL_set_verify (SSL_CTX *ctx, void *ver
__SSL_fill_err_buf ("SSL_CTX_set_default_verify_paths");
return (err_buf);