aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2014-09-20 16:08:01 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2014-09-20 16:08:01 +0000
commitf566039c138ceb204b464935a4148af0449bb5c8 (patch)
treeb56b74cb7b913ec4d5999de0d3c9ee7796ed112c /irc
parent530a8eab4844ef91689f8f88de2f200e247d3e7b (diff)
downloadports-f566039c138ceb204b464935a4148af0449bb5c8.tar.gz
ports-f566039c138ceb204b464935a4148af0449bb5c8.zip
OptionsNG conversion brokes few options making
them available by default. Also added MAKE_JOBS_UNSAFE to avoid intermittent build failures. PR: ports/181481 Submitted by: John Marshall <John.Marshall@riverwillow.com.au> Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=368658
Diffstat (limited to 'irc')
-rw-r--r--irc/ircd-ratbox/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index 313c3a0e6373..d7b26e3a9dc0 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ircd-ratbox
PORTVERSION= 3.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc ipv6
MASTER_SITES= http://www.ratbox.org/download/ \
http://www.ratbox.org/download/old/
@@ -21,6 +21,8 @@ USE_RC_SUBR= ircd-ratbox
USE_SQLITE= 3
USE_LDCONFIG= ${PREFIX}/lib/ircd-ratbox
+MAKE_JOBS_UNSAFE= yes
+
USERS= ircd
GROUPS= ${USERS}
@@ -72,15 +74,21 @@ CONFIGURE_ARGS+= --disable-openssl
.endif
.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MZIPLINKS}
+CONFIGURE_ARGS+= --enable-zlib
+.else
CONFIGURE_ARGS+= --disable-zlib
.endif
.if ${PORT_OPTIONS:MSHARED_MODS}
-CONFIGURE_ARGS+= --disable-shared-modules
+CONFIGURE_ARGS+= --disable-static
+.else
+CONFIGURE_ARGS+= --enable-static
.endif
.if ${PORT_OPTIONS:MASSERT}