aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /irc
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
downloadports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.tar.gz
ports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=314960
Diffstat (limited to 'irc')
-rw-r--r--irc/irssi-otr/Makefile2
-rw-r--r--irc/konversation-kde4/Makefile2
-rw-r--r--irc/kvirc/Makefile2
-rw-r--r--irc/minbif/Makefile2
-rw-r--r--irc/quassel/Makefile2
-rw-r--r--irc/weechat-devel/Makefile2
-rw-r--r--irc/weechat/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index 114338ce13bb..14274ec789b5 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
USE_GNOME= glib20
USE_PKGCONFIG= build
diff --git a/irc/konversation-kde4/Makefile b/irc/konversation-kde4/Makefile
index 8167aedae073..b9a9325c5001 100644
--- a/irc/konversation-kde4/Makefile
+++ b/irc/konversation-kde4/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
LATEST_LINK= ${PORTNAME}-kde4
USE_XZ= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= kdeprefix pimlibs automoc4
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index a9f37fed30be..f73bdfe22246 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -31,7 +31,7 @@ USE_OPENSSL= yes
USE_PERL5_BUILD= yes
USE_QT4= moc_build qmake_build rcc_build uic_build \
dbus gui network sql xml
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DWANT_ESD=no -DWANT_DOXYGEN=no \
-DMANDIR=${MANPREFIX}
INSTALLS_ICONS= yes
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index 58e71510f543..09c1365d34ef 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -24,7 +24,7 @@ PLUGINS_DESC= Compile additional libpurple-plugins
USE_RC_SUBR= minbif
USE_GNOME= glib20
USE_EFL= imlib2
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DENABLE_IMLIB:BOOL=ON
MAKE_JOBS_SAFE= yes
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 80223dc6973b..0347827eca05 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -17,7 +17,7 @@ COMMENT= Qt4 based distributed IRC client
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 8e317846b10f..e82733de45a4 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= weechat-0.3*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DENABLE_GUILE=no
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index aadc02130f96..ee52d243c11b 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= weechat-devel-0.*
USE_ICONV= yes
USE_LDCONFIG= yes
USE_NCURSES= yes
-USE_CMAKE= yes
+USES= cmake
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes