aboutsummaryrefslogtreecommitdiff
path: root/japanese/FreeWnn-server
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-04-22 15:58:54 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-04-22 15:58:54 +0000
commitc29c8ab31fb5b001e3638b966d197775cefb7451 (patch)
tree9424876ff3b85ade835beb8891dc0ec02d0deda1 /japanese/FreeWnn-server
parent62c1d6953830dc74521c89e95e1bd029dd215eb6 (diff)
downloadports-c29c8ab31fb5b001e3638b966d197775cefb7451.tar.gz
ports-c29c8ab31fb5b001e3638b966d197775cefb7451.zip
To use ${BATCH}
Noticed by: KIRIYAMA Kazuhiko <kiri@pis.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=18084
Diffstat (limited to 'japanese/FreeWnn-server')
-rw-r--r--japanese/FreeWnn-server/Makefile9
-rw-r--r--japanese/FreeWnn-server/pkg-install19
2 files changed, 20 insertions, 8 deletions
diff --git a/japanese/FreeWnn-server/Makefile b/japanese/FreeWnn-server/Makefile
index 8277b8817810..970c0be7e4a8 100644
--- a/japanese/FreeWnn-server/Makefile
+++ b/japanese/FreeWnn-server/Makefile
@@ -3,7 +3,7 @@
# Date created: 20 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.21 1999/02/03 11:11:48 asami Exp $
+# $Id: Makefile,v 1.22 1999/02/10 14:31:58 kuriyama Exp $
#
DISTNAME= Wnn4.2
@@ -27,6 +27,10 @@ WRKSRC= ${WRKDIR}/Xsi
WNN_EXTRA_PATCH= Wnn4.2.patch-981201.tar.gz
MAKE_ENV+= PATH=/usr/bin:$${PATH} PORT_IMAKE_DEFINES='${WNN_DEF}'
+.if defined(BATCH)
+BATCH= yes # make sure it's not empty
+.endif
+
.if (${PKGNAME} == ja-Wnn-4.2)
DISTFILES+= pubdic+.tar.gz pubdic+-fix01.gz pubdic+.diff pubdic+.special.diff
PORT_DOCDIR= ${PREFIX}/share/doc/ja-Wnn
@@ -134,7 +138,8 @@ post-build:
.endif
pre-install:
- @${SH} ${PKGDIR}/INSTALL ${PKGNAME} PRE-INSTALL
+ @${SETENV} BATCH=${BATCH} \
+ ${SH} ${PKGDIR}/INSTALL ${PKGNAME} PRE-INSTALL
post-install:
#### gerodic
diff --git a/japanese/FreeWnn-server/pkg-install b/japanese/FreeWnn-server/pkg-install
index 8a32fa8c9fce..a30d1a3933b9 100644
--- a/japanese/FreeWnn-server/pkg-install
+++ b/japanese/FreeWnn-server/pkg-install
@@ -76,14 +76,21 @@ EOF
# add an account 'wnn' to this system
echo ""
echo "You need an account 'wnn' whose ID number is 69"
- if yesno "Would you like to create it automatically?" y; then
- # We need a command 'pw(8)'
+ if [ -z "${BATCH}" ]; then
+ if yesno "Would you like to create it automatically?" y; then
+ # We need a command 'pw(8)'
+ check_pw
+ pw useradd wnn -u 69 -g 7 -h - -d /nonexistent \
+ -s /nonexistent -c Wnn || exit
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ else
+ echo "Create it automatically!"
check_pw
pw useradd wnn -u 69 -g 7 -h - -d /nonexistent \
- -s /nonexistent -c Wnn || exit
- else
- echo "Please create it, and try again."
- exit 1
+ -s /nonexistent -c Wnn || exit
fi
;;