aboutsummaryrefslogtreecommitdiff
path: root/japanese/ebview-gtk2/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 14:30:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 14:30:23 +0000
commitbaaa0732114a060988ba6a744e3f5c7cf2129ff4 (patch)
treedc2725fe28a2701d931b8a52c42fd21444759e1c /japanese/ebview-gtk2/Makefile
parent5c93dd25c8efe643e0b0811cc827f5b790195d22 (diff)
downloadports-baaa0732114a060988ba6a744e3f5c7cf2129ff4.tar.gz
ports-baaa0732114a060988ba6a744e3f5c7cf2129ff4.zip
- Fix build with clang
PR: 185717 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=340308
Diffstat (limited to 'japanese/ebview-gtk2/Makefile')
-rw-r--r--japanese/ebview-gtk2/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 549756a3d2e9..a697b08a7e33 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -10,36 +10,35 @@ PKGNAMESUFFIX= -gtk2
MAINTAINER= ports@FreeBSD.org
COMMENT= Electronic Book Viewer
-LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
+LICENSE= GPLv2 # (or later)
-CONFLICTS= ja-ebview-0*
+LIB_DEPENDS= libeb.so:${PORTSDIR}/japanese/eb
-USES= pkgconfig
-USE_GNOME= gtk20
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+CONFLICTS= ja-ebview-[0-9]*
+
+USES= gettext gmake pkgconfig
+USE_GNOME= gtk20 pangox-compat
USE_CSTD= gnu89
-CONFIGURE_ARGS+=--with-eb-conf=${LOCALBASE}/etc/eb.conf
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-eb-conf=${LOCALBASE}/etc/eb.conf
SUB_FILES= ebview.desktop
-NO_STAGE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-pthread|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|#define GTK_DISABLE_DEPRECATED 1||g' \
${WRKSRC}/src/ebview.c
post-install:
- ${INSTALL_DATA} ${WRKSRC}/pixmaps/ebview.xpm ${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${WRKDIR}/${SUB_FILES} ${PREFIX}/share/applications/
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ (cd ${WRKDIR} && ${INSTALL_DATA} ${SUB_FILES} \
+ ${STAGEDIR}${DESKTOPDIR})
+ (cd ${WRKSRC}/pixmaps && ${INSTALL_DATA} ebview.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ChangeLog README
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
.include <bsd.port.mk>