aboutsummaryrefslogtreecommitdiff
path: root/japanese/groff
diff options
context:
space:
mode:
authorOKAZAKI Tetsurou <okazaki@FreeBSD.org>2006-05-21 23:10:49 +0000
committerOKAZAKI Tetsurou <okazaki@FreeBSD.org>2006-05-21 23:10:49 +0000
commitb374518e4125f2cd1dd5b8d674db7717fe0bdd09 (patch)
tree159f821b3107a47c58f72ea1bea078b91c8efac8 /japanese/groff
parentbfc2b6667d4b45995b9326fc5c830e9320540fba (diff)
downloadports-b374518e4125f2cd1dd5b8d674db7717fe0bdd09.tar.gz
ports-b374518e4125f2cd1dd5b8d674db7717fe0bdd09.zip
Use SUB_FILES to install mdoc.local.
Support newer FreeBSD releases in the Fx macro. (*1) Submitted by: Watanabe Kazuhiro <CQG00620 at nifty.ne.jp> (*1)
Notes
Notes: svn path=/head/; revision=163033
Diffstat (limited to 'japanese/groff')
-rw-r--r--japanese/groff/Makefile22
-rw-r--r--japanese/groff/files/mdoc.local.in69
2 files changed, 80 insertions, 11 deletions
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index 4b3344f776e9..bb97223736a7 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -8,7 +8,7 @@
PORTNAME= groff
PORTVERSION= 1.18.1
DISTVERSIONSUFFIX= .1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_LOCAL:S,%SUBDIR%,okazaki/&,} \
${MASTER_SITE_DEBIAN:S,$,:debian,}
@@ -45,6 +45,15 @@ SITETMACDIR= share/groff/site-tmac
MDOCDIR= ${TMACDIR}/mdoc
PLIST_SUB= GROFF_VERSION=${PORTVERSION}
+SUB_FILES= mdoc.local
+SUB_LIST= OSREL=${OSREL}
+
+TMACFILES= tmac.orig_me tmac.vgrind \
+ an-old.tmac doc.tmac e.tmac
+MDOCFILES= ja.eucJP doc-common doc-syms
+
+DOCUMENTS= ChangeLog.jp NEWS PROBLEMS README README.jp
+
MAN1= addftinfo.1 afmtodit.1 \
eqn.1 eqn2graph.1 \
grn.1 grodvi.1 groff.1 groffer.1 grog.1 \
@@ -58,13 +67,6 @@ MAN7= ditroff.7 groff.7 groff_char.7 groff_diff.7 \
groff_me.7 groff_mm.7 groff_mmse.7 groff_mom.7 groff_ms.7 \
groff_trace.7 groff_www.7 roff.7
-SITETMACFILES= mdoc.local
-TMACFILES= tmac.orig_me tmac.vgrind \
- an-old.tmac doc.tmac e.tmac
-MDOCFILES= ja.eucJP doc-common doc-syms
-
-DOCUMENTS= ChangeLog.jp NEWS PROBLEMS README README.jp
-
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
@@ -128,15 +130,13 @@ post-build:
| ${XARGS} ${REINPLACE_CMD} -E -e 's|pro +([^/].*)|pro ${PREFIX}/bin/\1|g;'
post-install: ${POST_INSTALL_SEQ}
-.for F in ${SITETMACFILES}
- ${INSTALL_DATA} ${TMACBASE}/${F} ${PREFIX}/${SITETMACDIR}
-.endfor
.for F in ${TMACFILES}
${INSTALL_DATA} ${TMACBASE}/${F} ${PREFIX}/${TMACDIR}
.endfor
.for F in ${MDOCFILES}
${INSTALL_DATA} ${TMACBASE}/mdoc/${F} ${PREFIX}/${MDOCDIR}
.endfor
+ ${INSTALL_DATA} ${WRKDIR}/mdoc.local ${PREFIX}/${SITETMACDIR}
install-documents:
@${MKDIR} ${DOCSDIR}/${PORTVERSION}
diff --git a/japanese/groff/files/mdoc.local.in b/japanese/groff/files/mdoc.local.in
new file mode 100644
index 000000000000..74e73ee3d47a
--- /dev/null
+++ b/japanese/groff/files/mdoc.local.in
@@ -0,0 +1,69 @@
+.\" Copyright (c) 2001 Ruslan Ermilov <ru@FreeBSD.org>.
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.\"
+.\" %FreeBSD: src/gnu/usr.bin/groff/tmac/mdoc.local,v 1.2.2.19 2003/03/25 10:20:12 murray Exp %
+.\" $FreeBSD$
+.\"
+.eo
+.ds volume-operating-system FreeBSD
+.ds str-Lb-libc_r Reentrant C\~Library (libc_r, \-pthread)
+.ds str-Lb-libcalendar Calendar Arithmetic Library (libcalendar, \-lcalendar)
+.ds str-Lb-libcam Common Access Method User Library (libcam, \-lcam)
+.ds str-Lb-libcipher FreeSec Crypt Library (libcipher, \-lcipher)
+.ds str-Lb-libdevinfo Device and Resource Information Utility Library (libdevinfo, \-ldevinfo)
+.ds str-Lb-libdevstat Device Statistics Library (libdevstat, \-ldevstat)
+.ds str-Lb-libdisk Interface to Slice and Partition Labels Library (libdisk, \-ldisk)
+.ds str-Lb-libedit Line Editor and History Library (libedit, \-ledit)
+.ds str-Lb-libfetch File Transfer Library (libfetch, \-lfetch)
+.ds str-Lb-libipx IPX Address Conversion Support Library (libipx, \-lipx)
+.ds str-Lb-libmd Message Digest (MD4, MD5, etc.) Support Library (libmd, \-lmd)
+.ds str-Lb-libnetgraph Netgraph User Library (libnetgraph, \-lnetgraph)
+.ds str-Lb-libpam PAM Library (libpam, \-lpam)
+.ds str-Lb-libposix1e POSIX.1e Security API Library (libposix1e, \-lposix1e)
+.ds str-Lb-librpcsvc RPC Service Library (librpcsvc, \-lrpcsvc)
+.ds str-Lb-libskey S/Key Password Control Table Access Library (libskey, \-lskey)
+.ds str-Lb-libusbhid USB HID access routines library (libusbhid, \-lusbhid)
+.ds str-Lb-libvgl Video Graphics Library (libvgl, \-lvgl)
+.ds operating-system FreeBSD\~%%OSREL%%
+.ds operating-system-FreeBSD-4.9 4.9
+.ds operating-system-FreeBSD-4.10 4.10
+.ds operating-system-FreeBSD-4.11 4.11
+.ds operating-system-FreeBSD-5.2 5.2
+.ds operating-system-FreeBSD-5.2.1 5.2.1
+.ds operating-system-FreeBSD-5.3 5.3
+.ds operating-system-FreeBSD-5.4 5.4
+.ds operating-system-FreeBSD-5.5 5.5
+.ds operating-system-FreeBSD-6.0 6.0
+.ds operating-system-FreeBSD-6.1 6.1
+.ds operating-system-FreeBSD-7.0 7.0
+.ec
+.if d locale \{\
+.ie "\*[locale]"ru.KOI8-R" \
+.mso mdoc/ru.KOI8-R
+.el \{ .if "\*[locale]"ja.eucJP" \
+.mso mdoc/ja.eucJP
+.\}\}
+.if d lang \{\
+.if "\*[lang]"ja_JP.eucJP" .mso mdoc/ja.eucJP
+.\}