aboutsummaryrefslogtreecommitdiff
path: root/japanese/kcode
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-10-26 14:28:42 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-10-26 14:28:42 +0000
commit20aba8b57a317e5b6f7238a0703eedebc59ae2d8 (patch)
treeeaaebc189c3513f1385331e1edcef401c0da4af4 /japanese/kcode
parent67148f52a7d06616ce024d941b5f51b5a7522ef3 (diff)
downloadports-20aba8b57a317e5b6f7238a0703eedebc59ae2d8.tar.gz
ports-20aba8b57a317e5b6f7238a0703eedebc59ae2d8.zip
Add ja-kcode, a handy utility to show codepoint information of given
characters.
Notes
Notes: svn path=/head/; revision=120228
Diffstat (limited to 'japanese/kcode')
-rw-r--r--japanese/kcode/Makefile46
-rw-r--r--japanese/kcode/distinfo2
-rw-r--r--japanese/kcode/pkg-descr5
-rw-r--r--japanese/kcode/pkg-plist1
4 files changed, 54 insertions, 0 deletions
diff --git a/japanese/kcode/Makefile b/japanese/kcode/Makefile
new file mode 100644
index 000000000000..cc153633d173
--- /dev/null
+++ b/japanese/kcode/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: kcode
+# Date created: 26 October 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kcode
+PORTVERSION= 1.0
+CATEGORIES= japanese
+MASTER_SITES= http://www.irori.org/dl/tool/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.gz
+EXTRACT_ONLY= ${DISTFILES}
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A handy utility to show codepoint information of given characters
+
+RUN_DEPENDS= ${_RUN_DEPENDS}
+
+USE_PERL= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+MANLANG= ja
+MAN1= kcode.1
+MANCOMPRESSED= no
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6.0 or later
+.elif ${PERL_LEVEL} < 500800
+_RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+.endif
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} > ${WRKSRC}/kcode
+ pod2man ${WRKSRC}/kcode ${WRKSRC}/kcode.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/kcode ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/kcode.1 ${MAN1PREFIX}/man/ja/man1/
+
+.include <bsd.port.post.mk>
diff --git a/japanese/kcode/distinfo b/japanese/kcode/distinfo
new file mode 100644
index 000000000000..71791306b18a
--- /dev/null
+++ b/japanese/kcode/distinfo
@@ -0,0 +1,2 @@
+MD5 (kcode-1.0.gz) = 5ac5325d6683080596079941d5718615
+SIZE (kcode-1.0.gz) = 2492
diff --git a/japanese/kcode/pkg-descr b/japanese/kcode/pkg-descr
new file mode 100644
index 000000000000..13bc5941f9fb
--- /dev/null
+++ b/japanese/kcode/pkg-descr
@@ -0,0 +1,5 @@
+kcode is a handy utility to show codepoint information of given
+characters.
+
+WWW: http://www.irori.org/tool/kcode.html
+Author: HIROSE, Masaaki <hirose31 -at- irori -dot- org>
diff --git a/japanese/kcode/pkg-plist b/japanese/kcode/pkg-plist
new file mode 100644
index 000000000000..cd4cf5adbb4a
--- /dev/null
+++ b/japanese/kcode/pkg-plist
@@ -0,0 +1 @@
+bin/kcode