aboutsummaryrefslogtreecommitdiff
path: root/japanese/lookup/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /japanese/lookup/Makefile
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.tar.gz
ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Notes
Notes: svn path=/head/; revision=460621
Diffstat (limited to 'japanese/lookup/Makefile')
-rw-r--r--japanese/lookup/Makefile35
1 files changed, 7 insertions, 28 deletions
diff --git a/japanese/lookup/Makefile b/japanese/lookup/Makefile
index 807c14f870d5..2878caab5cc5 100644
--- a/japanese/lookup/Makefile
+++ b/japanese/lookup/Makefile
@@ -6,40 +6,19 @@ PORTVERSION= 1.4.1
PORTREVISION= 19
CATEGORIES= japanese elisp
MASTER_SITES= http://openlab.ring.gr.jp/edict/lookup/dist/
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
MAINTAINER= yasu@utahime.org
-COMMENT= Search interface on ${EMACS_PORT_NAME} for CD-ROM books, etc
+COMMENT= Emacs search interface for CD-ROM books, etc
LICENSE= GPLv2
-USE_EMACS= yes
+USES= emacs
-INFO?= lookup lookup-guide
-
-.include <bsd.port.pre.mk>
-
-.if (${EMACS_PORT_NAME} == "xemacs21-mule")
-EMACSDIR= ${PREFIX}/lib/xemacs/site-packages
-ELISPDIR= ${EMACSDIR}/lisp/lookup
-MANIFEST= MANIFEST.lookup
-.else
-ELISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/lookup
-PLIST_SUB= ELISPDIR=${EMACS_VERSION_SITE_LISPDIR}
-.endif
+EMACS_FLAVORS_EXCLUDE= devel_full and devel_nox # fail to build
+INFO= lookup lookup-guide
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
- --with-lispdir=${ELISPDIR}
-
-post-install:
-.if (${EMACS_PORT_NAME} == "xemacs21-mule")
- ${RM} ${WRKDIR}/${MANIFEST}
- emacsdir=`${ECHO_CMD} ${EMACSDIR} | ${SED} -e "s;^${PREFIX}/;;"`; \
- ${CAT} ${PLIST} | ${GREP} -e "^$${emacsdir}" | \
- ${SED} -e "s;^$${emacsdir}/;;" > ${WRKDIR}/${MANIFEST}
- ${MKDIR} ${EMACSDIR}/pkginfo
- ${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
- ${EMACSDIR}/pkginfo/
-.endif
+ --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/lookup
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>