aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-tool
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2010-09-18 06:05:47 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2010-09-18 06:05:47 +0000
commitfb9115ac90b4e96190acc267fe641d8062206755 (patch)
tree42f1b7b2377edaab4a3215a10c810acd77a57277 /japanese/mozc-tool
parentf44d934c79b9518ba5c4f449303f6b2ea460dd55 (diff)
downloadports-fb9115ac90b4e96190acc267fe641d8062206755.tar.gz
ports-fb9115ac90b4e96190acc267fe641d8062206755.zip
Update mozc to 0.13.464.102
Notes
Notes: svn path=/head/; revision=261369
Diffstat (limited to 'japanese/mozc-tool')
-rw-r--r--japanese/mozc-tool/Makefile3
-rw-r--r--japanese/mozc-tool/distinfo6
-rw-r--r--japanese/mozc-tool/files/patch-base_iconv.cc11
-rw-r--r--japanese/mozc-tool/files/patch-base_mutex.h19
-rw-r--r--japanese/mozc-tool/files/patch-base_process.cc23
-rw-r--r--japanese/mozc-tool/files/patch-base_util.cc18
-rw-r--r--japanese/mozc-tool/files/patch-build_mozc.py24
-rw-r--r--japanese/mozc-tool/files/patch-build_tools_mozc_version.py6
-rw-r--r--japanese/mozc-tool/files/patch-gui_about_dialog_about_dialog.cc11
-rw-r--r--japanese/mozc-tool/files/patch-gui_about_dialog_version_image_widget.cc11
-rw-r--r--japanese/mozc-tool/files/patch-gyp_common.gypi10
-rw-r--r--japanese/mozc-tool/files/patch-ipc_ipc_path_manager.cc11
-rw-r--r--japanese/mozc-tool/files/patch-ipc_unix_ipc.cc14
-rw-r--r--japanese/mozc-tool/files/patch-server_mozc_server.cc21
-rw-r--r--japanese/mozc-tool/files/patch-unix_ibus_gen_mozc_xml.py48
-rw-r--r--japanese/mozc-tool/files/patch-unix_ibus_path_util.cc16
-rw-r--r--japanese/mozc-tool/files/patch-unix_scim_scim.gyp4
17 files changed, 152 insertions, 104 deletions
diff --git a/japanese/mozc-tool/Makefile b/japanese/mozc-tool/Makefile
index a1b3605edac1..8ce8a10d8a93 100644
--- a/japanese/mozc-tool/Makefile
+++ b/japanese/mozc-tool/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mozc-tool
-PORTVERSION= 0.12.434.102
-PORTREVISION= 1
+PORTVERSION= 0.13.464.102
CATEGORIES= japanese
MASTER_SITES= http://people.freebsd.org/~daichi/distfiles/
DISTNAME= mozc-${PORTVERSION}
diff --git a/japanese/mozc-tool/distinfo b/japanese/mozc-tool/distinfo
index 1bb54ac94b84..8b8c964afe8a 100644
--- a/japanese/mozc-tool/distinfo
+++ b/japanese/mozc-tool/distinfo
@@ -1,3 +1,3 @@
-MD5 (mozc-0.12.434.102.tar.bz2) = ea760a57120e864feb1370ac03da6306
-SHA256 (mozc-0.12.434.102.tar.bz2) = 7256549a83537a8d63de7e51996c28b11d1431a149985692f9ccfdd3edabe22c
-SIZE (mozc-0.12.434.102.tar.bz2) = 34570612
+MD5 (mozc-0.13.464.102.tar.bz2) = cfca690cd9479140e362582ed2485efe
+SHA256 (mozc-0.13.464.102.tar.bz2) = bf4b7098dbedb2f76c5fb5ef2cd23901aef851cc169f3afd313346c67ae78435
+SIZE (mozc-0.13.464.102.tar.bz2) = 37926890
diff --git a/japanese/mozc-tool/files/patch-base_iconv.cc b/japanese/mozc-tool/files/patch-base_iconv.cc
index fd1f0fd28e43..8c1ba452294f 100644
--- a/japanese/mozc-tool/files/patch-base_iconv.cc
+++ b/japanese/mozc-tool/files/patch-base_iconv.cc
@@ -1,11 +1,14 @@
---- base/iconv.cc.org 2010-08-13 19:48:06.000000000 +0900
-+++ base/iconv.cc 2010-09-03 11:18:15.807359114 +0900
-@@ -52,7 +52,7 @@
+--- base/iconv.cc.org 2010-09-18 12:20:13.813642569 +0900
++++ base/iconv.cc 2010-09-18 12:19:33.357557229 +0900
+@@ -52,7 +52,11 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
while (ilen != 0) {
-- if (iconv(ic, reinterpret_cast<char **>(&ibuf), &ilen, &obuf, &olen)
++#ifdef __FreeBSD__
+ if (iconv(ic, (const char **)(&ibuf), &ilen, &obuf, &olen)
++#else
+ if (iconv(ic, reinterpret_cast<char **>(&ibuf), &ilen, &obuf, &olen)
++#endif
== static_cast<size_t>(-1)) {
return;
}
diff --git a/japanese/mozc-tool/files/patch-base_mutex.h b/japanese/mozc-tool/files/patch-base_mutex.h
index af372ba36f23..c75ef246511a 100644
--- a/japanese/mozc-tool/files/patch-base_mutex.h
+++ b/japanese/mozc-tool/files/patch-base_mutex.h
@@ -1,11 +1,16 @@
---- base/mutex.h 2010-08-13 19:48:05.000000000 +0900
-+++ base/mutex.h 2010-09-03 11:20:50.849065252 +0900
-@@ -87,7 +87,7 @@
+--- base/mutex.h.org 2010-09-18 12:23:25.325487231 +0900
++++ base/mutex.h 2010-09-18 12:25:51.859100581 +0900
+@@ -82,11 +82,11 @@
+ // PTHREAD_MUTEX_RECURSIVE_NP and PTHREAD_MUTEX_RECURSIVE seem to be
+ // variants. For example, Mac OS X 10.4 had
+ // PTHREAD_MUTEX_RECURSIVE_NP but Mac OS X 10.5 does not
+-#ifdef OS_MACOSX
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
+ #define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE
#endif
- #ifdef OS_LINUX
--#define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE_NP
-+#define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE
+-#ifdef OS_LINUX
++#if defined(OS_LINUX) && !defined(__FreeBSD__)
+ #define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE_NP
#endif
- pthread_mutexattr_t attr;
diff --git a/japanese/mozc-tool/files/patch-base_process.cc b/japanese/mozc-tool/files/patch-base_process.cc
index 41266287602e..908ba1effdb2 100644
--- a/japanese/mozc-tool/files/patch-base_process.cc
+++ b/japanese/mozc-tool/files/patch-base_process.cc
@@ -1,11 +1,22 @@
---- base/process.cc 2010-08-13 19:48:06.000000000 +0900
-+++ base/process.cc 2010-09-03 11:22:43.438900552 +0900
-@@ -195,7 +195,7 @@
+--- base/process.cc.org 2010-09-18 12:27:25.817558709 +0900
++++ base/process.cc 2010-09-18 12:30:41.053121051 +0900
+@@ -194,13 +194,18 @@
+ return ShellExecuteInSystemDir(L"open", wurl.c_str(), NULL, SW_SHOW);
#endif
- #ifdef OS_LINUX
-- static const char kBrowserCommand[] = "/usr/bin/xdg-open";
-+ static const char kBrowserCommand[] = "@@LOCALBASE@@/bin/xdg-open";
+-#ifdef OS_LINUX
++#if defined(OS_LINUX) && !defined(__FreeBSD__)
+ static const char kBrowserCommand[] = "/usr/bin/xdg-open";
// xdg-open which uses kfmclient or gnome-open internally works both on KDE
// and GNOME environments.
return SpawnProcess(kBrowserCommand, url);
+ #endif // LINUX
+
++#ifdef __FreeBSD__
++ static const char kBrowserCommand[] = "@@LOCALBASE@@/bin/xdg-open";
++ return SpawnProcess(kBrowserCommand, url);
++#endif
++
+ #ifdef OS_MACOSX
+ return MacProcess::OpenBrowserForMac(url);
+ #endif // OS_MACOSX
diff --git a/japanese/mozc-tool/files/patch-base_util.cc b/japanese/mozc-tool/files/patch-base_util.cc
index 9232b1b623e4..bee40881543d 100644
--- a/japanese/mozc-tool/files/patch-base_util.cc
+++ b/japanese/mozc-tool/files/patch-base_util.cc
@@ -1,11 +1,17 @@
---- base/util.cc.org 2010-09-03 11:24:20.268706017 +0900
-+++ base/util.cc 2010-09-03 11:24:57.363718651 +0900
-@@ -1497,7 +1497,7 @@
+--- base/util.cc.org 2010-09-18 12:31:34.023397161 +0900
++++ base/util.cc 2010-09-18 12:34:43.496234072 +0900
+@@ -1525,9 +1525,13 @@
+ return MacUtil::GetServerDirectory();
#endif // OS_MACOSX
- #ifdef OS_LINUX
-- return "/usr/lib/mozc";
-+ return "@@LOCALBASE@@/bin";
+-#ifdef OS_LINUX
++#if defined(OS_LINUX) && !defined(__FreeBSD__)
+ return "/usr/lib/mozc";
#endif // OS_LINUX
++
++#ifdef __FreeBSD__
++ return "@@LOCALBASE@@/bin";
++#endif
}
+ string Util::GetServerPath() {
diff --git a/japanese/mozc-tool/files/patch-build_mozc.py b/japanese/mozc-tool/files/patch-build_mozc.py
index 5976188aecb6..c174a39a2da0 100644
--- a/japanese/mozc-tool/files/patch-build_mozc.py
+++ b/japanese/mozc-tool/files/patch-build_mozc.py
@@ -1,29 +1,29 @@
---- build_mozc.py.org 2010-09-03 11:25:55.375517357 +0900
-+++ build_mozc.py 2010-09-03 14:33:39.472673001 +0900
+--- build_mozc.py.org 2010-09-18 12:36:34.298723774 +0900
++++ build_mozc.py 2010-09-18 12:43:00.635215143 +0900
@@ -69,7 +69,7 @@
def IsLinux():
"""Returns true if the platform is Linux."""
- return os.name == 'posix' and os.uname()[0] == 'Linux'
-+ return os.name == 'posix' and os.uname()[0] == 'FreeBSD'
++ return os.name == 'posix' and ( os.uname()[0] == 'Linux' or os.uname()[0] == 'FreeBSD' )
# TODO(yukawa): Move this function to util.py (b/2715400)
-@@ -510,7 +510,7 @@
- default='Win32',
- help='specify the target plaform: [Win32|x64]')
+@@ -576,6 +576,8 @@
+
# default Qt dir to support the current build procedure for Debian.
-- default_qtdir = '/usr/local/Trolltech/Qt-4.5.2'
-+ default_qtdir = '@@LOCALBASE@@/lib/qt4'
+ default_qtdir = '/usr/local/Trolltech/Qt-4.6.3'
++ if os.uname()[0] == 'FreeBSD':
++ default_qtdir = '@@LOCALBASE@@/lib/qt4'
if IsWindows():
default_qtdir = None
parser.add_option('--qtdir', dest='qtdir',
-@@ -557,7 +557,7 @@
- (unused_gyp_file_name, target_name) = ParseTarget(target)
+@@ -627,6 +629,8 @@
target_names.append(target_name)
-- make_command = os.getenv('BUILD_COMMAND', 'make')
-+ make_command = os.getenv('BUILD_COMMAND', 'gmake')
+ make_command = os.getenv('BUILD_COMMAND', 'make')
++ if os.uname()[0] == 'FreeBSD':
++ make_command = os.getenv('BUILD_COMMAND', 'gmake')
# flags for building in Chrome OS chroot environment
envvars = [
'CFLAGS',
diff --git a/japanese/mozc-tool/files/patch-build_tools_mozc_version.py b/japanese/mozc-tool/files/patch-build_tools_mozc_version.py
index cdfb90dffaaf..d4974e32f682 100644
--- a/japanese/mozc-tool/files/patch-build_tools_mozc_version.py
+++ b/japanese/mozc-tool/files/patch-build_tools_mozc_version.py
@@ -1,11 +1,11 @@
---- build_tools/mozc_version.py.org 2010-09-03 14:19:13.609379202 +0900
-+++ build_tools/mozc_version.py 2010-09-03 14:18:44.423726277 +0900
+--- build_tools/mozc_version.py.org 2010-09-18 12:43:48.727968273 +0900
++++ build_tools/mozc_version.py 2010-09-18 12:44:16.755115578 +0900
@@ -55,7 +55,7 @@
def IsLinux():
"""Returns true if the platform is Linux."""
- return os.name == 'posix' and os.uname()[0] == 'Linux'
-+ return os.name == 'posix' and os.uname()[0] == 'FreeBSD'
++ return os.name == 'posix' and ( os.uname()[0] == 'Linux' or os.uname()[0] == 'FreeBSD' )
def CalculateRevisionForPlatform(revision):
diff --git a/japanese/mozc-tool/files/patch-gui_about_dialog_about_dialog.cc b/japanese/mozc-tool/files/patch-gui_about_dialog_about_dialog.cc
index 8dc80af3d463..416af258cca9 100644
--- a/japanese/mozc-tool/files/patch-gui_about_dialog_about_dialog.cc
+++ b/japanese/mozc-tool/files/patch-gui_about_dialog_about_dialog.cc
@@ -1,11 +1,14 @@
---- gui/about_dialog/about_dialog.cc.org 2010-09-03 19:41:20.545071308 +0900
-+++ gui/about_dialog/about_dialog.cc 2010-09-03 19:43:51.975348061 +0900
-@@ -114,7 +114,7 @@
+--- gui/about_dialog/about_dialog.cc.org 2010-09-18 12:44:49.983959188 +0900
++++ gui/about_dialog/about_dialog.cc 2010-09-18 12:46:24.679654311 +0900
+@@ -114,7 +114,11 @@
SetLabelText(label_terms);
SetLabelText(label_credits);
-- product_image_.reset(new QImage(":/product_logo.png"));
++#ifdef __FreeBSD__
+ product_image_.reset(new QImage("@@LOCALBASE@@/share/mozc-tool/icons/product_logo.png"));
++#else
+ product_image_.reset(new QImage(":/product_logo.png"));
++#endif
}
void AboutDialog::paintEvent(QPaintEvent *event) {
diff --git a/japanese/mozc-tool/files/patch-gui_about_dialog_version_image_widget.cc b/japanese/mozc-tool/files/patch-gui_about_dialog_version_image_widget.cc
index 7bd46b21404b..05908d134771 100644
--- a/japanese/mozc-tool/files/patch-gui_about_dialog_version_image_widget.cc
+++ b/japanese/mozc-tool/files/patch-gui_about_dialog_version_image_widget.cc
@@ -1,11 +1,14 @@
---- gui/about_dialog/version_image_widget.cc.org 2010-09-03 19:45:25.423577654 +0900
-+++ gui/about_dialog/version_image_widget.cc 2010-09-03 19:44:57.400714134 +0900
-@@ -41,7 +41,7 @@
+--- gui/about_dialog/version_image_widget.cc.org 2010-09-18 12:47:08.097447075 +0900
++++ gui/about_dialog/version_image_widget.cc 2010-09-18 12:47:49.718581046 +0900
+@@ -41,7 +41,11 @@
void VersionImageWidget::loadImage() {
// Currently the version is always latest.
// TODO(mukai): add the version checking logic
-- pixmap_.reset(new QPixmap(":/update_uptodate.png"));
++#ifdef __FreeBSD__
+ pixmap_.reset(new QPixmap("@@LOCALBASE@@/share/mozc-tool/icons/update_uptodate.png"));
++#else
+ pixmap_.reset(new QPixmap(":/update_uptodate.png"));
++#endif
}
void VersionImageWidget::paintEvent(QPaintEvent* paint_event) {
diff --git a/japanese/mozc-tool/files/patch-gyp_common.gypi b/japanese/mozc-tool/files/patch-gyp_common.gypi
index a7e6ffa151a7..df9dd03305ef 100644
--- a/japanese/mozc-tool/files/patch-gyp_common.gypi
+++ b/japanese/mozc-tool/files/patch-gyp_common.gypi
@@ -1,6 +1,6 @@
---- gyp/common.gypi.org 2010-09-03 11:27:13.818109921 +0900
-+++ gyp/common.gypi 2010-09-03 11:28:44.023549160 +0900
-@@ -397,6 +397,12 @@
+--- gyp/common.gypi.org 2010-09-18 12:48:37.180713244 +0900
++++ gyp/common.gypi 2010-09-18 12:49:57.723919434 +0900
+@@ -437,6 +437,12 @@
'-lz',
'<@(extra_linux_libs)',
],
@@ -11,5 +11,5 @@
+ '-L@@LOCALBASE@@/lib'
+ ],
'conditions': [
- ['chromeos==1', {
- 'defines': [
+ ['use_libgtest==0', {
+ 'include_dirs': [
diff --git a/japanese/mozc-tool/files/patch-ipc_ipc_path_manager.cc b/japanese/mozc-tool/files/patch-ipc_ipc_path_manager.cc
index af41eb56846a..845d61690f3a 100644
--- a/japanese/mozc-tool/files/patch-ipc_ipc_path_manager.cc
+++ b/japanese/mozc-tool/files/patch-ipc_ipc_path_manager.cc
@@ -1,14 +1,11 @@
---- ipc/ipc_path_manager.cc.org 2010-09-04 07:45:47.421394850 +0900
-+++ ipc/ipc_path_manager.cc 2010-09-04 07:50:27.875266222 +0900
-@@ -265,7 +265,10 @@
+--- ipc/ipc_path_manager.cc.org 2010-09-18 12:50:30.684194274 +0900
++++ ipc/ipc_path_manager.cc 2010-09-18 12:51:46.640904973 +0900
+@@ -265,7 +265,7 @@
*ipc_name = kIPCPrefix;
#endif // OS_WINDOWS
-#ifdef OS_LINUX
-+#if !defined(__FreeBSD__) && defined(OS_LINUX)
-+// XXX
-+// Abstract Namespace of socket is LINUX ONLY incompatible feature.
-+// XXX
++#if defined(OS_LINUX) && !defined(__FreeBSD__)
// On Linux, use abstract namespace which is independent of the file system.
(*ipc_name)[0] = '\0';
#endif
diff --git a/japanese/mozc-tool/files/patch-ipc_unix_ipc.cc b/japanese/mozc-tool/files/patch-ipc_unix_ipc.cc
index 7c173cb839ee..b547617972be 100644
--- a/japanese/mozc-tool/files/patch-ipc_unix_ipc.cc
+++ b/japanese/mozc-tool/files/patch-ipc_unix_ipc.cc
@@ -1,11 +1,11 @@
---- ipc/unix_ipc.cc.org 2010-09-03 11:29:17.747782268 +0900
-+++ ipc/unix_ipc.cc 2010-09-05 10:10:24.194440985 +0900
+--- ipc/unix_ipc.cc.org 2010-09-18 12:52:17.569066513 +0900
++++ ipc/unix_ipc.cc 2010-09-18 12:56:22.118871027 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
#include <sys/types.h>
#include <sys/un.h>
-#ifdef OS_MACOSX
-+#if defined(__FreeBSD__) || defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
#include <sys/ucred.h>
#endif
#include <sys/wait.h>
@@ -14,7 +14,7 @@
*pid = 0;
-#ifdef OS_MACOSX
-+#if defined(__FreeBSD__) || defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
// If the OS is MAC, we should validate the peer by using LOCAL_PEERCRED.
struct xucred peer_cred;
socklen_t peer_cred_len = sizeof(struct xucred);
@@ -23,7 +23,7 @@
#endif
-#ifdef OS_LINUX
-+#if !defined(__FreeBSD__) && defined(OS_LINUX)
++#if defined(OS_LINUX) && !defined(__FreeBSD__)
// On ARM Linux, we do nothing and just return true since the platform (at
// least the qemu emulator) doesn't support the getsockopt(sock, SOL_SOCKET,
// SO_PEERCRED) system call.
@@ -32,7 +32,7 @@
::memcpy(address.sun_path, server_address.data(), server_address_length);
address.sun_path[server_address_length] = '\0';
-#ifdef OS_MACOSX
-+#if defined(__FreeBSD__) || defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
address.sun_len = SUN_LEN(&address);
const size_t sun_len = sizeof(address);
#else
@@ -41,7 +41,7 @@
reinterpret_cast<char *>(&on),
sizeof(on));
-#ifdef OS_MACOSX
-+#if defined(__FreeBSD__) || defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
addr.sun_len = SUN_LEN(&addr);
const size_t sun_len = sizeof(addr);
#else
diff --git a/japanese/mozc-tool/files/patch-server_mozc_server.cc b/japanese/mozc-tool/files/patch-server_mozc_server.cc
index 5562bd9b1367..bd58a84c4a7d 100644
--- a/japanese/mozc-tool/files/patch-server_mozc_server.cc
+++ b/japanese/mozc-tool/files/patch-server_mozc_server.cc
@@ -1,19 +1,20 @@
---- server/mozc_server.cc.org 2010-09-05 10:11:21.205396567 +0900
-+++ server/mozc_server.cc 2010-09-05 10:36:15.099047296 +0900
-@@ -29,6 +29,8 @@
-
+--- server/mozc_server.cc.org 2010-09-18 12:57:52.229553251 +0900
++++ server/mozc_server.cc 2010-09-18 13:00:29.172975389 +0900
+@@ -30,6 +30,9 @@
#ifdef OS_WINDOWS
#include <windows.h>
-+#else
-+#include <signal.h>
#endif
++#ifdef __FreeBSD__
++#include <signal.h>
++#endif
#include "base/base.h"
-@@ -46,6 +48,23 @@
+ #include "base/process.h"
+@@ -46,6 +49,23 @@
mozc::SessionServer *g_session_server = NULL;
}
-+#ifndef OS_WINDOWS
++#ifdef __FreeBSD__
+static void sig_func(int num)
+{
+ VLOG(1) << "signal " << num << " recieved.";
@@ -33,11 +34,11 @@
namespace mozc {
namespace {
-@@ -122,6 +141,12 @@
+@@ -122,6 +142,12 @@
return -1;
}
-+#ifndef OS_WINDOWS
++#ifdef __FreeBSD__
+ ::signal(SIGINT, sig_func);
+ ::signal(SIGHUP, sig_func);
+ ::signal(SIGTERM, sig_func);
diff --git a/japanese/mozc-tool/files/patch-unix_ibus_gen_mozc_xml.py b/japanese/mozc-tool/files/patch-unix_ibus_gen_mozc_xml.py
index 59c98cc23605..0acab8a486de 100644
--- a/japanese/mozc-tool/files/patch-unix_ibus_gen_mozc_xml.py
+++ b/japanese/mozc-tool/files/patch-unix_ibus_gen_mozc_xml.py
@@ -1,20 +1,34 @@
---- unix/ibus/gen_mozc_xml.py.org 2010-09-03 21:07:35.757153220 +0900
-+++ unix/ibus/gen_mozc_xml.py 2010-09-03 21:11:23.381492067 +0900
-@@ -47,7 +47,7 @@
- 'description': '%s Component',
- # TODO(yusukes): Support Linux distributions other than Gentoo/ChromeOS.
- # For example, Ubuntu uses /usr/lib/ibus-mozc/.
-- 'exec': '/usr/libexec/ibus-engine-mozc --ibus',
-+ 'exec': '@@LOCALBASE@@/libexec/ibus-engine-mozc --ibus',
- # TODO(mazda): Generate the version number.
- 'version': '0.0.0.0',
- 'author': 'Google Inc.',
-@@ -60,7 +60,7 @@
- IBUS_ENGINE_COMMON_PROPS = {
- 'description': '%s (Japanese Input Method)',
- 'language': 'ja',
-- 'icon': '/usr/share/ibus-mozc/product_icon.png',
-+ 'icon': '@@LOCALBASE@@/share/ibus-mozc/icons/product_logo.png',
+--- unix/ibus/gen_mozc_xml.py.org 2010-09-18 13:01:05.001373133 +0900
++++ unix/ibus/gen_mozc_xml.py 2010-09-18 14:29:43.314467115 +0900
+@@ -39,6 +39,7 @@
+
+ import optparse
+ import sys
++import os
+
+ # Information to generate <component> part of mozc.xml. %s will be replaced with
+ # a product name, 'Mozc' or 'Google Japanese Input'.
+@@ -63,6 +64,23 @@
+ 'icon': '/usr/share/ibus-mozc/product_icon.png',
'rank': '0',
}
++if os.uname()[0] == 'FreeBSD':
++ IBUS_COMPONENT_PROPS = {
++ 'name': 'com.google.IBus.Mozc',
++ 'description': '%s Component',
++ 'exec': '@@LOCALBASE@@/libexec/ibus-engine-mozc --ibus',
++ 'version': '0.0.0.0',
++ 'author': 'Google Inc.',
++ 'license': 'New BSD',
++ 'homepage': 'http://code.google.com/p/mozc/',
++ 'textdomain': 'ibus-mozc',
++ }
++ IBUS_ENGINE_COMMON_PROPS = {
++ 'description': '%s (Japanese Input Method)',
++ 'language': 'ja',
++ 'icon': '@@LOCALBASE@@/share/ibus-mozc/icons/product_logo.png',
++ 'rank': '0',
++ }
+ # A dictionary from --platform to engines that are used in the platform. The
+ # information is used to generate <engines> part of mozc.xml.
diff --git a/japanese/mozc-tool/files/patch-unix_ibus_path_util.cc b/japanese/mozc-tool/files/patch-unix_ibus_path_util.cc
index 7239e163f057..7cf1593994b2 100644
--- a/japanese/mozc-tool/files/patch-unix_ibus_path_util.cc
+++ b/japanese/mozc-tool/files/patch-unix_ibus_path_util.cc
@@ -1,19 +1,25 @@
---- unix/ibus/path_util.cc.org 2010-09-03 11:46:40.275135605 +0900
-+++ unix/ibus/path_util.cc 2010-09-03 11:47:34.058766206 +0900
-@@ -30,14 +30,14 @@
+--- unix/ibus/path_util.cc.org 2010-09-18 13:05:52.470217916 +0900
++++ unix/ibus/path_util.cc 2010-09-18 13:07:06.436608058 +0900
+@@ -30,14 +30,22 @@
#include "unix/ibus/path_util.h"
namespace {
--const char kInstalledDirectory[] = "/usr/share/ibus-mozc";
++#ifdef __FreeBSD__
+const char kInstalledDirectory[] = "@@LOCALBASE@@/share/ibus-mozc";
++#else
+ const char kInstalledDirectory[] = "/usr/share/ibus-mozc";
++#endif
}
namespace mozc {
namespace ibus {
string GetIconPath(const string &icon_file) {
-- return kInstalledDirectory + string("/") + icon_file;
++#ifdef __FreeBSD__
+ return string("@@LOCALBASE@@/share/ibus-mozc/icons/") + icon_file;
++#else
+ return kInstalledDirectory + string("/") + icon_file;
++#endif
}
} // namespace ibus
diff --git a/japanese/mozc-tool/files/patch-unix_scim_scim.gyp b/japanese/mozc-tool/files/patch-unix_scim_scim.gyp
index ac1e153c7e7c..d3189a6f0a31 100644
--- a/japanese/mozc-tool/files/patch-unix_scim_scim.gyp
+++ b/japanese/mozc-tool/files/patch-unix_scim_scim.gyp
@@ -1,5 +1,5 @@
---- unix/scim/scim.gyp.org 2010-09-03 11:48:22.034373161 +0900
-+++ unix/scim/scim.gyp 2010-09-03 11:57:21.964398346 +0900
+--- unix/scim/scim.gyp.org 2010-09-18 13:07:44.032136540 +0900
++++ unix/scim/scim.gyp 2010-09-18 13:08:24.780919695 +0900
@@ -44,7 +44,7 @@
'../../session/session.gyp:session',
],