aboutsummaryrefslogtreecommitdiff
path: root/japanese/otojiro-fpw
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2002-09-15 05:48:30 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2002-09-15 05:48:30 +0000
commit8ede6d055bdf6214746e6fad0ef90b2a978e2ee2 (patch)
treeaa211293763c187535474a2749fe69820ca48048 /japanese/otojiro-fpw
parenteda1c349aeb133fcd833947a6c792d516f501e74 (diff)
downloadports-8ede6d055bdf6214746e6fad0ef90b2a978e2ee2.tar.gz
ports-8ede6d055bdf6214746e6fad0ef90b2a978e2ee2.zip
Support the original dictionary EIJIRO included in a book sold by ALC Inc.
In the version, the dictionary files are archived in LHA format Change ${ENV} to ${SETENV} Submitted by: knu Fix the dependency Using FreePWING 1.4.3, deleting CR after NL is not necessary So nkf is not necessary. After FreePWING 1.4.2, catdump is used in FreePWING instead of epwutil.
Notes
Notes: svn path=/head/; revision=66344
Diffstat (limited to 'japanese/otojiro-fpw')
-rw-r--r--japanese/otojiro-fpw/Makefile34
1 files changed, 22 insertions, 12 deletions
diff --git a/japanese/otojiro-fpw/Makefile b/japanese/otojiro-fpw/Makefile
index 9a2ed784cd8c..b328c2d2d4ff 100644
--- a/japanese/otojiro-fpw/Makefile
+++ b/japanese/otojiro-fpw/Makefile
@@ -14,8 +14,8 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.a/a/}-src
MAINTAINER= taoka@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
- nkf:${PORTSDIR}/japanese/nkf \
+BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
+ ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
@@ -24,10 +24,25 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/otojiro-fpw${PORTVERSION:S/.a/a/}
DICT_PATH?= /cdrom
SRCFILE?= otojiro.txt
-MAKE_ENV= OTOJIRO_FILE=${DICT_PATH}/${SRCFILE}
-pre-extract::
- @if [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
+# For eijiro included in a book sold by ALC Inc.
+# (http://www.alc.co.jp/alcshop/eng/eijiro/)
+.if exists(${DICT_PATH}/eijiro-original)
+BUILD_DEPENDS+= lha:${PORTSDIR}/archivers/lha
+
+CDROM_PATH:= ${DICT_PATH}
+DICT_PATH:= ${WRKDIR}
+.else
+CDROM_PATH= ${NONEXISTENT}
+.endif
+
+MAKE_ENV:= OTOJIRO_FILE=${DICT_PATH}/${SRCFILE}
+
+post-extract:
+ @if [ -f ${CDROM_PATH}/eijiro-original/*.exe ]; then \
+ ${MKDIR} ${WRKDIR}; \
+ lha xiw=${WRKDIR} ${CDROM_PATH}/eijiro-original/*.exe '*/${SRCFILE}'; \
+ elif [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
${ECHO} "###################################################"; \
${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
${ECHO} "Specify the Otojiro Dictionary file with the full path"; \
@@ -39,14 +54,9 @@ pre-extract::
${FALSE}; \
fi
-post-build:
-## To delete CR after NL
- cd ${WRKSRC}; ${MV} catalogs.txt catalogs.txt.org; \
- nkf -sSd catalogs.txt.org > catalogs.txt; \
- fpwmake catalogs
-
do-build:
- cd ${WRKSRC}; ${ENV} ${MAKE_ENV} fpwmake
+ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} fpwmake; \
+ fpwmake catalogs
do-install:
${MKDIR} ${PREFIX}/share/dict/otojiro-fpw/otojiro/data