aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-Text-Kakasi/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /japanese/p5-Text-Kakasi/Makefile
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=29658
Diffstat (limited to 'japanese/p5-Text-Kakasi/Makefile')
-rw-r--r--japanese/p5-Text-Kakasi/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/japanese/p5-Text-Kakasi/Makefile b/japanese/p5-Text-Kakasi/Makefile
index 332ba436dfa5..e3c701b83fb9 100644
--- a/japanese/p5-Text-Kakasi/Makefile
+++ b/japanese/p5-Text-Kakasi/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= kakasi.2:${PORTSDIR}/japanese/kakasi
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Text::Kakasi.3
@@ -24,6 +24,7 @@ MAN3= Text::Kakasi.3
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.post.mk>