aboutsummaryrefslogtreecommitdiff
path: root/japanese/prn/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-24 13:54:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-24 13:54:11 +0000
commit2750942f18c7c9b42a36b950d2121dfe778bd934 (patch)
tree9e7e43ef6f11cf6f99de302d92eff10418f9a8cc /japanese/prn/Makefile
parentbcfc2e3ebf9b58458114c02019ce6604855a964c (diff)
downloadports-2750942f18c7c9b42a36b950d2121dfe778bd934.tar.gz
ports-2750942f18c7c9b42a36b950d2121dfe778bd934.zip
- Fix build with clang
- Remove leading article from COMMENT - Support staging PR: ports/184900 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337355
Diffstat (limited to 'japanese/prn/Makefile')
-rw-r--r--japanese/prn/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/japanese/prn/Makefile b/japanese/prn/Makefile
index 626512b78286..23051206caf7 100644
--- a/japanese/prn/Makefile
+++ b/japanese/prn/Makefile
@@ -3,19 +3,28 @@
PORTNAME= prn
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_PORTS_JP}
DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A yet another converter from text file to postscript (with Japanese support)
+COMMENT= Yet another converter from text file to postscript (with Japanese support)
RUN_DEPENDS= kcc:${PORTSDIR}/japanese/kcc
-INSTALL_TARGET= install install.man
-MANLANG= ja
-MAN1= prn.1 cprn.1 cmt.1 psconv.1
-MAN5= cmtdefs.5
+do-install:
+.for i in cmt prn psconv
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
+.endfor
+ ${LN} -sf prn ${STAGEDIR}${PREFIX}/bin/cprn
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} cmtdefs ${STAGEDIR}${DATADIR})
+.for i in cmt cprn prn psconv
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${i}.jman \
+ ${STAGEDIR}${MANPREFIX}/man/man1/${i}.1)
+.endfor
+ (cd ${WRKSRC} && ${INSTALL_MAN} cmtdefs.jman \
+ ${STAGEDIR}${MAN5PREFIX}/man/man5/cmtdefs.5)
-NO_STAGE= yes
.include <bsd.port.mk>