aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-canna/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-04-03 13:30:04 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-04-03 13:30:04 +0000
commitec67b0dfea7d9ab56b06a633114ce793e9fe8f68 (patch)
treed0012b7e6324a3fd902b30d226ba02d35b57beb3 /japanese/scim-canna/Makefile
parente541bcfae7098dd2f4eb4e071ef5433abe1c6644 (diff)
downloadports-ec67b0dfea7d9ab56b06a633114ce793e9fe8f68.tar.gz
ports-ec67b0dfea7d9ab56b06a633114ce793e9fe8f68.zip
Add scim-canna 0.0.0, is the SCIM IMEngine module using the Canna
input method. Obtained from: japanese/scim-anthy port I was cheated by: ume
Notes
Notes: svn path=/head/; revision=132345
Diffstat (limited to 'japanese/scim-canna/Makefile')
-rw-r--r--japanese/scim-canna/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/japanese/scim-canna/Makefile b/japanese/scim-canna/Makefile
new file mode 100644
index 000000000000..ef5bcedf28ff
--- /dev/null
+++ b/japanese/scim-canna/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ja-scim-canna
+# Date created: 2005-04-03
+# Whom: Norikatsu Shigemura <nork@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-canna
+PORTVERSION= 0.0.0
+CATEGORIES= japanese
+MASTER_SITES= http://www.homa.ne.jp/~ashie/linux/files/
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= SCIM IMEngine module using Canna
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= lthack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc"
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
+ @${ECHO}
+
+.include <bsd.port.post.mk>