aboutsummaryrefslogtreecommitdiff
path: root/japanese/tcsh
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-09-30 12:20:57 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-09-30 12:20:57 +0000
commit313cc21d957e3c37e0a01324c5afbfea99a499cb (patch)
treea4278de45a84b571799e421cc7ea063190e02301 /japanese/tcsh
parent8dfb405dd590da84badfe556227e2bf6e9a73dbb (diff)
downloadports-313cc21d957e3c37e0a01324c5afbfea99a499cb.tar.gz
ports-313cc21d957e3c37e0a01324c5afbfea99a499cb.zip
Update original tcsh version from 6.07.09 to 6.07.12.
PR: ports/8056 Submitted by: Issei Suzuki <issei@jp.FreeBSD.ORG>
Notes
Notes: svn path=/head/; revision=13550
Diffstat (limited to 'japanese/tcsh')
-rw-r--r--japanese/tcsh/Makefile22
-rw-r--r--japanese/tcsh/distinfo3
-rw-r--r--japanese/tcsh/files/patch-af37
-rw-r--r--japanese/tcsh/files/patch-ag6
-rw-r--r--japanese/tcsh/files/patch-aj6
-rw-r--r--japanese/tcsh/pkg-comment2
-rw-r--r--japanese/tcsh/pkg-descr4
-rw-r--r--japanese/tcsh/pkg-plist8
8 files changed, 56 insertions, 32 deletions
diff --git a/japanese/tcsh/Makefile b/japanese/tcsh/Makefile
index 3b644ba796d4..fec4f81db467 100644
--- a/japanese/tcsh/Makefile
+++ b/japanese/tcsh/Makefile
@@ -1,31 +1,23 @@
-# New ports collection makefile for: tcsh with kanji patch
-# Version required: 6.07.09
+# New ports collection makefile for: tcsh with multibyte support enabled
+# Version required: 6.07.12
# Date created: 29 November 1997
# Whom: issei <issei@jp.FreeBSD.ORG>
#
-# $Id: Makefile,v 1.4 1998/07/04 03:20:11 steve Exp $
+# $Id$
#
-DISTNAME= tcsh-6.07.09
-PKGNAME= ja-tcsh-6.07.09b5
+DISTNAME= tcsh-6.07.12
+PKGNAME= ja-tcsh-6.07.12
CATEGORIES= japanese shells
-MASTER_SITES= http://www2.wbs.ne.jp/~znc/tcsh/
-EXTRACT_SUFX= .tgz
-
-PATCH_SITES= http://www2.wbs.ne.jp/~znc/tcsh/
-PATCHFILES= ${DISTNAME}.kanji.patch7b5.gz
+MASTER_SITES= ftp://ftp.astron.com/pri/
MAINTAINER= issei@jp.FreeBSD.ORG
-PATCH_DIST_STRIP= -p1
GNU_CONFIGURE= yes
-# Ugly hack
-CONFIGURE_ARGS= --bindir=${PREFIX}/bin
ALL_TARGET= all catalogs
INSTALL_TARGET= install install.man
MAN1= tcsh.1
-PORTDOCS= complete.tcsh FAQ HISTORY.kanji.patch.euc HowToMakeNLS.euc \
- README.kanji.patch.euc
+PORTDOCS= FAQ Fixes README WishList complete.tcsh
post-install:
@(cd ${WRKSRC}; \
diff --git a/japanese/tcsh/distinfo b/japanese/tcsh/distinfo
index ae7fca635980..82c944d27021 100644
--- a/japanese/tcsh/distinfo
+++ b/japanese/tcsh/distinfo
@@ -1,2 +1 @@
-MD5 (tcsh-6.07.09.tgz) = f285baaebbb3c5f9c32425558415a798
-MD5 (tcsh-6.07.09.kanji.patch7b5.gz) = fe918113362ba0446b12269356a6e2de
+MD5 (tcsh-6.07.12.tar.gz) = 754718dc9af006d50eda615dac7f5d40
diff --git a/japanese/tcsh/files/patch-af b/japanese/tcsh/files/patch-af
index 8f14ba436c2a..63c19a4d9bd0 100644
--- a/japanese/tcsh/files/patch-af
+++ b/japanese/tcsh/files/patch-af
@@ -1,5 +1,5 @@
---- ../../tcsh-6.07.09/config_f.h Wed Jul 22 01:03:32 1998
-+++ config_f.h Wed Jul 22 01:04:17 1998
+--- config_f.h.orig Sat Sep 19 23:48:08 1998
++++ config_f.h Sat Sep 26 23:08:09 1998
@@ -65,7 +65,11 @@
* if you don't have <nl_types.h>, you don't want
* to define this.
@@ -13,3 +13,36 @@
/*
* LOGINFIRST Source ~/.login before ~/.cshrc
+@@ -117,20 +121,29 @@
+ * be used with SHORT_STRINGS
+ *
+ */
+-#undef KANJI
++#define KANJI
+
+ /*
+ * DSPMBYTE add variable "dspmbyte" and display multi-byte string at
+ * only output, when "dspmbyte" is set.
+ */
+-#undef DSPMBYTE
++#if defined(__FreeBSD__) || defined(__OpenBSD__)
++# define DSPMBYTE
++#else
++# undef DSPMBYTE
++#endif
++
+
+ /*
+ * MBYTEDEBUG when "dspmbyte" is changed, set multi-byte checktable to
+ * variable "mbytemap".
+ * (use for multi-byte table check)
+ */
+-#undef MBYTEDEBUG
++#if defined(__FreeBSD__) || defined(__OpenBSD__)
++# define MBYTEDEBUG
++#else
++# undef MBYTEDEBUG
++#endif
+
+ /*
+ * NEWGRP Provide a newgrp builtin.
diff --git a/japanese/tcsh/files/patch-ag b/japanese/tcsh/files/patch-ag
index 706fb022625f..14dec0db00a7 100644
--- a/japanese/tcsh/files/patch-ag
+++ b/japanese/tcsh/files/patch-ag
@@ -1,5 +1,5 @@
---- ../../tcsh-6.07.09/sh.func.c Wed Jul 22 01:03:33 1998
-+++ sh.func.c Wed Jul 22 01:04:47 1998
+--- sh.func.c.orig Sat Sep 19 01:09:11 1998
++++ sh.func.c Sat Sep 26 19:23:40 1998
@@ -1286,6 +1286,9 @@
struct command *c;
{
@@ -10,7 +10,7 @@
USE(c);
if (*++v == 0) {
-@@ -1338,7 +1341,15 @@
+@@ -1337,7 +1340,15 @@
# ifdef LC_MESSAGES
(void) setlocale(LC_MESSAGES, "");
# endif /* LC_MESSAGES */
diff --git a/japanese/tcsh/files/patch-aj b/japanese/tcsh/files/patch-aj
index 572623c7ffec..8567e25f325b 100644
--- a/japanese/tcsh/files/patch-aj
+++ b/japanese/tcsh/files/patch-aj
@@ -1,8 +1,8 @@
---- nls/Makefile.orig Wed Aug 19 14:21:20 1998
-+++ nls/Makefile Wed Aug 19 14:23:51 1998
+--- nls/Makefile.old Sat Sep 26 23:05:31 1998
++++ nls/Makefile Sat Sep 26 23:05:42 1998
@@ -1,5 +1,5 @@
--SUBDIRS= C german french greek spanish ja.roomi ja.koshiki ja
+-SUBDIRS= C german french italian ja greek spanish
+SUBDIRS= C
#GENCAT= gencat -new
GENCAT= gencat
diff --git a/japanese/tcsh/pkg-comment b/japanese/tcsh/pkg-comment
index b48705ad7908..f9612bb82d27 100644
--- a/japanese/tcsh/pkg-comment
+++ b/japanese/tcsh/pkg-comment
@@ -1 +1 @@
-An extended C-shell with many useful features with Japanese and color support.
+An extended C-shell with many useful features with multibyte support.
diff --git a/japanese/tcsh/pkg-descr b/japanese/tcsh/pkg-descr
index 4a6937ae5813..36dffe0615a1 100644
--- a/japanese/tcsh/pkg-descr
+++ b/japanese/tcsh/pkg-descr
@@ -2,8 +2,8 @@ TCSH is an extended C-shell with many useful features like
filename completion, history editing, etc.
This also supports
- 1. Japanese command-line editing
- 2. Japanese NLS catalogs
+ 1. Multibyte command-line editing
+ 2. Multibyte NLS catalogs
3. colorlized ls-F command
See also ${PREFIX}/share/doc/tcsh.
diff --git a/japanese/tcsh/pkg-plist b/japanese/tcsh/pkg-plist
index 8e43d8cb9568..ee3af04c02be 100644
--- a/japanese/tcsh/pkg-plist
+++ b/japanese/tcsh/pkg-plist
@@ -1,11 +1,11 @@
bin/tcsh
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
-share/doc/tcsh/complete.tcsh
share/doc/tcsh/FAQ
-share/doc/tcsh/HISTORY.kanji.patch.euc
-share/doc/tcsh/HowToMakeNLS.euc
-share/doc/tcsh/README.kanji.patch.euc
+share/doc/tcsh/Fixes
+share/doc/tcsh/README
+share/doc/tcsh/WishList
+share/doc/tcsh/complete.tcsh
@dirrm share/doc/tcsh
share/nls/C/tcsh.cat
share/nls/C/tcsh.m