aboutsummaryrefslogtreecommitdiff
path: root/japanese/texinfo/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-07 04:52:54 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-07 04:52:54 +0000
commitbb7ceb06ad0637278660036103193291a19a8209 (patch)
treecce1a30b5e34d1b04c665ebf4abf83b2fcacb1f9 /japanese/texinfo/Makefile
parent55f7f0b20127fddcf737b2afb3f209896aa327e4 (diff)
downloadports-bb7ceb06ad0637278660036103193291a19a8209.tar.gz
ports-bb7ceb06ad0637278660036103193291a19a8209.zip
Typeset Texinfo files for printing. Uses TeX (supported japanese)
PR: 13369 Submitted by: Mitsuru Yoshida <mitsuru@riken.go.jp>
Notes
Notes: svn path=/head/; revision=21349
Diffstat (limited to 'japanese/texinfo/Makefile')
-rw-r--r--japanese/texinfo/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/japanese/texinfo/Makefile b/japanese/texinfo/Makefile
new file mode 100644
index 000000000000..e53f17d32b79
--- /dev/null
+++ b/japanese/texinfo/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: texinfo
+# Version required: 3.12s
+# Date created: 18 Aug 1999
+# Whom: Mitsuru Yoshida <mitsuru@riken.go.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= texinfo-3.12s
+PKGNAME= ja-texinfo-3.12s
+CATEGORIES= japanese print
+MASTER_SITES= ftp://ftp.cs.umb.edu/private/tex/ \
+ ftp://texinfo.org/ \
+ ftp://alpha.gnu.org/gnu/gnu/ \
+ ftp://ftp.funet.fi/pub/gnu/alpha/
+
+PATCH_SITES= ftp://jupiter.fsci.fuk.kindai.ac.jp/pub/ptex/utils/ \
+ http://www.fsci.fuk.kindai.ac.jp/aftp/pub/ptex/utils/
+PATCHFILES= texinfo-3.12s-j.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= mitsuru@riken.go.jp
+
+RUN_DEPENDS= ptex:${PORTSDIR}/japanese/ptex-euc
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=j
+INSTALL_TARGET= install install-tex
+CFLAGS+= "-DEUC=1"
+MAKE_ARGS= TEXMF=${PREFIX}/share/texmf
+
+MAN1= jinfo.1 jinstall-info.1 jmakeinfo.1 jtexindex.1 jtexi2dvi.1
+MAN5= jinfo.5 jtexinfo.5
+
+.include <bsd.port.mk>