aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-09-16 12:19:44 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-09-16 12:19:44 +0000
commit069d7f97f9dc6405781060f1c8b37557e5adc33b (patch)
treee98a75466e1002d082b190bc3293e45539258036 /japanese
parent1f28ac4f9f3b288abfe0db561008444c9824b5fa (diff)
downloadports-069d7f97f9dc6405781060f1c8b37557e5adc33b.tar.gz
ports-069d7f97f9dc6405781060f1c8b37557e5adc33b.zip
Gjiten is a Japanese dictionary program for GNOME.
Gjiten also has a kanji dictionary. Any combination of stroke count, radicals and search key can be used for kanji lookups. WWW: http://gjiten.sourceforge.net/ PR: ports/171226 Submitted by: Stephane Lapie <stephane.lapie@darkbsd.org>
Notes
Notes: svn path=/head/; revision=304345
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/gjiten/Makefile80
-rw-r--r--japanese/gjiten/distinfo2
-rw-r--r--japanese/gjiten/pkg-descr6
-rw-r--r--japanese/gjiten/pkg-plist32
5 files changed, 121 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 3447ab0c2504..5cc9414f09c6 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gedy
SUBDIR += gicq
SUBDIR += gimp-help
+ SUBDIR += gjiten
SUBDIR += gorua
SUBDIR += gqmpeg
SUBDIR += grep
diff --git a/japanese/gjiten/Makefile b/japanese/gjiten/Makefile
new file mode 100644
index 000000000000..b8d215e45113
--- /dev/null
+++ b/japanese/gjiten/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: gjiten
+# Date created: 2012-09-03
+# Whom: Stephane Lapie <stephane.lapie@darkbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gjiten
+PORTVERSION= 2.6
+CATEGORIES= japanese gnome
+MASTER_SITES= http://gjiten.sourceforge.net/
+
+MAINTAINER= stephane.lapie@darkbsd.org
+COMMENT= Japanese dictionary program for GNOME
+
+OPTIONS_DEFINE= UTF8 KANJIPAD DOCS NLS
+UTF8_DESC= Use UTF-8 edict dictionaries
+KANJIPAD_DESC= Use Kanjipad
+
+USE_GNOME= gtk20 gconf2 libglade libgnomeui
+USE_GMAKE= yes
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= gjiten-doc.ja.html
+MAN1= gjiten.1
+GCONF_SCHEMAS= gjiten-dicfiles.schemas gjiten.schemas
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+MAKE_ENV+= USE_NLS=no
+.endif
+
+.if ${PORT_OPTIONS:MUTF8}
+EDICT_DIR= ${LOCALBASE}/share/dict/edict-utf-8
+EDICT_FILE= ${EDICT_DIR}/edict
+RUN_DEPENDS+= ${EDICT_FILE}:${PORTSDIR}/japanese/edict-utf-8
+.else
+EDICT_DIR= ${LOCALBASE}/share/dict/edict
+EDICT_FILE= ${EDICT_DIR}/edict
+RUN_DEPENDS+= ${EDICT_FILE}:${PORTSDIR}/japanese/edict
+BUILD_DEPENDS+= ${LOCALBASE}/bin/iconv:${PORTSDIR}/converters/libiconv
+.endif
+
+DICTIONARIES= kanjidic edict compdic
+GJITEN_DICS= ${DATADIR}/dics/
+
+.if ${PORT_OPTIONS:MKANJIPAD}
+RUN_DEPENDS+= ${LOCALBASE}/bin/kanjipad:${PORTSDIR}/japanese/kanjipad
+.endif
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xmlto:${PORTSDIR}/textproc/xmlto
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${INSTALL} -d ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/help/ja/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${INSTALL} -d ${GJITEN_DICS}
+.if ${PORT_OPTIONS:MUTF8}
+.for f in ${DICTIONARIES}
+ ${INSTALL_DATA} ${EDICT_DIR}/${f} ${GJITEN_DICS}
+.endfor
+.else
+.for f in ${DICTIONARIES}
+ ${LOCALBASE}/bin/iconv -c -f EUC-JP -t UTF-8 ${EDICT_DIR}/${f} > ${GJITEN_DICS}/${f}
+.endfor
+.endif
+ -@update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/japanese/gjiten/distinfo b/japanese/gjiten/distinfo
new file mode 100644
index 000000000000..e4eab2d1149c
--- /dev/null
+++ b/japanese/gjiten/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gjiten-2.6.tar.gz) = f6c0cc69e1e59ed8c3a946a1ee3e4a5e2e1deb16890bfc5f67c055adb10a71dd
+SIZE (gjiten-2.6.tar.gz) = 564845
diff --git a/japanese/gjiten/pkg-descr b/japanese/gjiten/pkg-descr
new file mode 100644
index 000000000000..34cd7efab755
--- /dev/null
+++ b/japanese/gjiten/pkg-descr
@@ -0,0 +1,6 @@
+Gjiten is a Japanese dictionary program for GNOME.
+
+Gjiten also has a kanji dictionary. Any combination of stroke count,
+radicals and search key can be used for kanji lookups.
+
+WWW: http://gjiten.sourceforge.net/
diff --git a/japanese/gjiten/pkg-plist b/japanese/gjiten/pkg-plist
new file mode 100644
index 000000000000..3f7c77376842
--- /dev/null
+++ b/japanese/gjiten/pkg-plist
@@ -0,0 +1,32 @@
+bin/gjiten
+share/application-registry/gjiten.desktop
+share/applications/gjiten.desktop
+%%DATADIR%%/dics/compdic
+%%DATADIR%%/dics/edict
+%%DATADIR%%/dics/kanjidic
+%%DATADIR%%/gjiten-settings.glade
+%%DATADIR%%/radkfile.utf8
+%%DATADIR%%/vconj.utf8
+share/gnome/help/gjiten/C/gjiten.xml
+share/gnome/help/gjiten/C/legal.xml
+%%NLS%%share/locale/de/LC_MESSAGES/gjiten.mo
+%%NLS%%share/locale/de_CH/LC_MESSAGES/gjiten.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gjiten.mo
+share/omf/gjiten/gjiten-C.omf
+share/pixmaps/gjiten/gjiten-logo.png
+share/pixmaps/jiten.png
+share/pixmaps/kanjidic.png
+share/pixmaps/kanjipad.png
+share/pixmaps/left_ptr_question.png
+@dirrm share/pixmaps/gjiten
+@dirrm share/omf/gjiten
+@dirrm share/gjiten/dics
+@dirrm share/gjiten
+@dirrmtry share/locale/de_CH/LC_MESSAGES
+@dirrmtry share/locale/de_CH
+@dirrmtry share/gnome/help/gjiten/C
+@dirrmtry share/gnome/help/gjiten
+@dirrmtry share/gnome/help
+@dirrmtry share/gnome
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true