aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-langpack
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-30 22:14:10 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-30 22:14:10 +0000
commit4671731e5cccdf750284d0adc5505800ca5d32ec (patch)
treea71ff5f31c575a546200b59b240dc23e436b4112 /java/eclipse-langpack
parent8cb7d5a29a51f1def07f81e20b869a930fd13c08 (diff)
downloadports-4671731e5cccdf750284d0adc5505800ca5d32ec.tar.gz
ports-4671731e5cccdf750284d0adc5505800ca5d32ec.zip
Stage java/eclipse-langpack
PR: 193088 Submitted by: turutani (Kyoto)
Notes
Notes: svn path=/head/; revision=366685
Diffstat (limited to 'java/eclipse-langpack')
-rw-r--r--java/eclipse-langpack/Makefile6
-rw-r--r--java/eclipse-langpack/files/install.sh5
-rw-r--r--java/eclipse-langpack/pkg-descr23
-rw-r--r--java/eclipse-langpack/pkg-plist3
4 files changed, 13 insertions, 24 deletions
diff --git a/java/eclipse-langpack/Makefile b/java/eclipse-langpack/Makefile
index 27770cda503d..582185143a9c 100644
--- a/java/eclipse-langpack/Makefile
+++ b/java/eclipse-langpack/Makefile
@@ -23,15 +23,13 @@ USES= zip
NO_WRKSUBDIR= yes
PLIST= ${WRKDIR}/pkg-plist
-NO_STAGE= yes
do-build:
@${RM} -f ${PLIST}
@${TOUCH} ${PLIST}
- @(cd ${WRKSRC}; ${FIND} eclipse -type f) | ${SORT} | ${SED} -e 's,^eclipse,lib/eclipse,' > ${PLIST}
+ (cd ${WRKSRC}; ${FIND} eclipse -type f) | ${SORT} | ${SED} -e 's,^eclipse,lib/eclipse,' > ${PLIST}
@${CAT} ${.CURDIR}/pkg-plist >> ${PLIST}
do-install:
- @${SETENV} ${SH} ${FILESDIR}/install.sh ${WRKSRC} \
- ${PREFIX} ${SHAREOWN} ${SHAREGRP} 0755 0644
+ ${SETENV} ${SH} ${FILESDIR}/install.sh ${WRKSRC} ${STAGEDIR}${PREFIX}
.include <bsd.port.mk>
diff --git a/java/eclipse-langpack/files/install.sh b/java/eclipse-langpack/files/install.sh
index 1ac25893a348..037ecd2d2667 100644
--- a/java/eclipse-langpack/files/install.sh
+++ b/java/eclipse-langpack/files/install.sh
@@ -1,13 +1,12 @@
#!/bin/sh
WRKDIR=$1; PREFIX=$2
-OWNER=$3; GROUP=$4; DPERM=$5; FPERM=$6
cd ${WRKDIR}
for dir in `find eclipse -type d | sort`; do
- install -d -o ${OWNER} -g ${GROUP} -m ${DPERM} ${PREFIX}/lib/${dir}
+ install -d ${PREFIX}/lib/${dir}
done
for file in `find eclipse -type f | sort`; do
- install -c -o ${OWNER} -g ${GROUP} -m ${FPERM} ${file} ${PREFIX}/lib/${file}
+ install ${file} ${PREFIX}/lib/${file}
done
diff --git a/java/eclipse-langpack/pkg-descr b/java/eclipse-langpack/pkg-descr
index cce14f474d44..654cb5c2a6ea 100644
--- a/java/eclipse-langpack/pkg-descr
+++ b/java/eclipse-langpack/pkg-descr
@@ -4,24 +4,19 @@ download which are distributed as a set of features which you can
install by extracting over your Eclipse directory and restarting
Eclipse. Specifically,
-NLpack1- Contains the NL fragments and the NL features that contain
-those fragments for: German, Spanish, French, Italian, Japanese,
-Korean, Portuguese (Brazil), Traditional Chinese and Simplified
-Chinese.
+NLpackX contains the NL fragments and the NL features that contain
+those fragments for the below languages with each X:
-NLpack2- Contains the NL fragments and the NL features that contain
-those fragments for: Czech, Hungarian, Polish and Russian.
-
-NLpack2a- Contains the NL fragments and the NL features that contain
-those fragments for: Danish, Dutch, Finnish, Greek, Norwegian,
-Portuguese, Swedish and Turkish.
-
-NLpackBidi- Contains the NL fragments and the NL features that contain
-those fragments for: Arabic and Hebrew.
+X=1: German, Spanish, French, Italian, Japanese, Korean,
+ Portuguese (Brazil), Traditional Chinese and Simplified Chinese.
+X=2: Czech, Hungarian, Polish and Russian.
+X=2a: Danish, Dutch, Finnish, Greek, Norwegian, Portuguese,
+ Swedish and Turkish.
+X=Bidi: Arabic and Hebrew.
These translations are based on the Eclipse 3.2 build but should work
with all subsequent 3.2.x maintenance releases. If new strings are
added to Eclipse after 3.2, they will not show up as translated in the
3.2.x stream when you install this language pack.
-http://download.eclipse.org/eclipse/downloads/drops/L-3.2.1_Language_Packs-200609210945/index.php
+WWW: http://www.eclipse.org/downloads/
diff --git a/java/eclipse-langpack/pkg-plist b/java/eclipse-langpack/pkg-plist
index afe1bef9fec5..1cf2fb21228e 100644
--- a/java/eclipse-langpack/pkg-plist
+++ b/java/eclipse-langpack/pkg-plist
@@ -384,7 +384,6 @@
@dirrm lib/eclipse/plugins/com.ibm.icu.source.nl2_3.4.5.v200609270227
@dirrm lib/eclipse/plugins/com.ibm.icu.source.nl1_3.4.5.v200609270227/META-INF
@dirrm lib/eclipse/plugins/com.ibm.icu.source.nl1_3.4.5.v200609270227
-@dirrmtry lib/eclipse/plugins
@dirrm lib/eclipse/features/org.eclipse.sdk.nlsBidi_3.2.1.v200609270227
@dirrm lib/eclipse/features/org.eclipse.sdk.nls2a_3.2.1.v200609270227
@dirrm lib/eclipse/features/org.eclipse.sdk.nls2_3.2.1.v200609270227
@@ -421,5 +420,3 @@
@dirrm lib/eclipse/features/org.eclipse.jdt.nls2a_3.2.1.v200609270227
@dirrm lib/eclipse/features/org.eclipse.jdt.nls2_3.2.1.v200609270227
@dirrm lib/eclipse/features/org.eclipse.jdt.nls1_3.2.1.v200609270227
-@dirrmtry lib/eclipse/features
-@dirrmtry lib/eclipse